mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Harry Yoo <harry@kernel.org>
To: Vladimir Zapolskiy <vladimir.zapolskiy@linaro.org>,
	Vlastimil Babka <vbabka@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Christoph Lameter <cl@gentwo.org>, Hao Li <hao.li@linux.dev>
Cc: David Rientjes <rientjes@google.com>,
	Roman Gushchin <roman.gushchin@linux.dev>,
	Hugh Dickins <hugh@veritas.com>,
	linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] mm/slab: fix probable issue of dentries registration under /sys/kernel/slab
Date: Wed, 20 May 2026 12:42:02 +0900	[thread overview]
Message-ID: <8a80496b-1568-4a0b-a878-836c27d19ad5@kernel.org> (raw)
In-Reply-To: <20260520011019.1707010-1-vladimir.zapolskiy@linaro.org>



On 5/20/26 10:10 AM, Vladimir Zapolskiy wrote:
> L2TP/IP and L2TP/IPv6 protocol names contain a slash symbol, however these
> names are blindly used as symlinks to slab cache objects registered under
> /sys/kernel/slab. This kind of symlink creation is successful, but its
> dentry is obviously broken, as well it breaks the access to the list of
> /sys/kernel/slab dentries.

Oops. I just loaded l2tp_ip module and it indeed broke it.

$ ls
ls: reading directory '.': Input/output error
:0000136/                        kmalloc-rnd-01-16/   kmalloc-rnd-15-32/
:0000192/                        kmalloc-rnd-02-512/  memdup_user-32/
:0000560/                        kmalloc-rnd-06-192/  memdup_user-4k/
:0000768/                        kmalloc-rnd-06-512/  pde_opener@
:a-0000168/                      kmalloc-rnd-07-4k/   pidfs_xattr_cache@
:A-0000184/                      kmalloc-rnd-11-8/    RAWv6/
audit_buffer@                    kmalloc-rnd-11-96/   rpc_inode_cache/
configfs_dir_cache@              kmalloc-rnd-12-4k/   task_delay_info@
ecryptfs_global_auth_tok_cache@  kmalloc-rnd-13-128/  TCPv6/
fscache_cookie_jar@              kmalloc-rnd-14-96/
io_kiocb/                        kmalloc-rnd-15-2k/

> Likely L2TP protocol renames cannot be done, since the defined protocol
> names are exposed over /proc/net/protocols for years, but the symlink
> names can be renamed, because they are yet to be properly created, and
> this should be eventually done by this change.
> 
> The problem manifests itself, if CONFIG_L2TP_IP build symbol is selected.
> 
> Fixes: 81819f0fc8285 ("SLUB core")
> Signed-off-by: Vladimir Zapolskiy <vladimir.zapolskiy@linaro.org>
> ---

There is also a debugfs feature that would cause a similar issue.
Can we replace '/' in the cache name, without renaming the protocol name?

-- 
Cheers,
Harry / Hyeonggon


  parent reply	other threads:[~2026-05-20  3:42 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-20  1:10 Vladimir Zapolskiy
2026-05-20  3:21 ` Hao Li
2026-05-20  8:49   ` Vladimir Zapolskiy
2026-05-20  3:42 ` Harry Yoo [this message]
2026-05-21 11:24   ` Vladimir Zapolskiy
2026-05-22  1:31     ` Harry Yoo
2026-05-22  2:11       ` Harry Yoo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8a80496b-1568-4a0b-a878-836c27d19ad5@kernel.org \
    --to=harry@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=cl@gentwo.org \
    --cc=hao.li@linux.dev \
    --cc=hugh@veritas.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=rientjes@google.com \
    --cc=roman.gushchin@linux.dev \
    --cc=vbabka@kernel.org \
    --cc=vladimir.zapolskiy@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome