From: "Dwivedi, Avaneesh Kumar (avani)" <akdwived@codeaurora.org>
To: Bjorn Andersson <bjorn.andersson@linaro.org>
Cc: sboyd@codeaurora.org, agross@codeaurora.org,
linux-arm-msm@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-remoteproc@vger.kernel.org
Subject: Re: [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and px regulator resource.
Date: Tue, 31 Jan 2017 11:28:59 +0530 [thread overview]
Message-ID: <8e0d5e13-3d91-0f00-ee1d-dae70370b30d@codeaurora.org> (raw)
In-Reply-To: <20170130214657.GB31134@builder>
On 1/31/2017 3:16 AM, Bjorn Andersson wrote:
> On Mon 30 Jan 07:03 PST 2017, Avaneesh Kumar Dwivedi wrote:
>
>> This patch add additional clock and regulator resource which are
>> initialized based on compatible and has no impact on existing driver
>> working. This resourse addition enable the existing driver to handle.
>> low pass sensor processor device also.
>>
>> Signed-off-by: Avaneesh Kumar Dwivedi <akdwived@codeaurora.org>
> Applied, with below modification.
Thanks Bjorn, but please look below inline comment.
>> ---
>> drivers/remoteproc/qcom_adsp_pil.c | 43 +++++++++++++++++++++++++++++++-------
>> 1 file changed, 36 insertions(+), 7 deletions(-)
>>
>> diff --git a/drivers/remoteproc/qcom_adsp_pil.c b/drivers/remoteproc/qcom_adsp_pil.c
> [..]
>> static int adsp_init_regulator(struct qcom_adsp *adsp)
>> {
>> - adsp->cx_supply = devm_regulator_get(adsp->dev, "cx");
>> + adsp->cx_supply = devm_regulator_get(adsp->dev, "vdd_cx");
> We should not change the name of devicetree properties, so I dropped
> "vdd_" on both of these.
I observed that giving "cx" or "px" string to devm_regulator_get() was
returning with dummy regulator, and if i gave "vdd_cx" and "vdd_px" it
did not print dummy regulator warning.
in device tree these regulators node were defined as "vdd_cx-supply" and
"vdd_px-supply"
>
>> if (IS_ERR(adsp->cx_supply))
>> return PTR_ERR(adsp->cx_supply);
>>
>> regulator_set_load(adsp->cx_supply, 100000);
>>
>> + adsp->px_supply = devm_regulator_get(adsp->dev, "vdd_px");
>> + if (IS_ERR(adsp->px_supply))
>> + return PTR_ERR(adsp->px_supply);
> Regards,
> Bjorn
--
Qualcomm India Private Limited, on behalf of Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
a Linux Foundation Collaborative Project.
next prev parent reply other threads:[~2017-01-31 6:07 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-01-30 15:03 [PATCH v3 0/4]remoteproc: qcom: Add support for Qualcomm low pass sensor peripheral loader Avaneesh Kumar Dwivedi
2017-01-30 15:03 ` [PATCH v3 1/4] remoteproc: qcom: Compatible string based resource initialization Avaneesh Kumar Dwivedi
2017-01-30 21:45 ` Bjorn Andersson
2017-01-30 15:03 ` [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and px regulator resource Avaneesh Kumar Dwivedi
2017-01-30 21:46 ` Bjorn Andersson
2017-01-31 5:58 ` Dwivedi, Avaneesh Kumar (avani) [this message]
2017-01-31 6:05 ` Bjorn Andersson
2017-01-30 15:03 ` [PATCH v3 3/4] remoteproc: qcom: Add SLPI rproc support to load and boot slpi proc Avaneesh Kumar Dwivedi
2017-01-30 21:50 ` Bjorn Andersson
2017-01-30 15:03 ` [PATCH v3 4/4] arm64: dts: msm8996: Add SLPI SMP2P dt node Avaneesh Kumar Dwivedi
2017-01-31 1:33 ` Bjorn Andersson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8e0d5e13-3d91-0f00-ee1d-dae70370b30d@codeaurora.org \
--to=akdwived@codeaurora.org \
--cc=agross@codeaurora.org \
--cc=bjorn.andersson@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=sboyd@codeaurora.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome