mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v1] s390/ap: Drop unused member from ap_device_id
@ 2026-08-06 15:57 Uwe Kleine-König (The Capable Hub)
  2026-08-06 16:21 ` [PATCH v2] " Uwe Kleine-König (The Capable Hub)
  2026-08-13 14:55 ` [PATCH v1] " Harald Freudenberger
  0 siblings, 2 replies; 4+ messages in thread
From: Uwe Kleine-König (The Capable Hub) @ 2026-08-06 15:57 UTC (permalink / raw)
  To: Harald Freudenberger, Holger Dengler
  Cc: Heiko Carstens, Vasily Gorbik, Alexander Gordeev,
	Christian Borntraeger, Sven Schnelle, linux-s390, linux-kernel,
	Pawel Zalewski

ap_device_id::device_info is not used in the kernel. The structure is
also not part of API/ABI, so the unused member can just be dropped.

Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
---
 include/linux/device-id/ap.h | 1 -
 1 file changed, 1 deletion(-)

diff --git a/include/linux/device-id/ap.h b/include/linux/device-id/ap.h
index 0992333a34db..011af33c0bcf 100644
--- a/include/linux/device-id/ap.h
+++ b/include/linux/device-id/ap.h
@@ -14,7 +14,6 @@ typedef unsigned long kernel_ulong_t;
 struct ap_device_id {
 	__u16 match_flags;	/* which fields to match against */
 	__u8 dev_type;		/* device type */
-	kernel_ulong_t driver_info;
 };
 
 #endif /* ifndef LINUX_DEVICE_ID_AP_H */

base-commit: 1701fda2f58e345c050f4309971bdc07cd6146ba
-- 
2.55.0.11.g153666a7d9bb


^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH v2] s390/ap: Drop unused member from ap_device_id
  2026-08-06 15:57 [PATCH v1] s390/ap: Drop unused member from ap_device_id Uwe Kleine-König (The Capable Hub)
@ 2026-08-06 16:21 ` Uwe Kleine-König (The Capable Hub)
  2026-08-10  8:40   ` Holger Dengler
  2026-08-13 14:55 ` [PATCH v1] " Harald Freudenberger
  1 sibling, 1 reply; 4+ messages in thread
From: Uwe Kleine-König (The Capable Hub) @ 2026-08-06 16:21 UTC (permalink / raw)
  To: Harald Freudenberger, Holger Dengler
  Cc: Heiko Carstens, Vasily Gorbik, Alexander Gordeev,
	Christian Borntraeger, Sven Schnelle, linux-s390, linux-kernel,
	Pawel Zalewski

ap_device_id::driver_info is not used in the kernel. The structure is
also not part of API/ABI, so the unused member can just be dropped.

Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
---
Hello,

Sashiko was quick to identify two issues in my patch. Before someone
gets around to review v1 by hand, here is a v2 addressing Sashiko's
concerns:

 - remove the typedef for kernel_ulong_t
 - s/device_info/driver_info/ in the commit log

Thanks
Uwe

 include/linux/device-id/ap.h | 2 --
 1 file changed, 2 deletions(-)

diff --git a/include/linux/device-id/ap.h b/include/linux/device-id/ap.h
index 0992333a34db..e050abebbf3d 100644
--- a/include/linux/device-id/ap.h
+++ b/include/linux/device-id/ap.h
@@ -4,7 +4,6 @@
 
 #ifdef __KERNEL__
 #include <linux/types.h>
-typedef unsigned long kernel_ulong_t;
 #endif
 
 #define AP_DEVICE_ID_MATCH_CARD_TYPE		0x01
@@ -14,7 +13,6 @@ typedef unsigned long kernel_ulong_t;
 struct ap_device_id {
 	__u16 match_flags;	/* which fields to match against */
 	__u8 dev_type;		/* device type */
-	kernel_ulong_t driver_info;
 };
 
 #endif /* ifndef LINUX_DEVICE_ID_AP_H */

base-commit: 1701fda2f58e345c050f4309971bdc07cd6146ba
-- 
2.55.0.11.g153666a7d9bb


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] s390/ap: Drop unused member from ap_device_id
  2026-08-06 16:21 ` [PATCH v2] " Uwe Kleine-König (The Capable Hub)
@ 2026-08-10  8:40   ` Holger Dengler
  0 siblings, 0 replies; 4+ messages in thread
From: Holger Dengler @ 2026-08-10  8:40 UTC (permalink / raw)
  To: Uwe Kleine-König (The Capable Hub)
  Cc: Harald Freudenberger, Heiko Carstens, Vasily Gorbik,
	Alexander Gordeev, Christian Borntraeger, Sven Schnelle,
	linux-s390, linux-kernel, Pawel Zalewski

On 8/6/26 18:21, Uwe Kleine-König (The Capable Hub) wrote:
> ap_device_id::driver_info is not used in the kernel. The structure is
> also not part of API/ABI, so the unused member can just be dropped.
> 
> Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>

Acked-by: Holger Dengler <dengler@linux.ibm.com>

-- 
Mit freundlichen Grüßen / Kind regards
Holger Dengler


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v1] s390/ap: Drop unused member from ap_device_id
  2026-08-06 15:57 [PATCH v1] s390/ap: Drop unused member from ap_device_id Uwe Kleine-König (The Capable Hub)
  2026-08-06 16:21 ` [PATCH v2] " Uwe Kleine-König (The Capable Hub)
@ 2026-08-13 14:55 ` Harald Freudenberger
  1 sibling, 0 replies; 4+ messages in thread
From: Harald Freudenberger @ 2026-08-13 14:55 UTC (permalink / raw)
  To: Uwe Kleine-König (The Capable Hub)
  Cc: Holger Dengler, Heiko Carstens, Vasily Gorbik, Alexander Gordeev,
	Christian Borntraeger, Sven Schnelle, linux-s390, linux-kernel,
	Pawel Zalewski

On 2026-08-06 17:57, Uwe Kleine-König wrote:
> ap_device_id::device_info is not used in the kernel. The structure is
> also not part of API/ABI, so the unused member can just be dropped.
> 
> Signed-off-by: Uwe Kleine-König (The Capable Hub) 
> <u.kleine-koenig@baylibre.com>
> ---
>  include/linux/device-id/ap.h | 1 -
>  1 file changed, 1 deletion(-)
> 
> diff --git a/include/linux/device-id/ap.h 
> b/include/linux/device-id/ap.h
> index 0992333a34db..011af33c0bcf 100644
> --- a/include/linux/device-id/ap.h
> +++ b/include/linux/device-id/ap.h
> @@ -14,7 +14,6 @@ typedef unsigned long kernel_ulong_t;
>  struct ap_device_id {
>  	__u16 match_flags;	/* which fields to match against */
>  	__u8 dev_type;		/* device type */
> -	kernel_ulong_t driver_info;
>  };
> 
>  #endif /* ifndef LINUX_DEVICE_ID_AP_H */
> 
> base-commit: 1701fda2f58e345c050f4309971bdc07cd6146ba

Reviewed-by: Harald Freudenberger <freude@linux.ibm.com>

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2026-08-13 14:55 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-08-06 15:57 [PATCH v1] s390/ap: Drop unused member from ap_device_id Uwe Kleine-König (The Capable Hub)
2026-08-06 16:21 ` [PATCH v2] " Uwe Kleine-König (The Capable Hub)
2026-08-10  8:40   ` Holger Dengler
2026-08-13 14:55 ` [PATCH v1] " Harald Freudenberger

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®