From: zhenwei pi <pizhenwei@bytedance.com>
To: "Michael S. Tsirkin" <mst@redhat.com>
Cc: stefanha@redhat.com, jasowang@redhat.com,
xuanzhuo@linux.alibaba.com,
virtualization@lists.linux-foundation.org,
linux-kernel@vger.kernel.org
Subject: Re: Re: Re: [PATCH v2 0/2] virtio: abstract virtqueue related methods
Date: Wed, 17 May 2023 12:58:10 +0800 [thread overview]
Message-ID: <949dd4db-89ea-4331-5fa7-700f96874ab3@bytedance.com> (raw)
In-Reply-To: <20230516235541-mutt-send-email-mst@kernel.org>
On 5/17/23 11:57, Michael S. Tsirkin wrote:
> On Wed, May 17, 2023 at 11:51:03AM +0800, zhenwei pi wrote:
>>
>>
>> On 5/17/23 11:46, Michael S. Tsirkin wrote:
>>> On Wed, May 17, 2023 at 10:54:22AM +0800, zhenwei pi wrote:
>>>> v1 -> v2:
>>>> - Suggested by MST, use fast path for vring based performance
>>>> sensitive API.
>>>> - Reduce changes in tools/virtio.
>>>>
>>>> Add test result(no obvious change):
>>>> Before:
>>>> time ./vringh_test --parallel
>>>> Using CPUS 0 and 191
>>>> Guest: notified 10036893, pinged 68278
>>>> Host: notified 68278, pinged 3093532
>>>>
>>>> real 0m14.463s
>>>> user 0m6.437s
>>>> sys 0m8.010s
>>>>
>>>> After:
>>>> time ./vringh_test --parallel
>>>> Using CPUS 0 and 191
>>>> Guest: notified 10036709, pinged 68347
>>>> Host: notified 68347, pinged 3085292
>>>>
>>>> real 0m14.196s
>>>> user 0m6.289s
>>>> sys 0m7.885s
>>>>
>>>> v1:
>>>> Hi,
>>>>
>>>> 3 weeks ago, I posted a proposal 'Virtio Over Fabrics':
>>>> https://lists.oasis-open.org/archives/virtio-comment/202304/msg00442.html
>>>>
>>>> Jason and Stefan pointed out that a non-vring based virtqueue has a
>>>> chance to overwrite virtqueue instead of using vring virtqueue.
>>>>
>>>> Then I try to abstract virtqueue related methods in this series, the
>>>> details changes see the comment of patch 'virtio: abstract virtqueue related methods'.
>>>>
>>>> Something is still remained:
>>>> - __virtqueue_break/__virtqueue_unbreak is supposed to use by internal
>>>> virtio core, I'd like to rename them to vring_virtqueue_break
>>>> /vring_virtqueue_unbreak. Is this reasonable?
>>>
>>> Why? These just set a flag?
>>>
>>
>> Rename '__virtqueue_break' to 'vring_virtqueue_break', to make symbols
>> exported from virtio_ring.ko have unified prefix 'vring_virtqueue_xxx'.
>
> I just do not see why you need these callbacks at all.
>
I use these callbacks for break/unbreak device like:
static inline void virtio_break_device(struct virtio_device *dev)
{
struct virtqueue *vq;
spin_lock(&dev->vqs_list_lock);
list_for_each_entry(vq, &dev->vqs, list) {
vq->__break(vq);
}
spin_unlock(&dev->vqs_list_lock);
}
>>>> - virtqueue_get_desc_addr/virtqueue_get_avail_addr/virtqueue_get_used_addr
>>>> /virtqueue_get_vring is vring specific, I'd like to rename them like
>>>> vring_virtqueue_get_desc_addr. Is this reasonable?
>>>> - there are still some functions in virtio_ring.c with prefix *virtqueue*,
>>>> for example 'virtqueue_add_split', just keep it or rename it to
>>>> 'vring_virtqueue_add_split'?
>>>> zhenwei pi (2):
>>>> virtio: abstract virtqueue related methods
>>>> tools/virtio: implement virtqueue in test
>>>>
>>>> drivers/virtio/virtio_ring.c | 285 +++++-----------------
>>>> include/linux/virtio.h | 441 +++++++++++++++++++++++++++++++----
>>>> include/linux/virtio_ring.h | 26 +++
>>>> tools/virtio/linux/virtio.h | 355 +++++++++++++++++++++++++---
>>>> 4 files changed, 807 insertions(+), 300 deletions(-)
>>>>
>>>> --
>>>> 2.20.1
>>>
>>
>> --
>> zhenwei pi
>
--
zhenwei pi
next prev parent reply other threads:[~2023-05-17 5:01 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-17 2:54 zhenwei pi
2023-05-17 2:54 ` [PATCH v2 1/2] " zhenwei pi
2023-05-17 6:57 ` kernel test robot
2023-05-17 7:10 ` kernel test robot
2023-05-17 7:39 ` Christoph Hellwig
2023-05-17 7:43 ` zhenwei pi
2023-05-17 7:46 ` Christoph Hellwig
2023-05-17 8:35 ` zhenwei pi
2023-05-17 10:39 ` Michael S. Tsirkin
2023-05-18 0:47 ` zhenwei pi
2023-05-18 10:09 ` Michael S. Tsirkin
2023-05-18 11:01 ` zhenwei pi
2023-05-17 17:59 ` kernel test robot
2023-05-17 2:54 ` [PATCH v2 2/2] tools/virtio: implement virtqueue in test zhenwei pi
2023-05-17 3:46 ` [PATCH v2 0/2] virtio: abstract virtqueue related methods Michael S. Tsirkin
2023-05-17 3:51 ` zhenwei pi
2023-05-17 3:57 ` Michael S. Tsirkin
2023-05-17 4:58 ` zhenwei pi [this message]
2023-05-17 6:10 ` Michael S. Tsirkin
2023-05-17 6:21 ` zhenwei pi
2023-05-17 10:13 ` Michael S. Tsirkin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=949dd4db-89ea-4331-5fa7-700f96874ab3@bytedance.com \
--to=pizhenwei@bytedance.com \
--cc=jasowang@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mst@redhat.com \
--cc=stefanha@redhat.com \
--cc=virtualization@lists.linux-foundation.org \
--cc=xuanzhuo@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®