From: "Jesper Juhl" <jesper.juhl@gmail.com>
To: "Andrew Morton" <akpm@osdl.org>
Cc: pj@sgi.com, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 01/12] making the kernel -Wshadow clean - fix mconf
Date: Sun, 30 Jul 2006 21:17:18 +0200 [thread overview]
Message-ID: <9a8748490607301217g1edad85dre8a45457c57bee35@mail.gmail.com> (raw)
In-Reply-To: <20060730120631.9ee1ab09.akpm@osdl.org>
On 30/07/06, Andrew Morton <akpm@osdl.org> wrote:
> On Sun, 30 Jul 2006 20:48:23 +0200
> "Jesper Juhl" <jesper.juhl@gmail.com> wrote:
>
> > > Perhaps I am misreading this patch set?
> > >
> > i don't think you are. It's just that I want to take the least
> > intrusive route *now*, make us -Wshadow clean, get -Wshadow to be an
> > accepted part of the Makefile, *then* deal with the more
> > intrusive/controversial renamings, where I guess you'd have done
> > things in the opposite order - right?
>
> yup. Experience tells us that it's better to get things right first time,
> because we don't get around to doing the intended second pass
I believe my (modest) track record would show that I do follow up on
these things...
But anyway, I believe the renames I've done are not bad one way or the
other and should be acceptable (and some of the long names for local
symbols are chosen based on maintainer feedback even)... but I'll
await more feedback and change the patches if needed.
> (looks at
> lock_cpu_hotplug())
>
Hmm, I'll take a look at lock_cpu_hotplug() - can you provide
additional details?
> That being said, no, we can't go and rename up(). Let us go through the
> patches one-at-a-time..
>
i figured as much. *But* won't you agree that up_sem() (or considering
the other locking function names, sem_up() would probably be better)
would be a much better name for a global like this one?
How about a plan like this:
We introduce sem_up() and sem_down() wrapper functions now. They could
go into 2.6.19 for example - and also add a note to
feature-removal-schedule.txt that the old function names will be
removed in 1 year. Then in a few kernel versions - say 2.6.21 - we
deprecate the old names and add a big fac comment in the source as
well.
Wouldn't that be doable? Or do we have to live with up()/down() forever?
--
Jesper Juhl <jesper.juhl@gmail.com>
Don't top-post http://www.catb.org/~esr/jargon/html/T/top-post.html
Plain text mails only, please http://www.expita.com/nomime.html
next prev parent reply other threads:[~2006-07-30 19:17 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-07-30 16:30 [PATCH 00/12] making the kernel -Wshadow clean - The initial step Jesper Juhl
2006-07-30 16:35 ` [PATCH 01/12] making the kernel -Wshadow clean - fix mconf Jesper Juhl
2006-07-30 18:34 ` Paul Jackson
2006-07-30 18:48 ` Jesper Juhl
2006-07-30 19:06 ` Andrew Morton
2006-07-30 19:17 ` Jesper Juhl [this message]
2006-07-30 19:51 ` Andrew Morton
2006-07-30 19:57 ` Arjan van de Ven
2006-07-30 20:03 ` Jesper Juhl
2006-07-30 19:32 ` Paul Jackson
2006-07-30 23:41 ` Arnd Bergmann
2006-07-31 15:41 ` Horst H. von Brand
2006-07-31 16:04 ` H. Peter Anvin
2006-07-30 16:36 ` [PATCH 02/12] making the kernel -Wshadow clean - fix lxdialog Jesper Juhl
2006-07-30 16:37 ` [PATCH 03/12] making the kernel -Wshadow clean - fix jiffies.h Jesper Juhl
2006-07-30 16:38 ` [PATCH 04/12] making the kernel -Wshadow clean - warnings related to 'up' Jesper Juhl
2006-07-30 16:38 ` [PATCH 05/12] making the kernel -Wshadow clean - warnings related to wbc and map_bh Jesper Juhl
2006-07-30 16:39 ` [PATCH 06/12] making the kernel -Wshadow clean - fix checksum Jesper Juhl
2006-07-30 16:40 ` [PATCH 07/12] making the kernel -Wshadow clean - fix vgacon Jesper Juhl
2006-07-30 16:41 ` [PATCH 08/12] making the kernel -Wshadow clean - fix keyboard.c Jesper Juhl
2006-07-30 16:42 ` [PATCH 09/12] making the kernel -Wshadow clean - neighbour.h and 'proc_handler' Jesper Juhl
2006-07-30 16:42 ` [PATCH 10/12] making the kernel -Wshadow clean - mm/truncate.c Jesper Juhl
2006-07-30 16:43 ` [PATCH 11/12] making the kernel -Wshadow clean - USB & completion Jesper Juhl
2006-07-30 16:44 ` [PATCH 12/12] making the kernel -Wshadow clean - 'irq' shadows local and global Jesper Juhl
2006-07-30 16:54 ` [PATCH 00/12] making the kernel -Wshadow clean - The initial step Krzysztof Halasa
2006-07-30 17:14 ` Jesper Juhl
2006-07-30 17:27 ` Krzysztof Halasa
2006-07-30 18:29 ` Andrew Morton
2006-07-30 23:36 ` Arnd Bergmann
2006-08-01 6:17 ` Jan Engelhardt
2006-07-30 19:24 ` Jesper Juhl
2006-07-30 20:09 ` Jan-Benedict Glaw
2006-07-30 19:29 ` Sam Ravnborg
2006-07-30 19:39 ` Jesper Juhl
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9a8748490607301217g1edad85dre8a45457c57bee35@mail.gmail.com \
--to=jesper.juhl@gmail.com \
--cc=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pj@sgi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®