mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Krzysztof Halasa <khc@pm.waw.pl>
To: "Jesper Juhl" <jesper.juhl@gmail.com>
Cc: linux-kernel@vger.kernel.org, "Andrew Morton" <akpm@osdl.org>,
	"Nikita Danilov" <nikita@clusterfs.com>,
	"Joe Perches" <joe@perches.com>,
	"Martin Waitz" <tali@admingilde.org>,
	"Jan-Benedict Glaw" <jbglaw@lug-owl.de>,
	"Christoph Hellwig" <hch@infradead.org>,
	"David Woodhouse" <dwmw2@infradead.org>,
	"Arjan van de Ven" <arjan@infradead.org>,
	"Dmitry Torokhov" <dmitry.torokhov@gmail.com>,
	"Valdis Kletnieks" <Valdis.Kletnieks@vt.edu>,
	"Sam Ravnborg" <sam@ravnborg.org>,
	"Russell King" <rmk@arm.linux.org.uk>,
	"Rusty Russell" <rusty@rustcorp.com.au>,
	"Randy Dunlap" <rdunlap@xenotime.net>
Subject: Re: [PATCH 00/12] making the kernel -Wshadow clean - The initial step
Date: Sun, 30 Jul 2006 19:27:36 +0200	[thread overview]
Message-ID: <m3wt9vj94n.fsf@defiant.localdomain> (raw)
In-Reply-To: <9a8748490607301014rf04b6cew9d991635a7834277@mail.gmail.com> (Jesper Juhl's message of "Sun, 30 Jul 2006 19:14:06 +0200")

"Jesper Juhl" <jesper.juhl@gmail.com> writes:

> I think it's a good thing that we have to take a little more care when
> choosing global function and variable names... Take up() for example -
> in my (very humble) oppinion that is a very bad name for a global
> function - it clashes too easily with local function and variable
> names, and a programmer who's not careful may end up calling the
> global up() when he wants the local and vice versa (a much better name
> would have been sem_up() - should we change that???).

Possibly, but it could then conflict with something else. Anytime we
add/change some global symbol, we would have to scan entire kernel
for conflicts (authors of (yet) off-tree things would hate us).
I don't think it's practical, especially with, IMHO, no real gain.

> I don't agree with you and I don't know how to convince you, but I
> still appreciate your feedback.
> Thanks.

You're welcome. I'd be more happy if I could say I like the idea :-(

> I'll leave it to people higher in the hierarchy to decide if these
> patches should be applied or not ;)

Sure.
-- 
Krzysztof Halasa

  reply	other threads:[~2006-07-30 17:27 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-07-30 16:30 Jesper Juhl
2006-07-30 16:35 ` [PATCH 01/12] making the kernel -Wshadow clean - fix mconf Jesper Juhl
2006-07-30 18:34   ` Paul Jackson
2006-07-30 18:48     ` Jesper Juhl
2006-07-30 19:06       ` Andrew Morton
2006-07-30 19:17         ` Jesper Juhl
2006-07-30 19:51           ` Andrew Morton
2006-07-30 19:57             ` Arjan van de Ven
2006-07-30 20:03             ` Jesper Juhl
2006-07-30 19:32         ` Paul Jackson
2006-07-30 23:41       ` Arnd Bergmann
2006-07-31 15:41       ` Horst H. von Brand
2006-07-31 16:04         ` H. Peter Anvin
2006-07-30 16:36 ` [PATCH 02/12] making the kernel -Wshadow clean - fix lxdialog Jesper Juhl
2006-07-30 16:37 ` [PATCH 03/12] making the kernel -Wshadow clean - fix jiffies.h Jesper Juhl
2006-07-30 16:38 ` [PATCH 04/12] making the kernel -Wshadow clean - warnings related to 'up' Jesper Juhl
2006-07-30 16:38 ` [PATCH 05/12] making the kernel -Wshadow clean - warnings related to wbc and map_bh Jesper Juhl
2006-07-30 16:39 ` [PATCH 06/12] making the kernel -Wshadow clean - fix checksum Jesper Juhl
2006-07-30 16:40 ` [PATCH 07/12] making the kernel -Wshadow clean - fix vgacon Jesper Juhl
2006-07-30 16:41 ` [PATCH 08/12] making the kernel -Wshadow clean - fix keyboard.c Jesper Juhl
2006-07-30 16:42 ` [PATCH 09/12] making the kernel -Wshadow clean - neighbour.h and 'proc_handler' Jesper Juhl
2006-07-30 16:42 ` [PATCH 10/12] making the kernel -Wshadow clean - mm/truncate.c Jesper Juhl
2006-07-30 16:43 ` [PATCH 11/12] making the kernel -Wshadow clean - USB & completion Jesper Juhl
2006-07-30 16:44 ` [PATCH 12/12] making the kernel -Wshadow clean - 'irq' shadows local and global Jesper Juhl
2006-07-30 16:54 ` [PATCH 00/12] making the kernel -Wshadow clean - The initial step Krzysztof Halasa
2006-07-30 17:14   ` Jesper Juhl
2006-07-30 17:27     ` Krzysztof Halasa [this message]
2006-07-30 18:29       ` Andrew Morton
2006-07-30 23:36         ` Arnd Bergmann
2006-08-01  6:17       ` Jan Engelhardt
2006-07-30 19:24 ` Jesper Juhl
2006-07-30 20:09   ` Jan-Benedict Glaw
2006-07-30 19:29 ` Sam Ravnborg
2006-07-30 19:39   ` Jesper Juhl

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=m3wt9vj94n.fsf@defiant.localdomain \
    --to=khc@pm.waw.pl \
    --cc=Valdis.Kletnieks@vt.edu \
    --cc=akpm@osdl.org \
    --cc=arjan@infradead.org \
    --cc=dmitry.torokhov@gmail.com \
    --cc=dwmw2@infradead.org \
    --cc=hch@infradead.org \
    --cc=jbglaw@lug-owl.de \
    --cc=jesper.juhl@gmail.com \
    --cc=joe@perches.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nikita@clusterfs.com \
    --cc=rdunlap@xenotime.net \
    --cc=rmk@arm.linux.org.uk \
    --cc=rusty@rustcorp.com.au \
    --cc=sam@ravnborg.org \
    --cc=tali@admingilde.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome