From: Sohil Mehta <sohil.mehta@intel.com>
To: Dave Hansen <dave.hansen@linux.intel.com>,
<linux-kernel@vger.kernel.org>
Cc: Borislav Petkov <bp@alien8.de>, "H. Peter Anvin" <hpa@zytor.com>,
"Ingo Molnar" <mingo@redhat.com>, Jon Kohler <jon@nutanix.com>,
Pawan Gupta <pawan.kumar.gupta@linux.intel.com>,
"Peter Zijlstra (Intel)" <peterz@infradead.org>,
Thomas Gleixner <tglx@kernel.org>,
Tony Luck <tony.luck@intel.com>, <x86@kernel.org>
Subject: Re: [PATCH 3/6] x86/microcode: Refactor platform ID enumeration into a helper
Date: Thu, 22 Jan 2026 11:26:17 -0800 [thread overview]
Message-ID: <9f397b71-54c7-4cf9-8c93-515f909404ae@intel.com> (raw)
In-Reply-To: <20260119195053.E0850F99@davehans-spike.ostc.intel.com>
On 1/19/2026 11:50 AM, Dave Hansen wrote:
> +static inline u32 intel_get_platform_id(void)
> +{
> + unsigned int val[2];
> +
> + /*
> + * This can be called early. Use CPUID directly to
> + * generate the VFM value for this CPU.
> + */
> + if (intel_cpuid_vfm() < INTEL_PENTIUM_III_DESCHUTES)
> + return 0;
> +
> + /* get processor flags from MSR 0x17 */
> + native_rdmsr(MSR_IA32_PLATFORM_ID, val[0], val[1]);
> + return 1 << ((val[1] >> 18) & 7);
> +}
Would it be better to use a *native_rdmsrq* and proper #defines instead
of passing the two ints and operating on them using magic values?
I understand the desire to keep this bugfix series as minimal as
possible. But doing this now makes it easier to understand this helper
and what it is returning exactly. That would avoid the confusion in
patch 4 between x86_platform_id and platform_mask.
If you prefer to leave the helper as-is, at a minimum, should we rename
it to intel_get_platform_mask()? Also, the variable name in struct
cpuinfo_x86 should then be x86_platform_mask.
> #endif /* !CONFIG_CPU_SUP_INTEL */
>
> bool microcode_nmi_handler(void);
> diff -puN arch/x86/kernel/cpu/microcode/intel.c~refactor-get-processor-flags arch/x86/kernel/cpu/microcode/intel.c
> --- a/arch/x86/kernel/cpu/microcode/intel.c~refactor-get-processor-flags 2026-01-19 11:38:08.780892582 -0800
> +++ b/arch/x86/kernel/cpu/microcode/intel.c 2026-01-19 11:38:08.783892696 -0800
> @@ -123,16 +123,8 @@ static inline unsigned int exttable_size
> void intel_collect_cpu_info(struct cpu_signature *sig)
> {
> sig->sig = cpuid_eax(1);
> - sig->pf = 0;
> sig->rev = intel_get_microcode_revision();
> -
> - if (IFM(x86_family(sig->sig), x86_model(sig->sig)) >= INTEL_PENTIUM_III_DESCHUTES) {
> - unsigned int val[2];
> -
> - /* get processor flags from MSR 0x17 */
> - native_rdmsr(MSR_IA32_PLATFORM_ID, val[0], val[1]);
> - sig->pf = 1 << ((val[1] >> 18) & 7);
> - }
> + sig->pf = intel_get_platform_id();
> }
> EXPORT_SYMBOL_GPL(intel_collect_cpu_info);
>
> _
next prev parent reply other threads:[~2026-01-22 19:26 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-01-19 19:50 [PATCH 0/6] x86/cpu: Take Intel platform into account for old microcode checks Dave Hansen
2026-01-19 19:50 ` [PATCH 1/6] x86/cpu: Break Vendor/Family/Model macros into separate header Dave Hansen
2026-01-20 8:24 ` Andy Shevchenko
2026-01-20 15:03 ` Dave Hansen
2026-01-20 16:22 ` Andy Shevchenko
2026-01-20 16:34 ` Dave Hansen
2026-01-20 20:54 ` Andy Shevchenko
2026-01-20 16:48 ` Luck, Tony
2026-01-20 20:50 ` Shevchenko, Andriy
2026-01-19 19:50 ` [PATCH 2/6] x86/cpu: Add missing #include Dave Hansen
2026-01-20 0:26 ` Dave Hansen
2026-01-20 8:19 ` Andy Shevchenko
2026-01-20 15:35 ` Dave Hansen
2026-01-19 19:50 ` [PATCH 3/6] x86/microcode: Refactor platform ID enumeration into a helper Dave Hansen
2026-01-20 3:07 ` Chao Gao
2026-01-20 16:06 ` Dave Hansen
2026-01-20 20:59 ` Andy Shevchenko
2026-01-22 19:26 ` Sohil Mehta [this message]
2026-01-19 19:50 ` [PATCH 4/6] x86/cpu: Add platform ID to CPU info structure Dave Hansen
2026-01-20 3:14 ` Chao Gao
2026-01-20 15:22 ` Dave Hansen
2026-01-21 2:03 ` Chao Gao
2026-01-20 8:27 ` Andy Shevchenko
2026-01-20 15:06 ` Dave Hansen
2026-01-20 20:44 ` Andy Shevchenko
2026-01-20 20:48 ` Dave Hansen
2026-01-19 19:50 ` [PATCH 5/6] x86/cpu: Add platform ID to CPU matching structure Dave Hansen
2026-01-20 8:30 ` Andy Shevchenko
2026-01-20 15:09 ` Dave Hansen
2026-01-19 19:51 ` [PATCH 6/6] x86/microcode: Add platform mask to Intel microcode "old" list Dave Hansen
2026-01-20 14:33 ` Zhao Liu
2026-01-20 15:10 ` Dave Hansen
2026-01-29 21:23 ` Sohil Mehta
2026-01-20 18:18 ` [PATCH 0/6] x86/cpu: Take Intel platform into account for old microcode checks Dave Hansen
2026-01-22 13:56 ` Ricardo Neri
2026-02-06 23:14 [PATCH 0/6] [v2] " Dave Hansen
2026-02-06 23:14 ` [PATCH 3/6] x86/microcode: Refactor platform ID enumeration into a helper Dave Hansen
2026-02-10 23:20 ` Sohil Mehta
2026-02-10 23:23 ` Dave Hansen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9f397b71-54c7-4cf9-8c93-515f909404ae@intel.com \
--to=sohil.mehta@intel.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=jon@nutanix.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=pawan.kumar.gupta@linux.intel.com \
--cc=peterz@infradead.org \
--cc=tglx@kernel.org \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®