mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jean Pihet <jean.pihet@newoldbits.com>
To: "Rafael J. Wysocki" <rjw@sisk.pl>
Cc: Thomas Renninger <trenn@suse.de>, Ingo Molnar <mingo@elte.hu>,
	Arjan van de Ven <arjan@linux.intel.com>,
	Peter Zijlstra <peterz@infradead.org>,
	Len Brown <len.brown@intel.com>,
	arjan@infradead.org, Kevin Hilman <khilman@deeprootsystems.com>,
	linux-kernel@vger.kernel.org,
	linux-pm@lists.linux-foundation.org, linux-omap@vger.kernel.org,
	linux-perf-users@vger.kernel.org,
	linux-trace-users@vger.kernel.org
Subject: Re: [PATCH] tracing, perf: add more power related events
Date: Tue, 28 Sep 2010 23:43:55 +0200	[thread overview]
Message-ID: <AANLkTin7yoSArdMTMSxKyamMP-dk7bubPiCEgWGb6RCc@mail.gmail.com> (raw)
In-Reply-To: <201009282322.16291.rjw@sisk.pl>

Hi,

On Tue, Sep 28, 2010 at 11:22 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> On Tuesday, September 28, 2010, Jean Pihet wrote:
>> Hi,
>
> Hi,
>
>> Here is what I am proposing, in reply to all your comments:
>>
>> 1) rename the events to match Thomas's proposal:
>>    power:power_cpu_cstate
>>    power:power_cpu_pstate
>>    power:power_cpu_sstate
>
> If that sstate thing is going to mean "suspend", then please drop it.
> "Suspend" is not a state, let alone a CPU state.  It is a procedure by which
> the (entire) system is put into a sleep state (that is not confined to CPUs).

Since suspend is tied to the power management of the system, is it ok
to rename it to e.g. power:system_suspend?

>
>>    ...
>>
>> 2) introduce a new Kconfig option CONFIG_DEPRECATED_POWER_EVENTS and
>> conditionally map a subset of the new events to the old ones for
>> backward compatibility with the existing user apps. The apps should be
>> converted to the new API asap,
>>
>> 3) update documentation
>
> Sounds reasonable.
OK

>
>> Other remarks here below:
>>
>> On Wed, Sep 22, 2010 at 8:49 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
>> ...
>> > This POWER_SSTATE thing seems to be totally artificial and omap-specific.
>> >
>> > Why do you want it to be done this way?
>> >
>> > Or is the ACPI handling added in the ACPI patch?  In which case, why don't you
>> > put that power_switch_state(POWER_SSTATE, 1, 0, cpu) into
>> > kernel/power/suspend.c:suspend_enter() (and analogously for
>> > power_switch_state(POWER_SSTATE, 0, 0, cpu)).
>> The ACPI code is not using the SSTATE event.
>> Indeed inserting a tracepoint at
>> kernel/power/suspend.c:suspend_enter() is more generic. I will correct
>> this.
>
> OK
>
>> > Moreover, why is the cpu argument necessary for POWER_SSTATE at all?
>> The cpu_id parameter is present in all events prototypes. This is not
>> needed. I will correct this.
>
> OK
>
> Thanks,
> Rafael
>

Thanks,
Jean

  reply	other threads:[~2010-09-28 21:43 UTC|newest]

Thread overview: 64+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-09-07  7:21 Jean Pihet
2010-09-07  8:01 ` Jean Pihet
2010-09-08  6:53 ` Ingo Molnar
2010-09-09  7:15   ` Jean Pihet
2010-09-09  7:54     ` Ingo Molnar
2010-09-15 15:45       ` Jean Pihet
2010-09-17 13:08         ` Thomas Renninger
2010-09-17 14:05           ` Jean Pihet
2010-09-17 14:24             ` Ingo Molnar
2010-09-17 15:36               ` Thomas Renninger
2010-09-17 16:24                 ` Ingo Molnar
2010-09-17 22:26                   ` Thomas Renninger
2010-09-22 15:31                     ` Jean Pihet
2010-09-22 15:33                       ` Arjan van de Ven
2010-09-22 15:36                         ` Jean Pihet
2010-09-22 16:32                           ` Arjan van de Ven
2010-09-22 16:43                             ` Peter Zijlstra
2010-09-22 17:06                               ` Arjan van de Ven
2010-09-22 17:30                                 ` Peter Zijlstra
2010-09-22 18:15                                   ` Steven Rostedt
2010-09-22 18:23                                     ` Ingo Molnar
2010-09-22 18:30                                       ` Peter Zijlstra
2010-09-22 18:26                                     ` Peter Zijlstra
2010-09-22 18:36                                       ` Steven Rostedt
2010-09-22 18:43                                         ` Peter Zijlstra
2010-09-22 19:14                                       ` Frank Ch. Eigler
2010-09-22 17:36                                 ` Thomas Renninger
2010-09-22 16:47                             ` Peter Zijlstra
2010-09-22 17:57                         ` Thomas Renninger
2010-09-22 18:13                           ` Arjan van de Ven
2010-09-22 18:34                             ` Thomas Renninger
2010-09-22 18:09                         ` Rafael J. Wysocki
2010-09-22 18:49                       ` Rafael J. Wysocki
2010-09-28  8:35                         ` Jean Pihet
2010-09-28 21:22                           ` Rafael J. Wysocki
2010-09-28 21:43                             ` Jean Pihet [this message]
2010-09-28 22:05                               ` Rafael J. Wysocki
2010-09-28 21:45                             ` Arjan van de Ven
2010-09-28 22:05                               ` Rafael J. Wysocki
2010-09-29  7:49                               ` Thomas Renninger
2010-09-29  9:25                                 ` Jean Pihet
2010-10-04 17:55                               ` [linux-pm] " Pavel Machek
2010-09-17 15:29             ` Thomas Renninger
2010-09-17 21:58             ` Thomas Renninger
2010-09-17 22:04             ` Thomas Renninger
2010-09-17 22:10             ` Thomas Renninger
2010-09-17 22:17             ` Thomas Renninger
2010-09-17  8:28 ` [tip:perf/core] tracing, perf: Add " tip-bot for Jean Pihet
  -- strict thread matches above, loose matches on Subject: below --
2010-08-16 11:09 [PATCH] tracing, perf: add " Jean Pihet
2010-08-16 11:15 ` Peter Zijlstra
2010-08-16 11:25   ` Jean Pihet
2010-08-23 10:25     ` Jean Pihet
2010-09-03 17:00       ` Jean Pihet
2010-09-03 18:05         ` Thomas Renninger
2010-09-03 19:55           ` Ingo Molnar
2010-09-03 20:10             ` Thomas Renninger
2010-09-03 20:28               ` Ingo Molnar
2010-09-03 22:56               ` Arjan van de Ven
2010-09-04  8:18                 ` Ingo Molnar
2010-09-06  8:56                   ` Jean Pihet
2010-09-06 10:42                     ` Thomas Renninger
2010-09-06 11:27                       ` Jean Pihet
2010-09-06 12:00                         ` Thomas Renninger
2010-09-07  7:28                           ` Jean Pihet

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=AANLkTin7yoSArdMTMSxKyamMP-dk7bubPiCEgWGb6RCc@mail.gmail.com \
    --to=jean.pihet@newoldbits.com \
    --cc=arjan@infradead.org \
    --cc=arjan@linux.intel.com \
    --cc=khilman@deeprootsystems.com \
    --cc=len.brown@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=linux-perf-users@vger.kernel.org \
    --cc=linux-pm@lists.linux-foundation.org \
    --cc=linux-trace-users@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=peterz@infradead.org \
    --cc=rjw@sisk.pl \
    --cc=trenn@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®