* Problem with DHCP when using tokenring on 2.4.x
@ 2001-04-24 13:00 mshiju
2001-04-25 7:50 ` Ingo Oeser
0 siblings, 1 reply; 4+ messages in thread
From: mshiju @ 2001-04-24 13:00 UTC (permalink / raw)
To: linux-kernel
Hello,
I have a problem with DHCP when using tokenring card on 2.4.x
kernel . When I am using IBM tokenring adapter( all) and trying to hook on
to the lan n/w using DHCP ,I get an error message "operation failed " from
the dhcp client . The dhcp server is getting the broadcast message when the
dhcp client is run. I am using pump that comes with 6.2 redhat
distribution . There is no problem when using static IP. I could
experience this problem only on 2.4.x . I am able to get a valid IP
address on 2.2.x kernel when using tokenring adapter. And also there is no
problem when using ethernet adapter on 2.4.x . . Has anyone experienced
this problem on 2.4.x . Can any one help me to resolve this problem.
Thanks & Regards
Shiju
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: Problem with DHCP when using tokenring on 2.4.x
2001-04-24 13:00 Problem with DHCP when using tokenring on 2.4.x mshiju
@ 2001-04-25 7:50 ` Ingo Oeser
0 siblings, 0 replies; 4+ messages in thread
From: Ingo Oeser @ 2001-04-25 7:50 UTC (permalink / raw)
To: mshiju; +Cc: linux-kernel
On Tue, Apr 24, 2001 at 06:30:59PM +0530, mshiju@in.ibm.com wrote:
> I have a problem with DHCP when using tokenring card on 2.4.x
> kernel . When I am using IBM tokenring adapter( all) and trying to hook on
> to the lan n/w using DHCP ,I get an error message "operation failed " from
> the dhcp client . The dhcp server is getting the broadcast message when the
> dhcp client is run. I am using pump that comes with 6.2 redhat
> distribution .
Try at least stracing pump and find out _which_ operation fails.
Then find out where in the source there are messages "operation
failed" and whatever messages are around that message and compare
these positions with the call trace you get from strace and an
static analysis of the code paths leading to this message.
As a last resort try to run a debugger over pump (you have to
rebuild it without optimization and with debugging symbols).
This sounds like an user space problem until now, but once you
tried all this, we can decide whether it is a kernel bug or a bug
in pump, which got triggered by more correct behavior of the
lastest kernels.
Regards
Ingo Oeser
--
10.+11.03.2001 - 3. Chemnitzer LinuxTag <http://www.tu-chemnitz.de/linux/tag>
<<<<<<<<<<<< been there and had much fun >>>>>>>>>>>>
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: Problem with DHCP when using tokenring on 2.4.x
@ 2001-04-25 9:57 Mulder, Tjeerd
0 siblings, 0 replies; 4+ messages in thread
From: Mulder, Tjeerd @ 2001-04-25 9:57 UTC (permalink / raw)
To: 'linux-kernel@vger.kernel.org'
The problem is probably caused by a change that was made around
kernel 2.3.29. The hardware type of a tokenring adapter was changed
from ARPHRD_IEEE802 to ARPHRD_IEEE802_TR. That breaks pump and the
ISC dhcp package. So pump from RH6.2 certainly won't work.
Fixing the ISC dhcp package is easy. Maybe it has been fixed
on the ISC site by now. Don't know about pump.
Patch for the ISC package:
--- dhcp-3.0b2pl11/common/discover.c.org Mon Jan 8 17:38:18 2001
+++ dhcp-3.0b2pl11/common/discover.c Mon Jan 8 17:23:56 2001
@@ -407,7 +407,11 @@
#ifndef HAVE_ARPHRD_IEEE802
# define ARPHRD_IEEE802 HTYPE_IEEE802
#endif
+#ifdef ARPHRD_IEEE802_TR
+ case ARPHRD_IEEE802_TR:
+#else
case ARPHRD_IEEE802:
+#endif
tmp -> hw_address.hlen = 7;
tmp -> hw_address.hbuf [0] = ARPHRD_IEEE802;
memcpy (&tmp -> hw_address.hbuf [1], sa.sa_data, 6);
--
======================================================================
Tjeerd Mulder ! mailto:tjeerd.mulder@fujitsu-siemens.com
Fujitsu Siemens Computers !
FSC PO PC RD MDE !
Buergermeister Ulrichstr 100 ! Phone: +49 821 804 3549
86199 Augsburg ! Fax : +49 821 804 3934
======================================================================
^ permalink raw reply [flat|nested] 4+ messages in thread
* Problem with DHCP when using tokenring on 2.4.x
@ 2001-04-24 15:14 mshiju
0 siblings, 0 replies; 4+ messages in thread
From: mshiju @ 2001-04-24 15:14 UTC (permalink / raw)
To: linux-kernel
Hello,
I have a problem with DHCP when using tokenring card on 2.4.x
kernel . When I am using IBM tokenring adapter( all) and trying to hook on
to the lan n/w using DHCP ,I get an error message "operation failed " from
the dhcp client . The dhcp server is getting the broadcast message when the
dhcp client is run. I am using pump that comes with 6.2 redhat
distribution . There is no problem when using static IP. I could
experience this problem only on 2.4.x . I am able to get a valid IP
address on 2.2.x kernel when using tokenring adapter. And also there is no
problem when using ethernet adapter on 2.4.x . . Has anyone experienced
this problem on 2.4.x . Can any one help me to resolve this problem.
Thanks & Regards
Shiju
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2001-04-25 9:55 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2001-04-24 13:00 Problem with DHCP when using tokenring on 2.4.x mshiju
2001-04-25 7:50 ` Ingo Oeser
2001-04-24 15:14 mshiju
2001-04-25 9:57 Mulder, Tjeerd
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®