mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Svyatoslav Ryhel <clamor95@gmail.com>
To: Johan Hovold <johan@kernel.org>
Cc: "Lee Jones" <lee@kernel.org>,
	"Daniel Thompson" <danielt@kernel.org>,
	"Jingoo Han" <jingoohan1@gmail.com>,
	"Pavel Machek" <pavel@kernel.org>,
	"Rob Herring" <robh@kernel.org>,
	"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
	"Conor Dooley" <conor+dt@kernel.org>,
	"Jonathan Cameron" <jic23@kernel.org>,
	"David Lechner" <dlechner@baylibre.com>,
	"Nuno Sá" <nuno.sa@analog.com>,
	"Andy Shevchenko" <andy@kernel.org>,
	"Helge Deller" <deller@gmx.de>,
	dri-devel@lists.freedesktop.org, linux-leds@vger.kernel.org,
	devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-iio@vger.kernel.org, linux-fbdev@vger.kernel.org
Subject: Re: [PATCH v5 05/14] iio: light: lm3533-als: Remove redundant pdata helpers
Date: Tue, 14 Jul 2026 16:31:08 +0300	[thread overview]
Message-ID: <CAPVz0n2DPia=nfvd3W-rHy91OvZNO6jdSczT7kyvH-G138KJyg@mail.gmail.com> (raw)
In-Reply-To: <akeHC-OA8tqM941f@hovoldconsulting.com>

пт, 3 лип. 2026 р. о 12:55 Johan Hovold <johan@kernel.org> пише:
>
> On Wed, Jun 17, 2026 at 11:00:22AM +0300, Svyatoslav Ryhel wrote:
> > The lm3533_als_set_input_mode() and lm3533_als_set_resistor() functions
> > are used only in lm3533_als_setup(). Incorporate their code into
> > lm3533_als_setup() directly to simplify driver readability.
>
> That's a debatable claim.
>

Adding helpers to wrap custom regmap wrappers seems redundant twice.

> > Signed-off-by: Svyatoslav Ryhel <clamor95@gmail.com>
> > ---
> >  drivers/iio/light/lm3533-als.c | 56 ++++++++++------------------------
> >  1 file changed, 16 insertions(+), 40 deletions(-)
> >
> > diff --git a/drivers/iio/light/lm3533-als.c b/drivers/iio/light/lm3533-als.c
> > index a9af8e2b965f..69bac1b202f1 100644
> > --- a/drivers/iio/light/lm3533-als.c
> > +++ b/drivers/iio/light/lm3533-als.c
>
> > -static int lm3533_als_setup(struct lm3533_als *als,
> > -                         const struct lm3533_als_platform_data *pdata)
> > -{
> > -     int ret;
> > -
> > -     ret = lm3533_als_set_input_mode(als, pdata->pwm_mode);
> > +                        pdata->r_select);
> >       if (ret)
> > -             return ret;
> > -
> > -     /* ALS input is always high impedance in PWM-mode. */
> > -     if (!pdata->pwm_mode) {
> > -             ret = lm3533_als_set_resistor(als, pdata->r_select);
> > -             if (ret)
> > -                     return ret;
> > -     }
> > +             return dev_err_probe(dev, ret, "failed to set resistor\n");
> >       return 0;
> >  }
>
> There's nothing hard to read about the above. To the contrary the logic
> is more obvious this way.
>
> You also remove the high-impedance comment for no good reason.
>

Removing one level of indentations without obscuring readability is
always a good idea.

> Johan

  reply	other threads:[~2026-07-14 13:31 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-17  8:00 [PATCH v5 00/14] mfd: lm3533: convert to OF bindings, improve support Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 01/14] dt-bindings: leds: Document TI LM3533 LED controller Svyatoslav Ryhel
2026-07-03  9:49   ` Johan Hovold
2026-07-14 13:27     ` Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 02/14] mfd: lm3533: Remove driver specific regmap wrappers Svyatoslav Ryhel
2026-06-17 10:32   ` Andy Shevchenko
2026-07-02 16:12     ` Lee Jones
2026-07-03  9:44   ` Johan Hovold
2026-07-14 13:26     ` Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 03/14] mfd: lm3533: Remove extern from shared functions in the header Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 04/14] mfd: lm3533: Pass only regmap and light sensor presence to child devices Svyatoslav Ryhel
2026-07-03  9:50   ` Johan Hovold
2026-07-14 13:28     ` Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 05/14] iio: light: lm3533-als: Remove redundant pdata helpers Svyatoslav Ryhel
2026-07-03  0:57   ` Jonathan Cameron
2026-07-03  9:55   ` Johan Hovold
2026-07-14 13:31     ` Svyatoslav Ryhel [this message]
2026-06-17  8:00 ` [PATCH v5 06/14] mfd: lm3533-core: " Svyatoslav Ryhel
2026-07-03  9:57   ` Johan Hovold
2026-07-14 13:32     ` Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 07/14] mfd: lm3533: Use dev_groups in struct device_driver Svyatoslav Ryhel
2026-06-25  7:23   ` Andy Shevchenko
2026-06-25  7:26     ` Andy Shevchenko
2026-07-03 10:11   ` Johan Hovold
2026-06-17  8:00 ` [PATCH v5 08/14] mfd: lm3533: Convert to use OF bindings Svyatoslav Ryhel
2026-07-03 11:03   ` Johan Hovold
2026-07-14 13:57     ` Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 09/14] mfd: lm3533: Add support for VIN power supply Svyatoslav Ryhel
2026-07-03 11:09   ` Johan Hovold
2026-07-14 14:00     ` Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 10/14] mfd: lm3533: Set DMA mask Svyatoslav Ryhel
2026-07-03 11:18   ` Johan Hovold
2026-06-17  8:00 ` [PATCH v5 11/14] video: backlight: lm3533_bl: Improve logic of sysfs functions Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 12/14] video: backlight: lm3533_bl: Set initial mapping mode from DT Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 13/14] video: backlight: lm3533_bl: Implement backlight_scale property Svyatoslav Ryhel
2026-06-17  8:00 ` [PATCH v5 14/14] video: leds: backlight: lm3533: Support getting LED sources from DT Svyatoslav Ryhel
2026-06-24 10:04   ` Daniel Thompson
2026-07-02 16:18 ` [PATCH v5 00/14] mfd: lm3533: convert to OF bindings, improve support Lee Jones
2026-07-03  8:50   ` Svyatoslav Ryhel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAPVz0n2DPia=nfvd3W-rHy91OvZNO6jdSczT7kyvH-G138KJyg@mail.gmail.com' \
    --to=clamor95@gmail.com \
    --cc=andy@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=danielt@kernel.org \
    --cc=deller@gmx.de \
    --cc=devicetree@vger.kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jic23@kernel.org \
    --cc=jingoohan1@gmail.com \
    --cc=johan@kernel.org \
    --cc=krzk+dt@kernel.org \
    --cc=lee@kernel.org \
    --cc=linux-fbdev@vger.kernel.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=nuno.sa@analog.com \
    --cc=pavel@kernel.org \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox