* [patch 02/12] list_for_each: arch-i386-pci-i386.c
@ 2004-09-01 20:15 janitor
0 siblings, 0 replies; only message in thread
From: janitor @ 2004-09-01 20:15 UTC (permalink / raw)
To: linux-kernel; +Cc: greg, janitor
Hi.
Replace for with more readable list_for_each.
Compile tested.
Signed-off-by: Domen Puncer <domen@coderock.org>
Signed-off-by: Maximilian Attems <janitor@sternwelten.at>
---
linux-2.6.9-rc1-bk7-max/arch/i386/pci/i386.c | 4 +---
1 files changed, 1 insertion(+), 3 deletions(-)
diff -puN arch/i386/pci/i386.c~list-for-each-arch_i386_pci_i386 arch/i386/pci/i386.c
--- linux-2.6.9-rc1-bk7/arch/i386/pci/i386.c~list-for-each-arch_i386_pci_i386 2004-09-01 19:38:06.000000000 +0200
+++ linux-2.6.9-rc1-bk7-max/arch/i386/pci/i386.c 2004-09-01 19:38:06.000000000 +0200
@@ -96,15 +96,13 @@ pcibios_align_resource(void *data, struc
static void __init pcibios_allocate_bus_resources(struct list_head *bus_list)
{
- struct list_head *ln;
struct pci_bus *bus;
struct pci_dev *dev;
int idx;
struct resource *r, *pr;
/* Depth-First Search on bus tree */
- for (ln=bus_list->next; ln != bus_list; ln=ln->next) {
- bus = pci_bus_b(ln);
+ list_for_each_entry(bus, bus_list, node) {
if ((dev = bus->self)) {
for (idx = PCI_BRIDGE_RESOURCES; idx < PCI_NUM_RESOURCES; idx++) {
r = &dev->resource[idx];
_
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2004-09-01 20:27 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2004-09-01 20:15 [patch 02/12] list_for_each: arch-i386-pci-i386.c janitor
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®