* [PATCH] tmpfs: recommend remount for mpol
@ 2006-02-24 20:18 Hugh Dickins
0 siblings, 0 replies; only message in thread
From: Hugh Dickins @ 2006-02-24 20:18 UTC (permalink / raw)
To: Linus Torvalds
Cc: Andrew Morton, Andi Kleen, Robin Holt, Brent Casavant,
Christoph Rohland, linux-kernel
akpm points out that switching to a non-NUMA kernel could be irritating
if mounting tmpfs fails on an mpol option: tmpfs.txt recommend remount.
Signed-off-by: Hugh Dickins <hugh@veritas.com>
---
Documentation/filesystems/tmpfs.txt | 9 +++++++++
1 files changed, 9 insertions(+)
--- 2.6.16-rc4-git7/Documentation/filesystems/tmpfs.txt 2006-02-24 19:56:07.000000000 +0000
+++ linux/Documentation/filesystems/tmpfs.txt 2006-02-24 19:56:45.000000000 +0000
@@ -92,6 +92,15 @@ NodeList format is a comma-separated lis
a range being two hyphen-separated decimal numbers, the smallest and
largest node numbers in the range. For example, mpol=bind:0-3,5,7,9-15
+Note that trying to mount a tmpfs with an mpol option will fail if the
+running kernel does not support NUMA; and will fail if its nodelist
+specifies a node >= MAX_NUMNODES. If your system relies on that tmpfs
+being mounted, but from time to time runs a kernel built without NUMA
+capability (perhaps a safe recovery kernel), or configured to support
+fewer nodes, then it is advisable to omit the mpol option from automatic
+mount options. It can be added later, when the tmpfs is already mounted
+on MountPoint, by 'mount -o remount,mpol=Policy:NodeList MountPoint'.
+
To specify the initial root directory you can use the following mount
options:
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2006-02-24 20:18 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-02-24 20:18 [PATCH] tmpfs: recommend remount for mpol Hugh Dickins
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®