mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Robert P. J. Day" <rpjday@mindspring.com>
To: Adrian Bunk <bunk@stusta.de>
Cc: Stefan Richter <stefanr@s5r6.in-berlin.de>,
	linux-kernel@vger.kernel.org, Josh Boyer <jwboyer@gmail.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Alexander Viro <viro@zeniv.linux.org.uk>,
	Randy Dunlap <randy.dunlap@oracle.com>,
	Alexey Dobriyan <adobriyan@gmail.com>
Subject: Re: [PATCH] FILESYSTEMS: Delete unused "int dummy[5]" from inodes_stat_t.
Date: Wed, 30 May 2007 07:38:03 -0400 (EDT)	[thread overview]
Message-ID: <Pine.LNX.4.64.0705300733200.12382@localhost.localdomain> (raw)
In-Reply-To: <20070530112946.GT3899@stusta.de>

On Wed, 30 May 2007, Adrian Bunk wrote:

> On Wed, May 30, 2007 at 08:41:56AM +0200, Stefan Richter wrote:
> > From: Stefan Richter <stefanr@s5r6.in-berlin.de>
> > Subject: fs: clarify "dummy" member in struct inodes_stat_t
> >
> > Found by Robert P. J. Day:  The role of inodes_stat_t.dummy wasn't clear
> > and one might be tempted to remove it.  Give it a better name and add a
> > comment.
> >
> > Signed-off-by: Stefan Richter <stefanr@s5r6.in-berlin.de>
> > ---
> > Only quickly compile-tested.
> >
> > Index: linux/include/linux/fs.h
> > ===================================================================
> > --- linux.orig/include/linux/fs.h
> > +++ linux/include/linux/fs.h
> > @@ -44,7 +44,7 @@ extern int get_max_files(void);
> >  struct inodes_stat_t {
> >  	int nr_inodes;
> >  	int nr_unused;
> > -	int dummy[5];
> > +	int reserved[5];	/* for sysctl and procfs ABI compatibility */
> >  };
> >  extern struct inodes_stat_t inodes_stat;
>
> Considering that we export this struct to usespace, I don't think
> renaming a member without a good reason is a good idea (but adding a
> comment makes sense).

that makes sense but, given that that array is guaranteed to always
contain zeroes and therefore no useful information, it might be
amusing to rename it just to see what userspace apps break because
they're referring to it by name for what should be no good reason.

no, no, just kidding ... that would be cruel.  :-)

rday

p.s.  i apologize for this thread having gotten this involved -- i
thought i was submitting a fairly innocuous patch.  live and learn.

-- 
========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

http://fsdev.net/wiki/index.php?title=Main_Page
========================================================================

  reply	other threads:[~2007-05-30 11:41 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-05-29 17:11 Robert P. J. Day
2007-05-29 18:00 ` Andrew Morton
2007-05-29 18:07   ` Robert P. J. Day
2007-05-29 18:19     ` Randy Dunlap
2007-05-29 18:21       ` Robert P. J. Day
2007-05-29 18:33         ` Randy Dunlap
2007-05-29 18:44           ` Josh Boyer
2007-05-29 19:33             ` Randy Dunlap
2007-05-30  6:41               ` Stefan Richter
2007-05-30 11:29                 ` Adrian Bunk
2007-05-30 11:38                   ` Robert P. J. Day [this message]
2007-05-30 19:01                     ` [trivial PATCH, updated] fs: clarify "dummy" member in struct inodes_stat_t Stefan Richter
2007-05-30 19:16                       ` Randy Dunlap
2007-05-29 18:04 ` [PATCH] FILESYSTEMS: Delete unused "int dummy[5]" from inodes_stat_t Alexey Dobriyan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Pine.LNX.4.64.0705300733200.12382@localhost.localdomain \
    --to=rpjday@mindspring.com \
    --cc=adobriyan@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=bunk@stusta.de \
    --cc=jwboyer@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=randy.dunlap@oracle.com \
    --cc=stefanr@s5r6.in-berlin.de \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®