mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: Gabriel Somlo <gsomlo@gmail.com>
Cc: linux-kernel@vger.kernel.org, linux-serial@vger.kernel.org,
	jirislaby@kernel.org, kgugala@antmicro.com,
	mholenko@antmicro.com, joel@jms.id.au,
	david.abdurachmanov@sifive.com, florent@enjoy-digital.fr
Subject: Re: [PATCH v1 1/3] serial: liteuart: cosmetic changes
Date: Wed, 9 Nov 2022 13:07:08 +0100	[thread overview]
Message-ID: <Y2uX7GJYOmaGvRR2@kroah.com> (raw)
In-Reply-To: <20221107171500.2537938-2-gsomlo@gmail.com>

On Mon, Nov 07, 2022 at 12:14:58PM -0500, Gabriel Somlo wrote:
> Make some cosmetic/stylistic (non-functional) improvements:
> 
> 1. Use a DRV_NAME macro to avoid hard-coding "liteuart" in multiple
> locations throughout the source file
> 
> 2. Use bit numbers instead of magic constants for event flags
> 
> 3. Remove stub uart_ops methods that are not called unconditionally
> from serial_core; Document stubs that are required by serial_core
> 
> 4. Don't set unused port->regshift and port->iobase fields gratuitously
> during probe()
> 
> 5. Improve coding style in liteuart_init()

When you list different things you do in a single patch, that means you
should break this up into individual patches.

Please do that here, this should be at least 5 patches.



> 
> Signed-off-by: Gabriel Somlo <gsomlo@gmail.com>
> ---
>  drivers/tty/serial/liteuart.c | 38 +++++++++--------------------------
>  1 file changed, 10 insertions(+), 28 deletions(-)
> 
> diff --git a/drivers/tty/serial/liteuart.c b/drivers/tty/serial/liteuart.c
> index 4c0604325ee9..4b9cca249828 100644
> --- a/drivers/tty/serial/liteuart.c
> +++ b/drivers/tty/serial/liteuart.c
> @@ -18,6 +18,8 @@
>  #include <linux/tty_flip.h>
>  #include <linux/xarray.h>
>  
> +#define DRV_NAME "liteuart"

Just use KBUILD_MODNAME please.

thanks,

greg k-h

  reply	other threads:[~2022-11-09 12:07 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-11-07 17:14 [PATCH v1 0/3] serial: liteuart: add IRQ support Gabriel Somlo
2022-11-07 17:14 ` [PATCH v1 1/3] serial: liteuart: cosmetic changes Gabriel Somlo
2022-11-09 12:07   ` Greg KH [this message]
2022-11-07 17:14 ` [PATCH v1 2/3] serial: liteuart: separate RX loop from poll timer Gabriel Somlo
2022-11-10  1:09   ` Joel Stanley
2022-11-11 17:06     ` Gabriel L. Somlo
2022-11-07 17:15 ` [PATCH v1 3/3] serial: liteuart: add IRQ support Gabriel Somlo
2022-11-10  1:08   ` Joel Stanley
2022-11-12 21:00     ` Gabriel L. Somlo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Y2uX7GJYOmaGvRR2@kroah.com \
    --to=gregkh@linuxfoundation.org \
    --cc=david.abdurachmanov@sifive.com \
    --cc=florent@enjoy-digital.fr \
    --cc=gsomlo@gmail.com \
    --cc=jirislaby@kernel.org \
    --cc=joel@jms.id.au \
    --cc=kgugala@antmicro.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    --cc=mholenko@antmicro.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®