* [PATCH] hwrng: stm32 - rename readl return value
@ 2022-11-08 6:42 Tomas Marek
2022-11-18 9:10 ` Herbert Xu
0 siblings, 1 reply; 2+ messages in thread
From: Tomas Marek @ 2022-11-08 6:42 UTC (permalink / raw)
To: mpm, herbert
Cc: mcoquelin.stm32, linux-arm-kernel, linux-crypto, linux-kernel,
linux-stm32, alexandre.torgue
Use a more meaningful name for the readl return value variable.
Link: https://lore.kernel.org/all/Y1J3QwynPFIlfrIv@loth.rohan.me.apana.org.au/
Signed-off-by: Tomas Marek <tomas.marek@elrest.cz>
---
drivers/char/hw_random/stm32-rng.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/char/hw_random/stm32-rng.c b/drivers/char/hw_random/stm32-rng.c
index 366edda4848b..a6731cf0627a 100644
--- a/drivers/char/hw_random/stm32-rng.c
+++ b/drivers/char/hw_random/stm32-rng.c
@@ -49,13 +49,13 @@ static int stm32_rng_read(struct hwrng *rng, void *data, size_t max, bool wait)
/* Manage timeout which is based on timer and take */
/* care of initial delay time when enabling rng */
if (!sr && wait) {
- int ret;
+ int err;
- ret = readl_relaxed_poll_timeout_atomic(priv->base
+ err = readl_relaxed_poll_timeout_atomic(priv->base
+ RNG_SR,
sr, sr,
10, 50000);
- if (ret)
+ if (err)
dev_err((struct device *)priv->rng.priv,
"%s: timeout %x!\n", __func__, sr);
}
--
2.25.1
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] hwrng: stm32 - rename readl return value
2022-11-08 6:42 [PATCH] hwrng: stm32 - rename readl return value Tomas Marek
@ 2022-11-18 9:10 ` Herbert Xu
0 siblings, 0 replies; 2+ messages in thread
From: Herbert Xu @ 2022-11-18 9:10 UTC (permalink / raw)
To: Tomas Marek
Cc: mpm, mcoquelin.stm32, linux-arm-kernel, linux-crypto,
linux-kernel, linux-stm32, alexandre.torgue
On Tue, Nov 08, 2022 at 07:42:40AM +0100, Tomas Marek wrote:
> Use a more meaningful name for the readl return value variable.
>
> Link: https://lore.kernel.org/all/Y1J3QwynPFIlfrIv@loth.rohan.me.apana.org.au/
>
> Signed-off-by: Tomas Marek <tomas.marek@elrest.cz>
> ---
> drivers/char/hw_random/stm32-rng.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
Patch applied. Thanks.
--
Email: Herbert Xu <herbert@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2022-11-18 9:10 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-11-08 6:42 [PATCH] hwrng: stm32 - rename readl return value Tomas Marek
2022-11-18 9:10 ` Herbert Xu
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®