From: Sakari Ailus <sakari.ailus@linux.intel.com>
To: Kieran Bingham <kieran.bingham@ideasonboard.com>
Cc: Shravan.Chippa@microchip.com, mchehab@kernel.org,
linux-media@vger.kernel.org, linux-kernel@vger.kernel.org,
Conor.Dooley@microchip.com,
Valentina.FernandezAlanis@microchip.com,
Praveen.Kumar@microchip.com
Subject: Re: [PATCH V7 4/4] media: i2c: imx334: add modes for 720p and 480p resolutions
Date: Wed, 5 Mar 2025 11:50:53 +0000 [thread overview]
Message-ID: <Z8g6nWDe2cjumixt@kekkonen.localdomain> (raw)
In-Reply-To: <174117154242.2914008.10875320688605396953@ping.linuxembedded.co.uk>
Hi Kieran, Shravan,
On Wed, Mar 05, 2025 at 10:45:42AM +0000, Kieran Bingham wrote:
> Quoting Shravan.Chippa@microchip.com (2025-03-05 10:22:12)
> > Hi Kieran
> >
> > > -----Original Message-----
> > > From: Kieran Bingham <kieran.bingham@ideasonboard.com>
> > > Sent: Wednesday, March 5, 2025 3:05 PM
> > > To: mchehab@kernel.org; sakari.ailus@linux.intel.com; shravan Chippa -
> > > I35088 <Shravan.Chippa@microchip.com>
> > > Cc: linux-media@vger.kernel.org; linux-kernel@vger.kernel.org; Conor Dooley
> > > - M52691 <Conor.Dooley@microchip.com>; Valentina Fernandez Alanis -
> > > M63239 <Valentina.FernandezAlanis@microchip.com>; Praveen Kumar -
> > > I30718 <Praveen.Kumar@microchip.com>; shravan Chippa - I35088
> > > <Shravan.Chippa@microchip.com>
> > > Subject: Re: [PATCH V7 4/4] media: i2c: imx334: add modes for 720p and 480p
> > > resolutions
> > >
> > > EXTERNAL EMAIL: Do not click links or open attachments unless you know the
> > > content is safe
> > >
> > > Quoting shravan kumar (2025-03-05 05:14:42)
> > > > From: Shravan Chippa <shravan.chippa@microchip.com>
> > > >
> > > > Added support for 1280x720@30 and 640x480@30 resolutions
> > > >
> > > > Signed-off-by: Shravan Chippa <shravan.chippa@microchip.com>
> > > > ---
> > > > drivers/media/i2c/imx334.c | 66
> > > > ++++++++++++++++++++++++++++++++++++++
> > > > 1 file changed, 66 insertions(+)
> > > >
> > > > diff --git a/drivers/media/i2c/imx334.c b/drivers/media/i2c/imx334.c
> > > > index a7c0bd38c9b8..8cd1eecd0143 100644
> > > > --- a/drivers/media/i2c/imx334.c
> > > > +++ b/drivers/media/i2c/imx334.c
> > > > @@ -314,6 +314,46 @@ static const struct imx334_reg
> > > common_mode_regs[] = {
> > > > {0x3002, 0x00},
> > > > };
> > > >
> > > > +/* Sensor mode registers for 640x480@30fps */ static const struct
> > > > +imx334_reg mode_640x480_regs[] = {
> > > > + {0x302c, 0x70},
> > > > + {0x302d, 0x06},
> > >
> > > These two are a single 16 bit register HTRIMMING_START = 1648
> > >
> > > > + {0x302e, 0x80},
> > > > + {0x302f, 0x02},
> > >
> > > These two are a single 16 bit register HNUM = 640
> > >
> > > > + {0x3074, 0x48},
> > > > + {0x3075, 0x07},
> > >
> > > These two are a single 16 bit (well, 12 bit value) AREA3_ST_ADR_1 = 1864
> > >
> > > > + {0x308e, 0x49},
> > > > + {0x308f, 0x07},
> > >
> > > These two are a single 16 bit register AREA3_ST_ADR_2 = 1865
> > >
> > > > + {0x3076, 0xe0},
> > > > + {0x3077, 0x01},
> > >
> > > These two are a single 16 bit register AREA3_WIDTH_1 = 480
> > >
> > > > + {0x3090, 0xe0},
> > > > + {0x3091, 0x01},
> > >
> > > These two are a single 16 bit register AREA3_WIDTH_2 = 480
> > >
> > > > + {0x3308, 0xe0},
> > > > + {0x3309, 0x01},
> > >
> > > These two are a single 16 bit register Y_OUT_SIZE
> > >
> > > Don't you think
> > > { Y_OUT_SIZE, 480 },
> > >
> > > Is so much more readable and easier to comprehend and maintain?
> > >
> > >
> > > > + {0x30d8, 0x30},
> > > > + {0x30d9, 0x0b},
> > >
> > > These two are a single 16 bit register UNREAD_ED_ADR = 2864
> > >
> > > > +};
> > >
> > > I'm still sad that we can all know the names of all these registers and yet this
> > > is writing new tables of hex values.
> >
> > Do you want me use call like bellow API with register names:
> > CCI_REG16_LE(0x30d8);
> > cci_write();
> > cci_multi_reg_write();
> > devm_cci_regmap_init_i2c();
>
>
> Yes please, I would want that very much. I'm not very good at reading
> and storing hex values in my head! That's why I broke down the above
> registers to strings and decimal values.
I agree, it'd be good to do these while changing the driver now. I think it
could be done after adding the new modes, now that the patches already
exist.
>
>
> The discussions at
> https://lore.kernel.org/all/PH0PR11MB5611FD22CF6E12F7226FA9C081E12@PH0PR11MB5611.namprd11.prod.outlook.com/
> reports the full datasheet, and I stated:
>
>
> > > > This is an enormous amount of duplicated data that could be factored
> > > > out.
> > > >
> > > > These are also /very/ common against the existing mode register
> > > > tables too.
> > > >
> > > > I think several things need to happen in this driver:
> > > >
> > > > 1. It should be converted to use the CCI helpers.
> > > > 2. Whereever identifiable, the register names should be used
> > > > instead of
> > > > just the addresses.
> > > > 3. The common factors of these tables should be de-duplicated.
> > > >
> > > > In your additions you only have differences in the following
> > > > registers from those entire tables:
>
> You replied with
>
> > >
> > > I will try to optimize camera resolution array register value usage by
> > > writing common register array values.
>
> which you have done (point 3), and is great progress in the series.
>
> Further down in the thread I stated:
>
>
> > > > 4. And ideally - the differences which determine the modes should
> > > > be
> > > > factored out to calculations so that we are not writing out
> > > > large
> > > > tables just to write a parameterised frame size.
> > > >
> > > >
> > > > I would beleive that at least steps 1 and 3 would be achievable, 2
> > > > and 4 would depend upon access to the datasheet.
> > > >
>
>
> I still believe steps 1 is important to this development. You have done
> step 3 I think. And now both step 2 and (later) step 4 are possible as we
> have the datasheet.
In this case the datasheet doesn't appear to be documenting the PLL.
--
Regards,
Sakari Ailus
next prev parent reply other threads:[~2025-03-05 11:51 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-05 5:14 [PATCH V7 0/4] media: i2c: imx334: Add support for 1280x720 & 640x480 resolutions shravan kumar
2025-03-05 5:14 ` [PATCH V7 1/4] media: i2c: imx334: Optimized 4k and 2k mode register arrays shravan kumar
2025-03-05 5:14 ` [PATCH V7 2/4] media: i2c: imx334: common reg value correction shravan kumar
2025-03-11 9:47 ` Sakari Ailus
2025-03-11 10:09 ` Tarang Raval
2025-03-05 5:14 ` [PATCH V7 3/4] media: i2c: imx334: update mode_3840x2160_regs array shravan kumar
2025-03-05 5:14 ` [PATCH V7 4/4] media: i2c: imx334: add modes for 720p and 480p resolutions shravan kumar
2025-03-05 9:35 ` Kieran Bingham
2025-03-05 10:22 ` Shravan.Chippa
2025-03-05 10:40 ` Tarang Raval
2025-03-05 10:49 ` Kieran Bingham
2025-03-05 11:30 ` Tarang Raval
2025-03-05 12:09 ` Kieran Bingham
2025-03-05 10:45 ` Kieran Bingham
2025-03-05 11:50 ` Sakari Ailus [this message]
2025-03-05 12:16 ` Kieran Bingham
2025-03-05 12:59 ` Dave Stevenson
2025-03-06 5:15 ` Shravan.Chippa
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Z8g6nWDe2cjumixt@kekkonen.localdomain \
--to=sakari.ailus@linux.intel.com \
--cc=Conor.Dooley@microchip.com \
--cc=Praveen.Kumar@microchip.com \
--cc=Shravan.Chippa@microchip.com \
--cc=Valentina.FernandezAlanis@microchip.com \
--cc=kieran.bingham@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=mchehab@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®