From: Yan Zhao <yan.y.zhao@intel.com>
To: Sean Christopherson <seanjc@google.com>
Cc: Chao Gao <chao.gao@intel.com>, <kvm@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <pbonzini@redhat.com>
Subject: Re: [PATCH v2 1/6] KVM: x86/mmu: add a new mmu zap helper to indicate memtype changes
Date: Wed, 31 May 2023 08:18:42 +0800 [thread overview]
Message-ID: <ZHaSYqOWDluRmIAd@yzhao56-desk.sh.intel.com> (raw)
In-Reply-To: <ZHaL/d0XhoCmoo3q@google.com>
On Tue, May 30, 2023 at 04:51:25PM -0700, Sean Christopherson wrote:
> On Tue, May 30, 2023, Yan Zhao wrote:
> > On Thu, May 25, 2023 at 08:54:15AM -0700, Sean Christopherson wrote:
> > And I combined the __kvm_mmu_honors_guest_mtrrs() into
> > kvm_mmu_honors_guest_mtrrs(). Not sure if you like it :)
>
> I would prefer to provide a separater inner helper, mainly so that the common
> case callers don't need to pass %false. I don't love passing bools, but it's
> tolerable for a one-off use of an inner helper.
Ok. Will follow this way.
It's reasonable :)
> > +/*
> > + * Returns if KVM honors guest MTRRs
> > + * @override_vm_has_noncoherent_dma: Allow caller to override non-coherent DMA
> > + * status returned from
> > + * kvm_arch_has_noncoherent_dma()
> > + */
> > +bool kvm_mmu_honors_guest_mtrrs(struct kvm *kvm,
> > + bool override_vm_has_noncoherent_dma)
> > +{
> > + bool noncoherent_dma = override_vm_has_noncoherent_dma ? true :
> > + kvm_arch_has_noncoherent_dma(kvm);
>
> The "override" name is confusing, e.g. it won't be clear when it's safe/correct
> for a new caller to override kvm_arch_has_noncoherent_dma(). If we go with a
> single helper, I could live with:
>
> bool kvm_mmu_honors_guest_mtrrs(struct kvm *kvm, bool stopping_noncoherent_dma)
> {
> bool noncoherent_dma = stopping_noncoherent_dma ||
> kvm_arch_has_noncoherent_dma(kvm);
>
> ...
> }
>
> but that makes it awkward to use common code for start+stop assignment, and as
> above there are three "normal" callers that would have to pass magic %false
> values regardless of the name.
next prev parent reply other threads:[~2023-05-31 0:44 UTC|newest]
Thread overview: 41+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-09 13:48 [PATCH v2 0/6] KVM: x86/mmu: refine memtype related mmu zap Yan Zhao
2023-05-09 13:50 ` [PATCH v2 1/6] KVM: x86/mmu: add a new mmu zap helper to indicate memtype changes Yan Zhao
2023-05-10 5:30 ` Chao Gao
2023-05-10 8:06 ` Yan Zhao
2023-05-23 22:51 ` Sean Christopherson
2023-05-24 2:22 ` Yan Zhao
2023-05-24 14:50 ` Sean Christopherson
2023-05-25 10:14 ` Yan Zhao
2023-05-25 15:54 ` Sean Christopherson
2023-05-30 1:32 ` Yan Zhao
2023-05-30 9:48 ` Yan Zhao
2023-05-30 23:51 ` Sean Christopherson
2023-05-31 0:18 ` Yan Zhao [this message]
2023-05-09 13:51 ` [PATCH v2 2/6] KVM: x86/mmu: only zap EPT when guest CR0_CD changes Yan Zhao
2023-05-09 13:51 ` [PATCH v2 3/6] KVM: x86/mmu: only zap EPT when guest MTRR changes Yan Zhao
2023-05-10 5:39 ` Chao Gao
2023-05-10 8:00 ` Yan Zhao
2023-05-10 10:54 ` Huang, Kai
2023-05-11 0:15 ` Yan Zhao
2023-05-11 2:42 ` Huang, Kai
2023-05-11 2:31 ` Yan Zhao
2023-05-11 3:05 ` Huang, Kai
2023-05-09 13:52 ` [PATCH v2 4/6] KVM: x86/mmu: Zap all EPT leaf entries according noncoherent DMA count Yan Zhao
2023-05-09 13:53 ` [PATCH v2 5/6] KVM: x86: Keep a per-VM MTRR state Yan Zhao
2023-05-10 17:23 ` David Matlack
2023-05-21 3:44 ` Robert Hoo
2023-05-23 6:21 ` Yan Zhao
2023-05-24 0:13 ` Sean Christopherson
2023-05-24 11:03 ` Yan Zhao
2023-05-24 18:21 ` Sean Christopherson
2023-05-25 10:09 ` Yan Zhao
2023-05-25 14:53 ` Sean Christopherson
2023-05-26 7:54 ` Yan Zhao
2023-05-26 16:09 ` Sean Christopherson
2023-05-30 1:19 ` Yan Zhao
2023-05-25 7:21 ` Robert Hoo
2023-05-25 15:00 ` Sean Christopherson
2023-05-26 1:49 ` Robert Hoo
2023-05-09 13:53 ` [PATCH v2 6/6] KVM: x86/mmu: use per-VM based MTRR for EPT Yan Zhao
2023-05-24 0:15 ` [PATCH v2 0/6] KVM: x86/mmu: refine memtype related mmu zap Sean Christopherson
2023-05-24 11:04 ` Yan Zhao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZHaSYqOWDluRmIAd@yzhao56-desk.sh.intel.com \
--to=yan.y.zhao@intel.com \
--cc=chao.gao@intel.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=seanjc@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome