mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Michal Wilczynski <michal.wilczynski@intel.com>
Cc: linux-acpi@vger.kernel.org, rafael@kernel.org,
	artem.bityutskiy@linux.intel.com, mingo@redhat.com, bp@alien8.de,
	dave.hansen@linux.intel.com, hpa@zytor.com, lenb@kernel.org,
	jgross@suse.com, linux-kernel@vger.kernel.org, x86@kernel.org,
	"Rafael J . Wysocki" <rafael.j.wysocki@intel.com>
Subject: Re: [PATCH v4 4/9] acpi: Rename ACPI_PDC constants
Date: Mon, 10 Jul 2023 17:20:15 +0300	[thread overview]
Message-ID: <ZKwTn/cLwAM7uSUA@smile.fi.intel.com> (raw)
In-Reply-To: <20230710140337.1434060-5-michal.wilczynski@intel.com>

On Mon, Jul 10, 2023 at 05:03:32PM +0300, Michal Wilczynski wrote:
> ACPI_PDC constants prefix suggest that those constants are only relevant
> in the context of the _PDC method. This is not true, as they can also be
> used in _OSC context. Change prefix to more generic ACPI_PROC_CAP, that
> better describe the purpose of those constants as they describe bits in
> processor capabilities buffer. Rename pdc_intel.h to proc_cap_intel.h to
> reflect the change in the prefix.

...

> -	/* Ask the Hypervisor whether to clear ACPI_PDC_C_C2C3_FFH. If so,
> +	/* Ask the Hypervisor whether to clear ACPI_PROC_CAP_C_C2C3_FFH. If so,
>  	 * don't expose MWAIT_LEAF and let ACPI pick the IOPORT version of C3.
>  	 */

/*
 * While at it, you can fix multi-line
 * comment style. It supposed to be
 * like in this example.
 */

I don't know if resend is required, I would wait for Rafael to comment on this.

-- 
With Best Regards,
Andy Shevchenko



  reply	other threads:[~2023-07-10 14:20 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-07-10 14:03 [PATCH v4 0/9] Prefer using _OSC method over deprecated _PDC Michal Wilczynski
2023-07-10 14:03 ` [PATCH v4 1/9] acpi: Move mwait quirk out of acpi_processor.c Michal Wilczynski
2023-07-10 14:03 ` [PATCH v4 2/9] acpi: Move processor_physically_present() to acpi_processor.c Michal Wilczynski
2023-07-10 14:03 ` [PATCH v4 3/9] acpi: Refactor arch_acpi_set_pdc_bits() Michal Wilczynski
2023-07-10 14:03 ` [PATCH v4 4/9] acpi: Rename ACPI_PDC constants Michal Wilczynski
2023-07-10 14:20   ` Andy Shevchenko [this message]
2023-07-10 14:03 ` [PATCH v4 5/9] acpi: Clear C_C2C3_FFH and C_C1_FFH in arch_acpi_set_proc_cap_bits() Michal Wilczynski
2023-07-10 14:03 ` [PATCH v4 6/9] acpi: Move setting CAP_SMP_T_SWCOORD to arch_acpi_set_proc_cap_bits() Michal Wilczynski
2023-07-10 14:03 ` [PATCH v4 7/9] acpi: Introduce acpi_processor_osc() Michal Wilczynski
2023-07-10 14:03 ` [PATCH v4 8/9] acpi: Use _OSC method to convey processor OSPM capabilities Michal Wilczynski
2023-07-10 14:03 ` [PATCH v4 9/9] acpi: Remove acpi_hwp_native_thermal_lvt_osc() Michal Wilczynski
2023-07-14 16:12 ` [PATCH v4 0/9] Prefer using _OSC method over deprecated _PDC Rafael J. Wysocki
2023-07-17 10:49   ` Wilczynski, Michal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZKwTn/cLwAM7uSUA@smile.fi.intel.com \
    --to=andriy.shevchenko@intel.com \
    --cc=artem.bityutskiy@linux.intel.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=jgross@suse.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=michal.wilczynski@intel.com \
    --cc=mingo@redhat.com \
    --cc=rafael.j.wysocki@intel.com \
    --cc=rafael@kernel.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®