From: Richard Acayan <mailingradian@gmail.com>
To: Konrad Dybcio <konrad.dybcio@linaro.org>
Cc: Stanimir Varbanov <stanimir.k.varbanov@gmail.com>,
Vikash Garodia <quic_vgarodia@quicinc.com>,
Bryan O'Donoghue <bryan.odonoghue@linaro.org>,
Andy Gross <agross@kernel.org>,
Bjorn Andersson <andersson@kernel.org>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Dikshita Agarwal <quic_dikshita@quicinc.com>,
Philipp Zabel <p.zabel@pengutronix.de>,
Marijn Suijten <marijn.suijten@somainline.org>,
Stanimir Varbanov <stanimir.varbanov@linaro.org>,
Mauro Carvalho Chehab <mchehab+huawei@kernel.org>,
linux-media@vger.kernel.org, linux-arm-msm@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 07/20] media: venus: core: Constify all members of the resource struct
Date: Tue, 20 Feb 2024 19:59:39 -0500 [thread overview]
Message-ID: <ZdVK-4S7XX_m9vBJ@radian> (raw)
In-Reply-To: <20230911-topic-mars-v2-7-3dac84b88c4b@linaro.org>
On Fri, Feb 09, 2024 at 10:09:51PM +0100, Konrad Dybcio wrote:
> Nothing inside the resource struct needs to be mutable. Sprinkle
> 'const' all over it. A lot of 'const'.
We already have 'const struct venus_resources'. Is that not sufficient?
Maybe it's just style, since the string arrays are const?
>
> Signed-off-by: Konrad Dybcio <konrad.dybcio@linaro.org>
> ---
> drivers/media/platform/qcom/venus/core.h | 58 ++++++++++++++++----------------
> 1 file changed, 29 insertions(+), 29 deletions(-)
>
> diff --git a/drivers/media/platform/qcom/venus/core.h b/drivers/media/platform/qcom/venus/core.h
> index 6a77de374454..6b1887f7d9cb 100644
> --- a/drivers/media/platform/qcom/venus/core.h
> +++ b/drivers/media/platform/qcom/venus/core.h
> @@ -56,39 +56,39 @@ enum vpu_version {
> };
>
> struct venus_resources {
> - u64 dma_mask;
> - const struct freq_tbl *freq_tbl;
> - unsigned int freq_tbl_size;
> - const struct bw_tbl *bw_tbl_enc;
> - unsigned int bw_tbl_enc_size;
> - const struct bw_tbl *bw_tbl_dec;
> - unsigned int bw_tbl_dec_size;
> - const struct reg_val *reg_tbl;
> - unsigned int reg_tbl_size;
> - const struct hfi_ubwc_config *ubwc_conf;
> + const u64 dma_mask;
> + const struct freq_tbl * const freq_tbl;
> + const unsigned int freq_tbl_size;
> + const struct bw_tbl * const bw_tbl_enc;
> + const unsigned int bw_tbl_enc_size;
> + const struct bw_tbl * const bw_tbl_dec;
> + const unsigned int bw_tbl_dec_size;
> + const struct reg_val * const reg_tbl;
> + const unsigned int reg_tbl_size;
> + const struct hfi_ubwc_config * const ubwc_conf;
> const char * const clks[VIDC_CLKS_NUM_MAX];
> - unsigned int clks_num;
> + const unsigned int clks_num;
> const char * const vcodec0_clks[VIDC_VCODEC_CLKS_NUM_MAX];
> const char * const vcodec1_clks[VIDC_VCODEC_CLKS_NUM_MAX];
> - unsigned int vcodec_clks_num;
> - const char **vcodec_pmdomains;
> - unsigned int vcodec_pmdomains_num;
> - const char **opp_pmdomain;
> - unsigned int vcodec_num;
> + const unsigned int vcodec_clks_num;
> + const char * const *vcodec_pmdomains;
This doesn't error on:
const char *pmdomains[] = { "venus", "vcodec0", "vcodec1" };
struct venus_resources res;
res.vcodec_pmdomains = pmdomains;
res.vcodec_pmdomains = NULL;
> + const unsigned int vcodec_pmdomains_num;
> + const char * const * const opp_pmdomain;
> + const unsigned int vcodec_num;
> const char * const resets[VIDC_RESETS_NUM_MAX];
> - unsigned int resets_num;
> - enum hfi_version hfi_version;
> - enum vpu_version vpu_version;
> - u8 num_vpp_pipes;
> - u32 max_load;
> - unsigned int vmem_id;
> - u32 vmem_size;
> - u32 vmem_addr;
> - u32 cp_start;
> - u32 cp_size;
> - u32 cp_nonpixel_start;
> - u32 cp_nonpixel_size;
> - const char *fwname;
> + const unsigned int resets_num;
> + const enum hfi_version hfi_version;
> + const enum vpu_version vpu_version;
> + const u8 num_vpp_pipes;
> + const u32 max_load;
> + const unsigned int vmem_id;
> + const u32 vmem_size;
> + const u32 vmem_addr;
> + const u32 cp_start;
> + const u32 cp_size;
> + const u32 cp_nonpixel_start;
> + const u32 cp_nonpixel_size;
> + const char * const fwname;
> };
>
> enum venus_fmt {
>
> --
> 2.43.0
>
next prev parent reply other threads:[~2024-02-21 0:59 UTC|newest]
Thread overview: 60+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-07-12 5:48 [PATCH 0/2] add device managed version of dev_pm_domain_attach|detach_list() Dikshita Agarwal
2024-02-09 21:09 ` [PATCH v2 00/20] Venus cleanups Konrad Dybcio
2024-02-09 21:09 ` [PATCH v2 01/20] media: venus: pm_helpers: Only set rate of the core clock in core_clks_enable Konrad Dybcio
2024-07-12 5:48 ` Dikshita Agarwal
2024-07-12 6:07 ` Dikshita Agarwal
2024-07-16 10:49 ` Konrad Dybcio
2024-02-09 21:09 ` [PATCH v2 02/20] media: venus: pm_helpers: Rename core_clks_get to venus_clks_get Konrad Dybcio
2024-03-06 11:48 ` Bryan O'Donoghue
2024-03-26 21:24 ` Konrad Dybcio
2024-02-09 21:09 ` [PATCH v2 03/20] media: venus: pm_helpers: Add kerneldoc to venus_clks_get() Konrad Dybcio
2024-03-06 12:20 ` Bryan O'Donoghue
2024-03-26 21:23 ` Konrad Dybcio
2024-03-27 9:55 ` Bryan O'Donoghue
2024-03-27 17:23 ` Konrad Dybcio
2024-02-09 21:09 ` [PATCH v2 04/20] media: venus: core: Set OPP clkname in a common code path Konrad Dybcio
2024-02-09 21:09 ` [PATCH v2 05/20] media: venus: pm_helpers: Kill dead code Konrad Dybcio
2024-03-04 5:40 ` Dikshita Agarwal
2024-03-26 21:30 ` Konrad Dybcio
2024-02-09 21:09 ` [PATCH v2 06/20] media: venus: pm_helpers: Move reset acquisition to common code Konrad Dybcio
2024-03-04 5:47 ` Dikshita Agarwal
2024-02-09 21:09 ` [PATCH v2 07/20] media: venus: core: Constify all members of the resource struct Konrad Dybcio
2024-02-21 0:59 ` Richard Acayan [this message]
2024-02-09 21:09 ` [PATCH v2 08/20] media: venus: core: Deduplicate OPP genpd names Konrad Dybcio
2024-03-06 12:28 ` Bryan O'Donoghue
2024-02-09 21:09 ` [PATCH v2 09/20] media: venus: core: Get rid of vcodec_num Konrad Dybcio
2024-03-06 12:29 ` Bryan O'Donoghue
2024-02-09 21:09 ` [PATCH v2 10/20] media: venus: core: Drop cache properties in resource struct Konrad Dybcio
2024-03-06 12:32 ` Bryan O'Donoghue
2024-02-09 21:09 ` [PATCH v2 11/20] media: venus: core: Use GENMASK for dma_mask Konrad Dybcio
2024-03-06 13:19 ` Bryan O'Donoghue
2024-02-09 21:09 ` [PATCH v2 12/20] media: venus: core: Remove cp_start Konrad Dybcio
2024-03-06 13:20 ` Bryan O'Donoghue
2024-02-09 21:09 ` [PATCH v2 13/20] media: venus: pm_helpers: Commonize core_power Konrad Dybcio
2024-02-09 21:09 ` [PATCH v2 14/20] media: venus: pm_helpers: Remove pm_ops->core_put Konrad Dybcio
2024-03-04 6:57 ` Dikshita Agarwal
2024-03-04 22:52 ` Konrad Dybcio
2024-03-06 9:54 ` Dikshita Agarwal
2024-02-09 21:09 ` [PATCH v2 15/20] media: venus: core: Define a pointer to core->res Konrad Dybcio
2024-02-09 21:10 ` [PATCH v2 16/20] media: venus: pm_helpers: Simplify vcodec clock handling Konrad Dybcio
2024-02-09 21:10 ` [PATCH v2 17/20] media: venus: pm_helpers: Commonize getting clocks and GenPDs Konrad Dybcio
2024-03-04 7:13 ` Dikshita Agarwal
2024-03-26 21:31 ` Konrad Dybcio
2024-02-09 21:10 ` [PATCH v2 18/20] media: venus: pm_helpers: Commonize vdec_get() Konrad Dybcio
2024-02-09 21:10 ` [PATCH v2 19/20] media: venus: pm_helpers: Commonize venc_get() Konrad Dybcio
2024-02-09 21:10 ` [PATCH v2 20/20] media: venus: pm_helpers: Use reset_bulk API Konrad Dybcio
2024-02-14 13:31 ` Philipp Zabel
2024-02-14 21:20 ` Konrad Dybcio
2024-02-21 13:34 ` Philipp Zabel
2024-02-21 13:37 ` Konrad Dybcio
2024-02-21 13:45 ` Philipp Zabel
2024-02-14 12:56 ` [PATCH v2 00/20] Venus cleanups Bryan O'Donoghue
2024-02-14 21:43 ` Konrad Dybcio
2024-07-12 5:48 ` [PATCH 1/2] PM: domains: add device managed version of dev_pm_domain_attach|detach_list() Dikshita Agarwal
2024-07-13 2:42 ` kernel test robot
2024-07-14 23:08 ` Bryan O'Donoghue
2024-07-16 4:11 ` Pavan Kondeti
2024-07-12 5:48 ` [PATCH 2/2] media: venus: use device managed APIs for power domains Dikshita Agarwal
2024-07-13 3:16 ` kernel test robot
2024-07-14 22:59 ` Bryan O'Donoghue
2024-07-15 11:17 ` [PATCH 0/2] add device managed version of dev_pm_domain_attach|detach_list() Ulf Hansson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZdVK-4S7XX_m9vBJ@radian \
--to=mailingradian@gmail.com \
--cc=agross@kernel.org \
--cc=andersson@kernel.org \
--cc=bryan.odonoghue@linaro.org \
--cc=konrad.dybcio@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=marijn.suijten@somainline.org \
--cc=mchehab+huawei@kernel.org \
--cc=mchehab@kernel.org \
--cc=p.zabel@pengutronix.de \
--cc=quic_dikshita@quicinc.com \
--cc=quic_vgarodia@quicinc.com \
--cc=stanimir.k.varbanov@gmail.com \
--cc=stanimir.varbanov@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®