mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dikshita Agarwal <quic_dikshita@quicinc.com>
To: Konrad Dybcio <konrad.dybcio@linaro.org>,
	Stanimir Varbanov <stanimir.k.varbanov@gmail.com>,
	Vikash Garodia <quic_vgarodia@quicinc.com>,
	Bryan O'Donoghue <bryan.odonoghue@linaro.org>,
	Andy Gross <agross@kernel.org>,
	Bjorn Andersson <andersson@kernel.org>,
	"Mauro Carvalho Chehab" <mchehab@kernel.org>,
	Philipp Zabel <p.zabel@pengutronix.de>
Cc: Marijn Suijten <marijn.suijten@somainline.org>,
	Stanimir Varbanov <stanimir.varbanov@linaro.org>,
	Mauro Carvalho Chehab <mchehab+huawei@kernel.org>,
	<linux-media@vger.kernel.org>, <linux-arm-msm@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 06/20] media: venus: pm_helpers: Move reset acquisition to common code
Date: Mon, 4 Mar 2024 11:17:44 +0530	[thread overview]
Message-ID: <b3ec7faa-e059-d33e-4e4c-749c551e0097@quicinc.com> (raw)
In-Reply-To: <20230911-topic-mars-v2-6-3dac84b88c4b@linaro.org>



On 2/10/2024 2:39 AM, Konrad Dybcio wrote:
> There is no reason to keep reset_get code local to HFIv4/v6.
> 
> Move it to the common part.
> 
> Signed-off-by: Konrad Dybcio <konrad.dybcio@linaro.org>
> ---
>  drivers/media/platform/qcom/venus/core.c       |  9 ++++++++-
>  drivers/media/platform/qcom/venus/pm_helpers.c | 23 -----------------------
>  2 files changed, 8 insertions(+), 24 deletions(-)
> 
> diff --git a/drivers/media/platform/qcom/venus/core.c b/drivers/media/platform/qcom/venus/core.c
> index 5ab3c414ec0f..0652065cb113 100644
> --- a/drivers/media/platform/qcom/venus/core.c
> +++ b/drivers/media/platform/qcom/venus/core.c
> @@ -15,6 +15,7 @@
>  #include <linux/of_platform.h>
>  #include <linux/platform_device.h>
>  #include <linux/pm_opp.h>
> +#include <linux/reset.h>
>  #include <linux/slab.h>
>  #include <linux/types.h>
>  #include <linux/pm_domain.h>
> @@ -286,7 +287,7 @@ static int venus_probe(struct platform_device *pdev)
>  {
>  	struct device *dev = &pdev->dev;
>  	struct venus_core *core;
> -	int ret;
> +	int i, ret;
>  
>  	core = devm_kzalloc(dev, sizeof(*core), GFP_KERNEL);
>  	if (!core)
> @@ -324,6 +325,12 @@ static int venus_probe(struct platform_device *pdev)
>  	if (ret)
>  		return ret;
>  
> +	for (i = 0; i < core->res->resets_num; i++) {
> +		core->resets[i] = devm_reset_control_get_exclusive(dev, core->res->resets[i]);
> +		if (IS_ERR(core->resets[i]))
> +			return PTR_ERR(core->resets[i]);
> +	}
> +
>  	if (core->pm_ops->core_get) {
>  		ret = core->pm_ops->core_get(core);
>  		if (ret)
> diff --git a/drivers/media/platform/qcom/venus/pm_helpers.c b/drivers/media/platform/qcom/venus/pm_helpers.c
> index 7193075e8c04..6017a9236bff 100644
> --- a/drivers/media/platform/qcom/venus/pm_helpers.c
> +++ b/drivers/media/platform/qcom/venus/pm_helpers.c
> @@ -939,25 +939,6 @@ static int core_resets_reset(struct venus_core *core)
>  	return ret;
>  }
>  
> -static int core_resets_get(struct venus_core *core)
> -{
> -	struct device *dev = core->dev;
> -	const struct venus_resources *res = core->res;
> -	unsigned int i;
> -	int ret;
> -
> -	for (i = 0; i < res->resets_num; i++) {
> -		core->resets[i] =
> -			devm_reset_control_get_exclusive(dev, res->resets[i]);
> -		if (IS_ERR(core->resets[i])) {
> -			ret = PTR_ERR(core->resets[i]);
> -			return ret;
> -		}
> -	}
> -
> -	return 0;
> -}
> -
resets are applicable to only v6 so it should be ok to keep this only in
core_get_v4 which is invoked for v6 as well. common code should be common
for all SOCs.
>  static int core_get_v4(struct venus_core *core)
>  {
>  	struct device *dev = core->dev;
> @@ -981,10 +962,6 @@ static int core_get_v4(struct venus_core *core)
>  	if (ret)
>  		return ret;
>  
> -	ret = core_resets_get(core);
> -	if (ret)
> -		return ret;
> -
>  	if (legacy_binding)
>  		return 0;
>  
> 

  reply	other threads:[~2024-03-04  5:48 UTC|newest]

Thread overview: 60+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-07-12  5:48 [PATCH 0/2] add device managed version of dev_pm_domain_attach|detach_list() Dikshita Agarwal
2024-02-09 21:09 ` [PATCH v2 00/20] Venus cleanups Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 01/20] media: venus: pm_helpers: Only set rate of the core clock in core_clks_enable Konrad Dybcio
2024-07-12  5:48     ` Dikshita Agarwal
2024-07-12  6:07     ` Dikshita Agarwal
2024-07-16 10:49       ` Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 02/20] media: venus: pm_helpers: Rename core_clks_get to venus_clks_get Konrad Dybcio
2024-03-06 11:48     ` Bryan O'Donoghue
2024-03-26 21:24       ` Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 03/20] media: venus: pm_helpers: Add kerneldoc to venus_clks_get() Konrad Dybcio
2024-03-06 12:20     ` Bryan O'Donoghue
2024-03-26 21:23       ` Konrad Dybcio
2024-03-27  9:55         ` Bryan O'Donoghue
2024-03-27 17:23           ` Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 04/20] media: venus: core: Set OPP clkname in a common code path Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 05/20] media: venus: pm_helpers: Kill dead code Konrad Dybcio
2024-03-04  5:40     ` Dikshita Agarwal
2024-03-26 21:30       ` Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 06/20] media: venus: pm_helpers: Move reset acquisition to common code Konrad Dybcio
2024-03-04  5:47     ` Dikshita Agarwal [this message]
2024-02-09 21:09   ` [PATCH v2 07/20] media: venus: core: Constify all members of the resource struct Konrad Dybcio
2024-02-21  0:59     ` Richard Acayan
2024-02-09 21:09   ` [PATCH v2 08/20] media: venus: core: Deduplicate OPP genpd names Konrad Dybcio
2024-03-06 12:28     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 09/20] media: venus: core: Get rid of vcodec_num Konrad Dybcio
2024-03-06 12:29     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 10/20] media: venus: core: Drop cache properties in resource struct Konrad Dybcio
2024-03-06 12:32     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 11/20] media: venus: core: Use GENMASK for dma_mask Konrad Dybcio
2024-03-06 13:19     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 12/20] media: venus: core: Remove cp_start Konrad Dybcio
2024-03-06 13:20     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 13/20] media: venus: pm_helpers: Commonize core_power Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 14/20] media: venus: pm_helpers: Remove pm_ops->core_put Konrad Dybcio
2024-03-04  6:57     ` Dikshita Agarwal
2024-03-04 22:52       ` Konrad Dybcio
2024-03-06  9:54         ` Dikshita Agarwal
2024-02-09 21:09   ` [PATCH v2 15/20] media: venus: core: Define a pointer to core->res Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 16/20] media: venus: pm_helpers: Simplify vcodec clock handling Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 17/20] media: venus: pm_helpers: Commonize getting clocks and GenPDs Konrad Dybcio
2024-03-04  7:13     ` Dikshita Agarwal
2024-03-26 21:31       ` Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 18/20] media: venus: pm_helpers: Commonize vdec_get() Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 19/20] media: venus: pm_helpers: Commonize venc_get() Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 20/20] media: venus: pm_helpers: Use reset_bulk API Konrad Dybcio
2024-02-14 13:31     ` Philipp Zabel
2024-02-14 21:20       ` Konrad Dybcio
2024-02-21 13:34         ` Philipp Zabel
2024-02-21 13:37           ` Konrad Dybcio
2024-02-21 13:45             ` Philipp Zabel
2024-02-14 12:56   ` [PATCH v2 00/20] Venus cleanups Bryan O'Donoghue
2024-02-14 21:43     ` Konrad Dybcio
2024-07-12  5:48 ` [PATCH 1/2] PM: domains: add device managed version of dev_pm_domain_attach|detach_list() Dikshita Agarwal
2024-07-13  2:42   ` kernel test robot
2024-07-14 23:08   ` Bryan O'Donoghue
2024-07-16  4:11   ` Pavan Kondeti
2024-07-12  5:48 ` [PATCH 2/2] media: venus: use device managed APIs for power domains Dikshita Agarwal
2024-07-13  3:16   ` kernel test robot
2024-07-14 22:59   ` Bryan O'Donoghue
2024-07-15 11:17 ` [PATCH 0/2] add device managed version of dev_pm_domain_attach|detach_list() Ulf Hansson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b3ec7faa-e059-d33e-4e4c-749c551e0097@quicinc.com \
    --to=quic_dikshita@quicinc.com \
    --cc=agross@kernel.org \
    --cc=andersson@kernel.org \
    --cc=bryan.odonoghue@linaro.org \
    --cc=konrad.dybcio@linaro.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=marijn.suijten@somainline.org \
    --cc=mchehab+huawei@kernel.org \
    --cc=mchehab@kernel.org \
    --cc=p.zabel@pengutronix.de \
    --cc=quic_vgarodia@quicinc.com \
    --cc=stanimir.k.varbanov@gmail.com \
    --cc=stanimir.varbanov@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®