From: Frank Li <Frank.li@nxp.com>
To: Marc Kleine-Budde <mkl@pengutronix.de>
Cc: Wei Fang <wei.fang@nxp.com>, Shenwei Wang <shenwei.wang@nxp.com>,
Clark Wang <xiaoning.wang@nxp.com>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
Richard Cochran <richardcochran@gmail.com>,
imx@lists.linux.dev, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org, kernel@pengutronix.de
Subject: Re: [PATCH net-next 09/13] net: fec: fec_enet_rx_queue(): use same signature as fec_enet_tx_queue()
Date: Wed, 16 Oct 2024 22:32:20 -0400 [thread overview]
Message-ID: <ZxB3NB7qbSuPluZc@lizhi-Precision-Tower-5810> (raw)
In-Reply-To: <20241016-fec-cleanups-v1-9-de783bd15e6a@pengutronix.de>
On Wed, Oct 16, 2024 at 11:51:57PM +0200, Marc Kleine-Budde wrote:
> There are the functions fec_enet_rx_queue() and fec_enet_tx_queue(),
> one for handling the RX queue the other one handles the TX queue.
>
> However they don't have the same signature. To make the code more
> readable make the signature of fec_enet_rx_queue() identical to the
> signature of fec_enet_tx_queue().
'signature' is strange here.
Align fec_enet_rx_queue() argument order with fec_enet_tx_queue() to make
code more readable.
Frank
>
> Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
> ---
> drivers/net/ethernet/freescale/fec_main.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/net/ethernet/freescale/fec_main.c b/drivers/net/ethernet/freescale/fec_main.c
> index c8b2170735e599cd10492169ab32d0e20b28311b..eb26e869c026225194f4df66db145494408bfe8a 100644
> --- a/drivers/net/ethernet/freescale/fec_main.c
> +++ b/drivers/net/ethernet/freescale/fec_main.c
> @@ -1678,7 +1678,7 @@ fec_enet_run_xdp(struct fec_enet_private *fep, struct bpf_prog *prog,
> * effectively tossing the packet.
> */
> static int
> -fec_enet_rx_queue(struct net_device *ndev, int budget, u16 queue_id)
> +fec_enet_rx_queue(struct net_device *ndev, u16 queue_id, int budget)
> {
> struct fec_enet_private *fep = netdev_priv(ndev);
> struct fec_enet_priv_rx_q *rxq;
> @@ -1899,7 +1899,7 @@ static int fec_enet_rx(struct net_device *ndev, int budget)
>
> /* Make sure that AVB queues are processed first. */
> for (i = fep->num_rx_queues - 1; i >= 0; i--)
> - done += fec_enet_rx_queue(ndev, budget - done, i);
> + done += fec_enet_rx_queue(ndev, i, budget - done);
>
> return done;
> }
>
> --
> 2.45.2
>
>
next prev parent reply other threads:[~2024-10-17 2:32 UTC|newest]
Thread overview: 60+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-16 21:51 [PATCH net-next 00/13] net: fec: cleanups, update quirk, update IRQ naming Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 01/13] net: fec: fix typos found by codespell Marc Kleine-Budde
2024-10-17 1:31 ` Wei Fang
2024-10-17 1:52 ` Frank Li
2024-11-15 14:40 ` Csókás Bence
2024-10-16 21:51 ` [PATCH net-next 02/13] net: fec: struct fec_enet_private: remove obsolete comment Marc Kleine-Budde
2024-10-17 1:37 ` Wei Fang
2024-10-17 1:55 ` Frank Li
2024-10-17 6:53 ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 03/13] net: fec: add missing header files Marc Kleine-Budde
2024-10-17 1:40 ` Wei Fang
2024-10-17 1:56 ` Frank Li
2024-10-17 6:53 ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 04/13] net: fec: rename struct fec_devinfo fec_imx6x_info -> fec_imx6sx_info Marc Kleine-Budde
2024-10-17 1:44 ` Wei Fang
2024-10-17 1:59 ` Frank Li
2024-10-17 6:54 ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 05/13] net: fec: fec_restart(): introduce a define for FEC_ECR_SPEED Marc Kleine-Budde
2024-10-17 1:47 ` Wei Fang
2024-10-17 2:05 ` Frank Li
2024-10-17 6:56 ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 06/13] net: fec: fec_restart(): make use of FEC_ECR_RESET Marc Kleine-Budde
2024-10-17 1:49 ` Wei Fang
2024-10-17 2:07 ` Frank Li
2024-10-17 6:56 ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 07/13] net: fec: fec_probe(): update quirk: bring IRQs in correct order Marc Kleine-Budde
2024-10-17 2:15 ` Frank Li
2024-10-17 6:13 ` Marc Kleine-Budde
2024-10-17 3:09 ` Wei Fang
2024-10-17 6:16 ` Marc Kleine-Budde
2024-10-17 7:43 ` Wei Fang
2024-10-17 10:21 ` Marc Kleine-Budde
2024-10-17 14:03 ` Frank Li
2024-10-17 14:21 ` Marc Kleine-Budde
2024-10-17 15:30 ` Frank Li
2024-10-18 9:16 ` Marc Kleine-Budde
2024-10-18 15:26 ` Frank Li
2024-10-16 21:51 ` [PATCH net-next 08/13] net: fec: fec_probe(): let IRQ name reflect its function Marc Kleine-Budde
2024-10-17 2:24 ` Frank Li
2024-10-17 3:12 ` Wei Fang
2024-10-16 21:51 ` [PATCH net-next 09/13] net: fec: fec_enet_rx_queue(): use same signature as fec_enet_tx_queue() Marc Kleine-Budde
2024-10-17 2:32 ` Frank Li [this message]
2024-10-17 7:02 ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 10/13] net: fec: fec_enet_rx_queue(): replace open coded cast by skb_vlan_eth_hdr() Marc Kleine-Budde
2024-10-17 2:44 ` Frank Li
2024-10-17 7:04 ` Marc Kleine-Budde
2024-10-17 3:15 ` Wei Fang
2024-10-16 21:51 ` [PATCH net-next 11/13] net: fec: fec_enet_rx_queue(): reduce scope of data Marc Kleine-Budde
2024-10-17 2:49 ` Frank Li
2024-10-17 3:19 ` Wei Fang
2024-10-16 21:52 ` [PATCH net-next 12/13] net: fec: fec_enet_rx_queue(): move_call to _vlan_hwaccel_put_tag() Marc Kleine-Budde
2024-10-17 3:05 ` Frank Li
2024-10-17 7:05 ` Marc Kleine-Budde
2024-10-17 3:29 ` Wei Fang
2024-10-16 21:52 ` [PATCH net-next 13/13] net: fec: fec_enet_rx_queue(): factor out VLAN handling into separate function fec_enet_rx_vlan() Marc Kleine-Budde
2024-10-17 3:07 ` Frank Li
2024-10-17 3:33 ` Wei Fang
2024-10-17 7:09 ` Marc Kleine-Budde
2024-10-17 7:48 ` Wei Fang
2024-10-18 7:21 ` Marc Kleine-Budde
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZxB3NB7qbSuPluZc@lizhi-Precision-Tower-5810 \
--to=frank.li@nxp.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=imx@lists.linux.dev \
--cc=kernel@pengutronix.de \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mkl@pengutronix.de \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=richardcochran@gmail.com \
--cc=shenwei.wang@nxp.com \
--cc=wei.fang@nxp.com \
--cc=xiaoning.wang@nxp.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®