mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Frank Li <Frank.li@nxp.com>
To: Marc Kleine-Budde <mkl@pengutronix.de>
Cc: Wei Fang <wei.fang@nxp.com>, Shenwei Wang <shenwei.wang@nxp.com>,
	Clark Wang <xiaoning.wang@nxp.com>,
	"David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
	Richard Cochran <richardcochran@gmail.com>,
	imx@lists.linux.dev, netdev@vger.kernel.org,
	linux-kernel@vger.kernel.org, kernel@pengutronix.de
Subject: Re: [PATCH net-next 05/13] net: fec: fec_restart(): introduce a define for FEC_ECR_SPEED
Date: Wed, 16 Oct 2024 22:05:36 -0400	[thread overview]
Message-ID: <ZxBw8Jph6mPW8ExQ@lizhi-Precision-Tower-5810> (raw)
In-Reply-To: <20241016-fec-cleanups-v1-5-de783bd15e6a@pengutronix.de>

On Wed, Oct 16, 2024 at 11:51:53PM +0200, Marc Kleine-Budde wrote:
> Instead of open coding the bit mask to configure for 1000 MBit/s add a
> define for it.

Replace "1 << 5" for configuring 1000 MBit/s with a defined constant to
improve code readability and maintainability.

Reviewed-by: Frank Li <Frank.Li@nxp.com>
>
> Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
> ---
>  drivers/net/ethernet/freescale/fec_main.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/net/ethernet/freescale/fec_main.c b/drivers/net/ethernet/freescale/fec_main.c
> index c57039cc83228dcd980a8fdbc18cd3eab2dfe1a5..2ee7e4765ba3163fb0d158e60b534b171da26c22 100644
> --- a/drivers/net/ethernet/freescale/fec_main.c
> +++ b/drivers/net/ethernet/freescale/fec_main.c
> @@ -276,6 +276,7 @@ MODULE_PARM_DESC(macaddr, "FEC Ethernet MAC address");
>  #define FEC_ECR_MAGICEN         BIT(2)
>  #define FEC_ECR_SLEEP           BIT(3)
>  #define FEC_ECR_EN1588          BIT(4)
> +#define FEC_ECR_SPEED           BIT(5)
>  #define FEC_ECR_BYTESWP         BIT(8)
>  /* FEC RCR bits definition */
>  #define FEC_RCR_LOOP            BIT(0)
> @@ -1160,7 +1161,7 @@ fec_restart(struct net_device *ndev)
>  		/* 1G, 100M or 10M */
>  		if (ndev->phydev) {
>  			if (ndev->phydev->speed == SPEED_1000)
> -				ecntl |= (1 << 5);
> +				ecntl |= FEC_ECR_SPEED;
>  			else if (ndev->phydev->speed == SPEED_100)
>  				rcntl &= ~FEC_RCR_10BASET;
>  			else
>
> --
> 2.45.2
>
>

  parent reply	other threads:[~2024-10-17  2:05 UTC|newest]

Thread overview: 60+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-10-16 21:51 [PATCH net-next 00/13] net: fec: cleanups, update quirk, update IRQ naming Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 01/13] net: fec: fix typos found by codespell Marc Kleine-Budde
2024-10-17  1:31   ` Wei Fang
2024-10-17  1:52   ` Frank Li
2024-11-15 14:40   ` Csókás Bence
2024-10-16 21:51 ` [PATCH net-next 02/13] net: fec: struct fec_enet_private: remove obsolete comment Marc Kleine-Budde
2024-10-17  1:37   ` Wei Fang
2024-10-17  1:55   ` Frank Li
2024-10-17  6:53     ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 03/13] net: fec: add missing header files Marc Kleine-Budde
2024-10-17  1:40   ` Wei Fang
2024-10-17  1:56   ` Frank Li
2024-10-17  6:53     ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 04/13] net: fec: rename struct fec_devinfo fec_imx6x_info -> fec_imx6sx_info Marc Kleine-Budde
2024-10-17  1:44   ` Wei Fang
2024-10-17  1:59   ` Frank Li
2024-10-17  6:54     ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 05/13] net: fec: fec_restart(): introduce a define for FEC_ECR_SPEED Marc Kleine-Budde
2024-10-17  1:47   ` Wei Fang
2024-10-17  2:05   ` Frank Li [this message]
2024-10-17  6:56     ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 06/13] net: fec: fec_restart(): make use of FEC_ECR_RESET Marc Kleine-Budde
2024-10-17  1:49   ` Wei Fang
2024-10-17  2:07   ` Frank Li
2024-10-17  6:56     ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 07/13] net: fec: fec_probe(): update quirk: bring IRQs in correct order Marc Kleine-Budde
2024-10-17  2:15   ` Frank Li
2024-10-17  6:13     ` Marc Kleine-Budde
2024-10-17  3:09   ` Wei Fang
2024-10-17  6:16     ` Marc Kleine-Budde
2024-10-17  7:43       ` Wei Fang
2024-10-17 10:21         ` Marc Kleine-Budde
2024-10-17 14:03           ` Frank Li
2024-10-17 14:21             ` Marc Kleine-Budde
2024-10-17 15:30               ` Frank Li
2024-10-18  9:16                 ` Marc Kleine-Budde
2024-10-18 15:26                   ` Frank Li
2024-10-16 21:51 ` [PATCH net-next 08/13] net: fec: fec_probe(): let IRQ name reflect its function Marc Kleine-Budde
2024-10-17  2:24   ` Frank Li
2024-10-17  3:12   ` Wei Fang
2024-10-16 21:51 ` [PATCH net-next 09/13] net: fec: fec_enet_rx_queue(): use same signature as fec_enet_tx_queue() Marc Kleine-Budde
2024-10-17  2:32   ` Frank Li
2024-10-17  7:02     ` Marc Kleine-Budde
2024-10-16 21:51 ` [PATCH net-next 10/13] net: fec: fec_enet_rx_queue(): replace open coded cast by skb_vlan_eth_hdr() Marc Kleine-Budde
2024-10-17  2:44   ` Frank Li
2024-10-17  7:04     ` Marc Kleine-Budde
2024-10-17  3:15   ` Wei Fang
2024-10-16 21:51 ` [PATCH net-next 11/13] net: fec: fec_enet_rx_queue(): reduce scope of data Marc Kleine-Budde
2024-10-17  2:49   ` Frank Li
2024-10-17  3:19   ` Wei Fang
2024-10-16 21:52 ` [PATCH net-next 12/13] net: fec: fec_enet_rx_queue(): move_call to _vlan_hwaccel_put_tag() Marc Kleine-Budde
2024-10-17  3:05   ` Frank Li
2024-10-17  7:05     ` Marc Kleine-Budde
2024-10-17  3:29   ` Wei Fang
2024-10-16 21:52 ` [PATCH net-next 13/13] net: fec: fec_enet_rx_queue(): factor out VLAN handling into separate function fec_enet_rx_vlan() Marc Kleine-Budde
2024-10-17  3:07   ` Frank Li
2024-10-17  3:33   ` Wei Fang
2024-10-17  7:09     ` Marc Kleine-Budde
2024-10-17  7:48       ` Wei Fang
2024-10-18  7:21         ` Marc Kleine-Budde

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZxBw8Jph6mPW8ExQ@lizhi-Precision-Tower-5810 \
    --to=frank.li@nxp.com \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=imx@lists.linux.dev \
    --cc=kernel@pengutronix.de \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mkl@pengutronix.de \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    --cc=richardcochran@gmail.com \
    --cc=shenwei.wang@nxp.com \
    --cc=wei.fang@nxp.com \
    --cc=xiaoning.wang@nxp.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®