From: Robin Murphy <robin.murphy@arm.com>
To: Joerg Roedel <joro@8bytes.org>
Cc: will@kernel.org, iommu@lists.linux-foundation.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, suravee.suthikulpanit@amd.com,
baolu.lu@linux.intel.com, john.garry@huawei.com,
dianders@chromium.org
Subject: Re: [PATCH 16/23] iommu/arm-smmu: Prepare for multiple DMA domain types
Date: Mon, 26 Jul 2021 14:09:00 +0100 [thread overview]
Message-ID: <a0689d30-2214-c92e-8387-8f1d3b22909b@arm.com> (raw)
In-Reply-To: <YP6ukfewNVjgS/bt@8bytes.org>
On 2021-07-26 13:46, Joerg Roedel wrote:
> On Wed, Jul 21, 2021 at 07:20:27PM +0100, Robin Murphy wrote:
>> - if (type == IOMMU_DOMAIN_DMA && using_legacy_binding)
>> + if ((type & __IOMMU_DOMAIN_DMA_API) && using_legacy_binding)
>
> Hmm, I wonder whether it is time to introduce helpers for these checks?
>
> Something like iommu_domain_is_dma() is more readable.
Ha, I had exactly that at one point, except I think in the order of
iommu_is_dma_domain() :)
The end result didn't seem to give enough extra clarity to justify the
header churn for me, but I'm happy to be wrong about that if you prefer.
Cheers,
Robin.
next prev parent reply other threads:[~2021-07-26 13:09 UTC|newest]
Thread overview: 41+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-07-21 18:20 [PATCH 00/23] iommu: Refactor DMA domain strictness Robin Murphy
2021-07-21 18:20 ` [PATCH 01/23] iommu: Pull IOVA cookie management into the core Robin Murphy
2021-07-21 18:20 ` [PATCH 02/23] iommu/amd: Drop IOVA cookie management Robin Murphy
2021-07-21 18:20 ` [PATCH 03/23] iommu/arm-smmu: " Robin Murphy
2021-07-21 18:20 ` [PATCH 04/23] iommu/vt-d: " Robin Murphy
2021-07-21 18:20 ` [PATCH 05/23] iommu/exynos: " Robin Murphy
2021-07-21 18:20 ` [PATCH 06/23] iommu/ipmmu-vmsa: " Robin Murphy
2021-07-21 18:20 ` [PATCH 07/23] iommu/mtk: " Robin Murphy
2021-07-21 18:20 ` [PATCH 08/23] iommu/rockchip: " Robin Murphy
2021-07-21 18:20 ` [PATCH 09/23] iommu/sprd: " Robin Murphy
2021-07-21 18:20 ` [PATCH 10/23] iommu/sun50i: " Robin Murphy
2021-07-21 18:20 ` [PATCH 11/23] iommu/virtio: " Robin Murphy
2021-07-21 18:20 ` [PATCH 12/23] iommu/dma: Unexport " Robin Murphy
2021-07-21 18:20 ` [PATCH 13/23] iommu/dma: Remove redundant "!dev" checks Robin Murphy
2021-07-26 8:28 ` John Garry
2021-07-21 18:20 ` [PATCH 14/23] iommu: Introduce explicit type for non-strict DMA domains Robin Murphy
2021-07-21 18:20 ` [PATCH 15/23] iommu/amd: Prepare for multiple DMA domain types Robin Murphy
2021-07-21 18:20 ` [PATCH 16/23] iommu/arm-smmu: " Robin Murphy
2021-07-26 12:46 ` Joerg Roedel
2021-07-26 13:09 ` Robin Murphy [this message]
2021-07-26 18:43 ` Joerg Roedel
2021-07-21 18:20 ` [PATCH 17/23] iommu/vt-d: " Robin Murphy
2021-07-22 16:44 ` kernel test robot
2021-07-22 17:30 ` Robin Murphy
2021-07-22 18:44 ` kernel test robot
2021-07-24 5:23 ` Lu Baolu
2021-07-26 8:30 ` Robin Murphy
2021-07-21 18:20 ` [PATCH 18/23] iommu: Express DMA strictness via the domain type Robin Murphy
2021-07-24 5:29 ` Lu Baolu
2021-07-26 8:27 ` Robin Murphy
2021-07-26 11:31 ` Lu Baolu
2021-07-26 12:29 ` Lu Baolu
2021-07-26 12:43 ` Robin Murphy
2021-07-21 18:20 ` [PATCH 19/23] iommu: Expose DMA domain strictness via sysfs Robin Murphy
2021-07-21 18:20 ` [PATCH 20/23] iommu: Allow choosing DMA strictness at build time Robin Murphy
2021-07-21 18:20 ` [PATCH 21/23] iommu/dma: Factor out flush queue init Robin Murphy
2021-07-21 18:20 ` [PATCH 22/23] iommu: Allow enabling non-strict mode dynamically Robin Murphy
2021-07-21 18:20 ` [PATCH 23/23] iommu/arm-smmu: Allow non-strict in pgtable_quirks interface Robin Murphy
2021-07-26 8:13 ` [PATCH 00/23] iommu: Refactor DMA domain strictness John Garry
2021-07-26 12:06 ` Robin Murphy
2021-07-26 13:02 ` Joerg Roedel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a0689d30-2214-c92e-8387-8f1d3b22909b@arm.com \
--to=robin.murphy@arm.com \
--cc=baolu.lu@linux.intel.com \
--cc=dianders@chromium.org \
--cc=iommu@lists.linux-foundation.org \
--cc=john.garry@huawei.com \
--cc=joro@8bytes.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=suravee.suthikulpanit@amd.com \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®