mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Feng Tang <feng.tang@linux.alibaba.com>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: linux-kernel@vger.kernel.org,
	Andrew Morton <akpm@linux-foundation.org>,
	Petr Mladek <pmladek@suse.com>
Subject: Re: [PATCH v2 6/6] panic: sys_info: Factor out read and write handlers
Date: Thu, 30 Oct 2025 10:06:14 +0800	[thread overview]
Message-ID: <aQLIFovZGopZb-QX@U-2FWC9VHC-2323.local> (raw)
In-Reply-To: <20251029111202.3217870-8-andriy.shevchenko@linux.intel.com>

On Wed, Oct 29, 2025 at 12:07:41PM +0100, Andy Shevchenko wrote:
> For the sake of the code readability and easier maintenance
> factor out read and write sys_info handlers.
> 
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> ---
>  lib/sys_info.c | 72 ++++++++++++++++++++++++++++++--------------------
>  1 file changed, 44 insertions(+), 28 deletions(-)
> 
> diff --git a/lib/sys_info.c b/lib/sys_info.c
> index c86f52644857..8ed3b4b55854 100644
> --- a/lib/sys_info.c
> +++ b/lib/sys_info.c
> @@ -43,13 +43,52 @@ unsigned long sys_info_parse_param(char *str)
>  
>  #ifdef CONFIG_SYSCTL
>  
> +static int sys_info_write_handler(struct ctl_table *table,
> +				  void *buffer, size_t *lenp, loff_t *ppos,
> +				  unsigned long *si_bits_global)
> +{
> +	unsigned long si_bits;
> +	int ret;
> +
> +	ret = proc_dostring(table, 1, buffer, lenp, ppos);
> +	if (ret)
> +		return ret;
> +
> +	si_bits = sys_info_parse_param(table->data);
> +
> +	/* The access to the global value is not synchronized. */
> +	WRITE_ONCE(*si_bits_global, si_bits);
> +
> +	return 0;
> +}
> +
> +static int sys_info_read_handler(struct ctl_table *table,
> +				 void *buffer, size_t *lenp, loff_t *ppos,
> +				 unsigned long *si_bits_global)
> +{
> +	unsigned long si_bits;
> +	unsigned int len = 0;
> +	char *delim = "";
> +	unsigned int i;
> +
> +	/* The access to the global value is not synchronized. */
> +	si_bits = READ_ONCE(*si_bits_global);
> +
> +	for_each_set_bit(i, &si_bits, ARRAY_SIZE(si_names)) {
> +		len += scnprintf(table->data + len, table->maxlen - len,
> +				 "%s%s", delim, si_names[i]);
> +		delim = ",";
> +	}
> +
> +	return proc_dostring(table, 0, buffer, lenp, ppos);
> +}
> +
>  int sysctl_sys_info_handler(const struct ctl_table *ro_table, int write,
>  					  void *buffer, size_t *lenp,
>  					  loff_t *ppos)
>  {
>  	struct ctl_table table;
>  	unsigned long *si_bits_global;
> -	unsigned long si_bits;
>  	unsigned int i;
>  	size_t maxlen;
>  
> @@ -67,33 +106,10 @@ int sysctl_sys_info_handler(const struct ctl_table *ro_table, int write,
>  	table.data = names;
>  	table.maxlen = maxlen;
>  
> -	if (write) {
> -		int ret;
> -
> -		ret = proc_dostring(&table, write, buffer, lenp, ppos);
> -		if (ret)
> -			return ret;
> -
> -		si_bits = sys_info_parse_param(names);
> -		/* The access to the global value is not synchronized. */
> -		WRITE_ONCE(*si_bits_global, si_bits);
> -		return 0;
> -	} else {
> -		/* for 'read' operation */
> -		unsigned int len = 0;
> -		char *delim = "";
> -
> -		/* The access to the global value is not synchronized. */
> -		si_bits = READ_ONCE(*si_bits_global);
> -
> -		for_each_set_bit(i, &si_bits, ARRAY_SIZE(si_names)) {
> -			len += scnprintf(names + len, maxlen - len,
> -					 "%s%s", delim, si_names[i]);
> -			delim = ",";
> -		}
> -
> -		return proc_dostring(&table, write, buffer, lenp, ppos);
> -	}

As the if and else block each has only round 10 lines of code, and fit a
screen well, I'm not sure whether adding 2 new functions will improve
readabilty, but I'm fine with the change.

Thanks,
Feng

  reply	other threads:[~2025-10-30  2:06 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-10-29 11:07 [PATCH v2 0/6] panic: sys_info: Refactor and fix a potential issue Andy Shevchenko
2025-10-29 11:07 ` [PATCH v2 1/6] panic: sys_info: Capture si_bits_global before iterating over it Andy Shevchenko
2025-10-30  2:00   ` Feng Tang
2025-10-29 11:07 ` [PATCH v2 2/6] panic: sys_info: Align constant definition names with parameters Andy Shevchenko
2025-10-30  1:59   ` Feng Tang
2025-10-29 11:07 ` [PATCH v2 3/6] panic: sys_info: Replace struct sys_info_name with plain array of strings Andy Shevchenko
2025-10-30  2:01   ` Feng Tang
2025-10-30  7:36     ` Andy Shevchenko
2025-10-30  8:45       ` Feng Tang
2025-10-30  9:05         ` Andy Shevchenko
2025-10-30 10:36           ` Feng Tang
2025-10-29 11:07 ` [PATCH v2 4/6] panic: sys_info: Rewrite a fix for a compilation error (`make W=1`) Andy Shevchenko
2025-10-29 11:07 ` [PATCH v2 5/6] panic: sys_info: Deduplicate local variable 'table; assignments Andy Shevchenko
2025-10-30  2:11   ` Feng Tang
2025-10-29 11:07 ` [PATCH v2 6/6] panic: sys_info: Factor out read and write handlers Andy Shevchenko
2025-10-30  2:06   ` Feng Tang [this message]
2025-10-30  7:44     ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aQLIFovZGopZb-QX@U-2FWC9VHC-2323.local \
    --to=feng.tang@linux.alibaba.com \
    --cc=akpm@linux-foundation.org \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pmladek@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®