mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Marcos Paulo de Souza <mpdesouza@suse.com>
To: Petr Mladek <pmladek@suse.com>, John Ogness <john.ogness@linutronix.de>
Cc: Sergey Senozhatsky <senozhatsky@chromium.org>,
	Steven Rostedt <rostedt@goodmis.org>,
	Chris Down <chris@chrisdown.name>,
	 linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/8] printk: Rename struct console_cmdline to preferred_console
Date: Thu, 19 Feb 2026 15:34:17 -0300	[thread overview]
Message-ID: <aaa8b1127379ccdd70099cc9b13231c7bb48dfb8.camel@suse.com> (raw)
In-Reply-To: <20260206165002.496724-2-pmladek@suse.com>

On Fri, 2026-02-06 at 17:49 +0100, Petr Mladek wrote:
> The structure 'console_cmdline' was originally intended to store
> details
> about consoles defined on the kernel command line. However, its usage
> has since expanded; it now stores information for consoles preferred
> via SPCR, device tree, or by particular platforms, e.g. XEN.
> 
> The current naming is misleading as it implies the configuration only
> originates from the command line.
> 
> Rename the structure and associated artifacts to better reflect their
> current purpose, for example:
> 
>   - struct console_cmdline c -> struct preferred_console pc
>   - console_cmdline[]        -> preferred_consoles[]
>   - console_cmdline.h        -> console_register.h
>   - c			     -> pc
> 
> Additionally, renaming the header file to console_register.h would
> eventually allow to decouple console registration logic from
> the monolithic printk.c.
> 
> Finally, renaming the local variable from "c" to "pc" helps to
> distinguish
> it from struct console variables. Note that "c" is used for struct
> console
> in some code, for example see vt_console_device() function
> definition.
> 
> Signed-off-by: Petr Mladek <pmladek@suse.com>

The renaming is very welcome, since it was indeed confusing to
distinguish between console_cmdline, struct console and whatnot.

Acked-by: Marcos Paulo de Souza <mpdesouza@suse.com>

  parent reply	other threads:[~2026-02-19 18:34 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-02-06 16:49 [PATCH 0/8] printk: Clean up preferred console handling Petr Mladek
2026-02-06 16:49 ` [PATCH 1/8] printk: Rename struct console_cmdline to preferred_console Petr Mladek
2026-02-19 14:40   ` Chris Down
2026-02-19 18:34   ` Marcos Paulo de Souza [this message]
2026-02-06 16:49 ` [PATCH 2/8] printk: Rename preferred_console to preferred_dev_console Petr Mladek
2026-02-19 14:41   ` Chris Down
2026-02-19 18:37   ` Marcos Paulo de Souza
2026-02-06 16:49 ` [PATCH 3/8] printk: Separate code for adding/updating preferred console metadata Petr Mladek
2026-02-16 14:05   ` John Ogness
2026-02-19 12:46     ` Petr Mladek
2026-02-19 14:06       ` John Ogness
2026-02-19 14:48   ` Chris Down
2026-02-19 16:51     ` Petr Mladek
2026-02-06 16:49 ` [PATCH 4/8] printk: Cleanup _braille_(un)register_console() wrappers Petr Mladek
2026-02-19 14:49   ` Chris Down
2026-02-19 18:50   ` Marcos Paulo de Souza
2026-02-06 16:49 ` [PATCH 5/8] printk: Try to register each console as Braille first Petr Mladek
2026-02-19 14:59   ` Chris Down
2026-02-19 16:59     ` Petr Mladek
2026-02-20  4:52       ` Chris Down
2026-02-20 11:43         ` Petr Mladek
2026-02-06 16:50 ` [PATCH 6/8] printk: Do not set Braille console as preferred_console Petr Mladek
2026-02-16 16:07   ` John Ogness
2026-02-19 14:55     ` Petr Mladek
2026-02-19 15:35       ` John Ogness
2026-02-19 15:03   ` Chris Down
2026-02-06 16:50 ` [PATCH 7/8] printk: Handle pre-enabled consoles directly in register_console() Petr Mladek
2026-02-19 15:03   ` Chris Down
2026-02-06 16:50 ` [PATCH 8/8] printk: Try enable preferred consoles only when there are any Petr Mladek
2026-02-19 15:16   ` Chris Down
2026-02-17  8:56 ` [PATCH 0/8] printk: Clean up preferred console handling John Ogness
2026-02-19 15:20 ` Chris Down

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aaa8b1127379ccdd70099cc9b13231c7bb48dfb8.camel@suse.com \
    --to=mpdesouza@suse.com \
    --cc=chris@chrisdown.name \
    --cc=john.ogness@linutronix.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pmladek@suse.com \
    --cc=rostedt@goodmis.org \
    --cc=senozhatsky@chromium.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome