mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Sanjay Chitroda <sanjayembeddedse@gmail.com>
Cc: jic23@kernel.org, dlechner@baylibre.com, nuno.sa@analog.com,
	andy@kernel.org, kees@kernel.org, linux-iio@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 3/5] iio: ssp_sensors: factor out pending list add/remove helpers
Date: Mon, 6 Apr 2026 23:04:41 +0300	[thread overview]
Message-ID: <adQR2ZKVOavHlJDt@ashevche-desk.local> (raw)
In-Reply-To: <20260406080852.2727453-4-sanjayembedded@gmail.com>

On Mon, Apr 06, 2026 at 01:38:50PM +0530, Sanjay Chitroda wrote:

> The SSP SPI transfer path manipulates the pending message list in
> multiple places, each time open-coding the same locking and list
> operations.
> 
> Re-factor the pending list add and delete logic into small helper
> functions to avoid duplication and simplify transfer flow to follow.
> 
> No functional change intended.

Suggested-by?

...

> +static inline void ssp_pending_add(struct ssp_data *data,
> +				   struct ssp_msg *msg)

Make it rather:

static inline void ssp_pending_add(struct ssp_data *data, struct ssp_msg *msg)
{
	if (msg->length)
		return;
	...
}

> +{
> +	mutex_lock(&data->pending_lock);
> +	list_add_tail(&msg->list, &data->pending_list);
> +	mutex_unlock(&data->pending_lock);
> +}
> +
> +static inline void ssp_pending_del(struct ssp_data *data,
> +				   struct ssp_msg *msg)
> +{
> +	mutex_lock(&data->pending_lock);
> +	list_del(&msg->list);
> +	mutex_unlock(&data->pending_lock);
> +}

(in the same manner)

...

> -	if (!use_no_irq) {
> -		mutex_lock(&data->pending_lock);
> -		list_add_tail(&msg->list, &data->pending_list);
> -		mutex_unlock(&data->pending_lock);
> -	}
> +	if (!use_no_irq)
> +		ssp_pending_add(data, msg);

...and then it will become

	ssp_pending_add(data, msg);

>  	status = ssp_check_lines(data, true);
>  	if (status < 0) {
> -		if (!use_no_irq) {
> -			mutex_lock(&data->pending_lock);
> -			list_del(&msg->list);
> -			mutex_unlock(&data->pending_lock);
> -		}
> +		if (!use_no_irq)
> +			ssp_pending_del(data, msg);
>  		goto _error_locked;
>  	}

...

>  		if (wait_for_completion_timeout(done,
>  						msecs_to_jiffies(timeout)) ==
>  		    0) {
> -			mutex_lock(&data->pending_lock);
> -			list_del(&msg->list);
> -			mutex_unlock(&data->pending_lock);
> +			ssp_pending_del(data, msg);
>  
>  			data->timeout_cnt++;
>  			return -ETIMEDOUT;

Also rewrite this to follow the style (missing {}, better indentation):

	if (msg->length && done &&
	    !wait_for_completion_timeout(done, msecs_to_jiffies(timeout))) {
		ssp_pending_del(data, msg);

		data->timeout_cnt++;
		return -ETIMEDOUT;
	}

And kill that use_no_urq altogether. Move the comment rather to a helper(s).

-- 
With Best Regards,
Andy Shevchenko



  reply	other threads:[~2026-04-06 20:04 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-04-06  8:08 [PATCH v5 0/5] iio: ssp_sensors: improve resource cleanup Sanjay Chitroda
2026-04-06  8:08 ` [PATCH v5 1/5] iio: ssp_sensors: cleanup codestyle warning Sanjay Chitroda
2026-04-06 18:33   ` Andy Shevchenko
2026-04-07 17:42     ` Sanjay Chitroda
2026-04-07 19:32       ` Andy Shevchenko
2026-04-06  8:08 ` [PATCH v5 2/5] iio: ssp_sensors: cleanup codestyle check Sanjay Chitroda
2026-04-06  8:08 ` [PATCH v5 3/5] iio: ssp_sensors: factor out pending list add/remove helpers Sanjay Chitroda
2026-04-06 20:04   ` Andy Shevchenko [this message]
2026-04-08  8:22     ` Sanjay Chitroda
     [not found]     ` <FA511CDD-1F98-4E66-BCE8-5156DBAF4359@gmail.com>
2026-04-08 11:36       ` Andy Shevchenko
2026-04-06  8:08 ` [PATCH v5 4/5] iio: ssp_sensors: use devm APIs for mutex and IRQ resources Sanjay Chitroda
2026-04-06 16:14   ` David Lechner
2026-04-11 11:35     ` Sanjay Chitroda
2026-04-11 18:31       ` David Lechner
2026-04-12 16:45         ` Sanjay Chitroda
2026-04-07 12:42   ` Andy Shevchenko
2026-04-11 11:41     ` Sanjay Chitroda
2026-04-06  8:08 ` [PATCH v5 5/5] iio: ssp_sensors: reuse preallocated RX buffer for SPI transfers Sanjay Chitroda
2026-04-06 16:07   ` David Lechner
2026-04-11 11:57     ` Sanjay Chitroda
2026-04-11 12:17     ` Sanjay Chitroda

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=adQR2ZKVOavHlJDt@ashevche-desk.local \
    --to=andriy.shevchenko@intel.com \
    --cc=andy@kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=jic23@kernel.org \
    --cc=kees@kernel.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nuno.sa@analog.com \
    --cc=sanjayembeddedse@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®