From: Hans de Goede <johannes.goede@oss.qualcomm.com>
To: "Marco Nenciarini" <mnencia@kcore.it>,
"Daniel Scally" <djrscally@gmail.com>,
"Sakari Ailus" <sakari.ailus@linux.intel.com>,
"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v7 1/4] platform/x86: int3472: Use local variable for LED struct access
Date: Wed, 1 Apr 2026 15:40:14 +0200 [thread overview]
Message-ID: <ae7ef22f-c418-42a5-a058-a2b26dccc799@oss.qualcomm.com> (raw)
In-Reply-To: <20260331134443.1573053-2-mnencia@kcore.it>
Hi,
On 31-Mar-26 15:44, Marco Nenciarini wrote:
> Introduce a local struct int3472_pled pointer in the LED registration,
> unregistration, and brightness callback functions to avoid repeatedly
> dereferencing int3472->pled. In the brightness callback, use
> container_of() to get the int3472_pled struct directly instead of
> going through int3472_discrete_device.
>
> No functional change.
>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> Signed-off-by: Marco Nenciarini <mnencia@kcore.it>
Thanks, patch looks good to me:
Reviewed-by: Hans de Goede <johannes.goede@oss.qualcomm.com>
Regards,
Hans
> ---
>
> Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> drivers/platform/x86/intel/int3472/led.c | 43 ++++++++++++------------
> 1 file changed, 22 insertions(+), 21 deletions(-)
>
> diff --git a/drivers/platform/x86/intel/int3472/led.c b/drivers/platform/x86/intel/int3472/led.c
> index b1d84b9..35abad9 100644
> --- a/drivers/platform/x86/intel/int3472/led.c
> +++ b/drivers/platform/x86/intel/int3472/led.c
> @@ -6,55 +6,56 @@
> #include <linux/leds.h>
> #include <linux/platform_data/x86/int3472.h>
>
> -static int int3472_pled_set(struct led_classdev *led_cdev,
> - enum led_brightness brightness)
> +static int int3472_pled_set(struct led_classdev *led_cdev, enum led_brightness brightness)
> {
> - struct int3472_discrete_device *int3472 =
> - container_of(led_cdev, struct int3472_discrete_device, pled.classdev);
> + struct int3472_pled *led = container_of(led_cdev, struct int3472_pled, classdev);
>
> - gpiod_set_value_cansleep(int3472->pled.gpio, brightness);
> + gpiod_set_value_cansleep(led->gpio, brightness);
> return 0;
> }
>
> int skl_int3472_register_pled(struct int3472_discrete_device *int3472, struct gpio_desc *gpio)
> {
> + struct int3472_pled *led = &int3472->pled;
> char *p;
> int ret;
>
> - if (int3472->pled.classdev.dev)
> + if (led->classdev.dev)
> return -EBUSY;
>
> - int3472->pled.gpio = gpio;
> + led->gpio = gpio;
>
> /* Generate the name, replacing the ':' in the ACPI devname with '_' */
> - snprintf(int3472->pled.name, sizeof(int3472->pled.name),
> + snprintf(led->name, sizeof(led->name),
> "%s::privacy_led", acpi_dev_name(int3472->sensor));
> - p = strchr(int3472->pled.name, ':');
> + p = strchr(led->name, ':');
> if (p)
> *p = '_';
>
> - int3472->pled.classdev.name = int3472->pled.name;
> - int3472->pled.classdev.max_brightness = 1;
> - int3472->pled.classdev.brightness_set_blocking = int3472_pled_set;
> + led->classdev.name = led->name;
> + led->classdev.max_brightness = 1;
> + led->classdev.brightness_set_blocking = int3472_pled_set;
>
> - ret = led_classdev_register(int3472->dev, &int3472->pled.classdev);
> + ret = led_classdev_register(int3472->dev, &led->classdev);
> if (ret)
> return ret;
>
> - int3472->pled.lookup.provider = int3472->pled.name;
> - int3472->pled.lookup.dev_id = int3472->sensor_name;
> - int3472->pled.lookup.con_id = "privacy";
> - led_add_lookup(&int3472->pled.lookup);
> + led->lookup.provider = led->name;
> + led->lookup.dev_id = int3472->sensor_name;
> + led->lookup.con_id = "privacy";
> + led_add_lookup(&led->lookup);
>
> return 0;
> }
>
> void skl_int3472_unregister_pled(struct int3472_discrete_device *int3472)
> {
> - if (IS_ERR_OR_NULL(int3472->pled.classdev.dev))
> + struct int3472_pled *led = &int3472->pled;
> +
> + if (IS_ERR_OR_NULL(led->classdev.dev))
> return;
>
> - led_remove_lookup(&int3472->pled.lookup);
> - led_classdev_unregister(&int3472->pled.classdev);
> - gpiod_put(int3472->pled.gpio);
> + led_remove_lookup(&led->lookup);
> + led_classdev_unregister(&led->classdev);
> + gpiod_put(led->gpio);
> }
next prev parent reply other threads:[~2026-04-01 13:40 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-31 13:44 [PATCH v7 0/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED) Marco Nenciarini
2026-03-31 13:44 ` [PATCH v7 1/4] platform/x86: int3472: Use local variable for LED struct access Marco Nenciarini
2026-04-01 13:40 ` Hans de Goede [this message]
2026-03-31 13:44 ` [PATCH v7 2/4] platform/x86: int3472: Rename pled to led in LED registration code Marco Nenciarini
2026-04-01 13:42 ` Hans de Goede
2026-03-31 13:44 ` [PATCH v7 3/4] platform/x86: int3472: Parameterize LED con_id in registration Marco Nenciarini
2026-03-31 18:50 ` Andy Shevchenko
2026-04-01 13:43 ` Hans de Goede
2026-03-31 13:44 ` [PATCH v7 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED) Marco Nenciarini
2026-03-31 18:54 ` Andy Shevchenko
2026-04-01 13:45 ` Hans de Goede
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ae7ef22f-c418-42a5-a058-a2b26dccc799@oss.qualcomm.com \
--to=johannes.goede@oss.qualcomm.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=djrscally@gmail.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mnencia@kcore.it \
--cc=platform-driver-x86@vger.kernel.org \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®