From: Lorenzo Stoakes <ljs@kernel.org>
To: "David Hildenbrand (Arm)" <david@kernel.org>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Arnd Bergmann <arnd@arndb.de>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
"Liam R . Howlett" <liam@infradead.org>,
Vlastimil Babka <vbabka@kernel.org>,
Mike Rapoport <rppt@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>, Jann Horn <jannh@google.com>,
Pedro Falcato <pfalcato@suse.de>,
linux-kernel@vger.kernel.org, linux-mm@kvack.org
Subject: Re: [PATCH v2 3/3] mm/vma: eliminate mmap_action->error_hook, introduce error_filter
Date: Tue, 2 Jun 2026 11:07:13 +0100 [thread overview]
Message-ID: <ah6qt-JQaSPwGTfi@lucifer> (raw)
In-Reply-To: <192ad271-13f0-4e8d-b5c2-feb65392bc6b@kernel.org>
On Tue, Jun 02, 2026 at 11:16:03AM +0200, David Hildenbrand (Arm) wrote:
>
> >>> /*
> >>> - * If specified, this hook is invoked when an error occurred when
> >>> - * attempting the selected action.
> >>> - *
> >>> - * The hook can return an error code in order to filter the error, but
> >>> - * it is not valid to clear the error here.
> >>> + * If non-zero, filter errors that arise from mmap actions such that we
> >>> + * return error_filter instead. Only valid error codes may be specified.
> >>
> >> Is that really a filter or rather an "error conversion" / "error override".
> >>
> >> "Filter" to my German brain implies that we would ... filter selected error
> >> codes, not convert them to something else?
> >
> > I thik it's what people tend to call this, it's what I've seen it called anyway!
>
> You mean for this monstrosity or for a mechanism that translates one value to
> another one?
In general, but a quick search on lore suggests this might not be as common as I
thought.
>
> > I mean your German brain is being logical :) but by convention going with this
> > terminology.
>
> Sorry, but which convention?
Of calling this error 'filtering'.
I'll send a quick respin and rename this to error_override then!
>
> --
> Cheers,
>
> David
Cheers, Lorenzo
next prev parent reply other threads:[~2026-06-02 10:07 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-22 16:00 [PATCH v2 0/3] remove mmap_action success, error hooks Lorenzo Stoakes
2026-05-22 16:00 ` [PATCH v2 1/3] drivers/char/mem: eliminate unnecessary use of success_hook Lorenzo Stoakes
2026-06-01 15:18 ` David Hildenbrand (Arm)
2026-05-22 16:00 ` [PATCH v2 2/3] mm/vma: remove mmap_action->success_hook Lorenzo Stoakes
2026-06-01 15:19 ` David Hildenbrand (Arm)
2026-05-22 16:00 ` [PATCH v2 3/3] mm/vma: eliminate mmap_action->error_hook, introduce error_filter Lorenzo Stoakes
2026-06-01 15:25 ` David Hildenbrand (Arm)
2026-06-01 15:46 ` Lorenzo Stoakes
2026-06-02 9:16 ` David Hildenbrand (Arm)
2026-06-02 10:07 ` Lorenzo Stoakes [this message]
2026-06-02 11:23 ` David Hildenbrand (Arm)
2026-06-02 11:28 ` Lorenzo Stoakes
2026-05-22 16:07 ` [PATCH v2 0/3] remove mmap_action success, error hooks Lorenzo Stoakes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ah6qt-JQaSPwGTfi@lucifer \
--to=ljs@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=arnd@arndb.de \
--cc=david@kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=jannh@google.com \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mhocko@suse.com \
--cc=pfalcato@suse.de \
--cc=rppt@kernel.org \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome