From: "Uwe Kleine-König (The Capable Hub)" <u.kleine-koenig@baylibre.com>
To: Liam Girdwood <lgirdwood@gmail.com>, Mark Brown <broonie@kernel.org>
Cc: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>,
Jaroslav Kysela <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>,
linux-sound@vger.kernel.org, linux-renesas-soc@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v1 2/4] ASoC: renesas: fsi: Simplify driver_data handling
Date: Fri, 12 Jun 2026 09:43:56 +0200 [thread overview]
Message-ID: <aiu4T1HgDW8xl2nC@monoceros> (raw)
In-Reply-To: <308c08c0fb309c190412f5ceb21b0027842b6294.1779958164.git.u.kleine-koenig@baylibre.com>
[-- Attachment #1: Type: text/plain, Size: 1792 bytes --]
On Thu, May 28, 2026 at 11:06:01AM +0200, Uwe Kleine-König (The Capable Hub) wrote:
> Instead of hiding the fsi_core struct for the only supported (non-of)
> device behind an abstraction for multi-device support, hardcode the used
> pointer which gets rid of (open-coded) platform_get_device_id() and two
> casts.
>
> Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
> ---
> sound/soc/renesas/fsi.c | 8 +++-----
> 1 file changed, 3 insertions(+), 5 deletions(-)
>
> diff --git a/sound/soc/renesas/fsi.c b/sound/soc/renesas/fsi.c
> index 8cbd7acc26f4..efd1447eacb9 100644
> --- a/sound/soc/renesas/fsi.c
> +++ b/sound/soc/renesas/fsi.c
> @@ -1905,8 +1905,8 @@ static const struct of_device_id fsi_of_match[] = {
> MODULE_DEVICE_TABLE(of, fsi_of_match);
>
> static const struct platform_device_id fsi_id_table[] = {
> - { "sh_fsi", (kernel_ulong_t)&fsi1_core },
> - {},
> + { .name = "sh_fsi" },
> + { }
> };
> MODULE_DEVICE_TABLE(platform, fsi_id_table);
>
> @@ -1929,9 +1929,7 @@ static int fsi_probe(struct platform_device *pdev)
> fsi_of_parse("fsia", np, &info.port_a, &pdev->dev);
> fsi_of_parse("fsib", np, &info.port_b, &pdev->dev);
> } else {
> - const struct platform_device_id *id_entry = pdev->id_entry;
> - if (id_entry)
> - core = (struct fsi_core *)id_entry->driver_data;
> + core = &fsi1_core;
>
> if (pdev->dev.platform_data)
> memcpy(&info, pdev->dev.platform_data, sizeof(info));
With commit 38d3273075d6 ("ASoC: renesas: fsi: remove platform data
style support") this patch doesn't apply any more. I will wait till
after the upcoming merge window and then respin this series. (But if you
take the other patches until then, I won't be angry :-)
Best regards
Uwe
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]
next prev parent reply other threads:[~2026-06-12 7:43 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-28 9:05 [PATCH v1 0/4] ASoC: Use named initializers for platform_device_id arrays Uwe Kleine-König (The Capable Hub)
2026-05-28 9:06 ` [PATCH v1 1/4] ASoC: codecs: mt6357: Drop unused assignment of platform_device_id driver data Uwe Kleine-König (The Capable Hub)
2026-05-28 9:06 ` [PATCH v1 2/4] ASoC: renesas: fsi: Simplify driver_data handling Uwe Kleine-König (The Capable Hub)
2026-05-28 22:29 ` Kuninori Morimoto
2026-06-12 7:43 ` Uwe Kleine-König (The Capable Hub) [this message]
2026-05-28 9:06 ` [PATCH v1 3/4] ASoC: Use named initializers for platform_device_id arrays Uwe Kleine-König (The Capable Hub)
2026-05-28 12:49 ` Mukunda,Vijendar
2026-05-28 9:06 ` [PATCH v1 4/4] ASOC: Unify code style " Uwe Kleine-König (The Capable Hub)
2026-05-28 9:27 ` Cezary Rojewski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aiu4T1HgDW8xl2nC@monoceros \
--to=u.kleine-koenig@baylibre.com \
--cc=broonie@kernel.org \
--cc=kuninori.morimoto.gx@renesas.com \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=linux-sound@vger.kernel.org \
--cc=perex@perex.cz \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®