mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
To: Jeremy Fitzhardinge <jeremy@goop.org>
Cc: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>,
	Stefano Stabellini <Stefano.Stabellini@eu.citrix.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"xen-devel@lists.xensource.com" <xen-devel@lists.xensource.com>,
	"ddutile@redhat.com" <ddutile@redhat.com>,
	"sheng@linux.intel.com" <sheng@linux.intel.com>
Subject: Re: [Xen-devel] [PATCH 06/12] Allow xen platform pci device to be compiled as a module
Date: Thu, 17 Jun 2010 16:42:02 +0100	[thread overview]
Message-ID: <alpine.DEB.2.00.1006171557470.3401@kaball-desktop> (raw)
In-Reply-To: <4C17A8B2.3050203@goop.org>

On Tue, 15 Jun 2010, Jeremy Fitzhardinge wrote:
> On 06/14/2010 10:20 PM, Konrad Rzeszutek Wilk wrote:
> >> -static inline unsigned int max_nr_grant_frames(void)
> >> +unsigned int gnttab_max_nr_grant_frames(void)
> >>  {
> >>  	unsigned int xen_max = __max_nr_grant_frames();
> >>  
> >> @@ -444,6 +445,7 @@ static inline unsigned int max_nr_grant_frames(void)
> >>  		return boot_max_nr_grant_frames;
> >>  	return xen_max;
> >>  }
> >> +EXPORT_SYMBOL_GPL(gnttab_max_nr_grant_frames);
> >>     
> > Prefix the name with 'xen_' ? That is a mouthfull thought:
> >
> > Xen Grant Table Max Nr Grant Frames. How about 'xen_gnttab_max_frames' ?
> >   
> 
> Unfortunately the gnttab API is generally lacking xen_ prefixes.  It's
> better to keep this consistent, and then maybe sort them all out together.
> 
 

I renamed it to gnttab_max_grant_frames for now.

  reply	other threads:[~2010-06-17 15:44 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-06-03 13:10 [PATCH 01/12] Add support for hvm_op stefano.stabellini
2010-06-03 13:10 ` [PATCH 02/12] early PV on HVM stefano.stabellini
2010-06-04 20:20   ` [Xen-devel] " Konrad Rzeszutek Wilk
2010-06-07 14:38     ` Stefano Stabellini
2010-06-08 13:46       ` Konrad Rzeszutek Wilk
2010-06-08 15:55         ` Stefano Stabellini
2010-06-08 16:12           ` Konrad Rzeszutek Wilk
2010-06-08 16:25             ` Stefano Stabellini
2010-06-08 19:05               ` Konrad Rzeszutek Wilk
2010-06-10 13:36                 ` Stefano Stabellini
2010-06-08 16:09         ` Jeremy Fitzhardinge
2010-06-04 20:23   ` Konrad Rzeszutek Wilk
2010-06-07 14:39     ` Stefano Stabellini
2010-06-03 13:10 ` [PATCH 03/12] evtchn delivery " stefano.stabellini
2010-06-14 21:20   ` [Xen-devel] " Konrad Rzeszutek Wilk
2010-06-17 15:41     ` Stefano Stabellini
2010-06-17 17:38       ` Konrad Rzeszutek Wilk
2010-06-17 17:40         ` Stefano Stabellini
2010-06-03 13:10 ` [PATCH 04/12] Xen PCI platform device driver stefano.stabellini
2010-06-03 13:10 ` [PATCH 05/12] Add suspend\resume support for PV on HVM guests stefano.stabellini
2010-06-14 21:20   ` [Xen-devel] " Konrad Rzeszutek Wilk
2010-06-17 15:42     ` Stefano Stabellini
2010-06-03 13:10 ` [PATCH 06/12] Allow xen platform pci device to be compiled as a module stefano.stabellini
2010-06-14 21:20   ` [Xen-devel] " Konrad Rzeszutek Wilk
2010-06-15 16:22     ` Jeremy Fitzhardinge
2010-06-17 15:42       ` Stefano Stabellini [this message]
2010-06-03 13:10 ` [PATCH 07/12] Fix find_unbound_irq in presence of ioapic irqs stefano.stabellini
2010-06-03 13:10 ` [PATCH 08/12] Fix possible NULL pointer dereference in print_IO_APIC stefano.stabellini
2010-06-03 13:10 ` [PATCH 09/12] __setup_vector_irq: handle NULL chip_data stefano.stabellini
2010-06-03 13:10 ` [PATCH 10/12] Do not try to disable hpet if it hasn't been initialized before stefano.stabellini
2010-06-03 13:10 ` [PATCH 11/12] Use xen_vcpuop_clockevent, xen_clocksource and xen wallclock stefano.stabellini
2010-06-03 13:10 ` [PATCH 12/12] Unplug emulated disks and nics stefano.stabellini
2010-06-14 21:20   ` [Xen-devel] " Konrad Rzeszutek Wilk
2010-06-17 15:42     ` Stefano Stabellini
2010-06-17 17:46       ` Konrad Rzeszutek Wilk
2010-06-17 18:00         ` Stefano Stabellini
2010-06-17 23:35       ` Jeremy Fitzhardinge

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.00.1006171557470.3401@kaball-desktop \
    --to=stefano.stabellini@eu.citrix.com \
    --cc=ddutile@redhat.com \
    --cc=jeremy@goop.org \
    --cc=konrad.wilk@oracle.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sheng@linux.intel.com \
    --cc=xen-devel@lists.xensource.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®