From: Thomas Gleixner <tglx@linutronix.de>
To: Paolo Bonzini <pbonzini@redhat.com>
Cc: linux-kernel@vger.kernel.org, kvm@vger.kernel.org,
chris.j.arges@canonical.com, John Stultz <john.stultz@linaro.org>
Subject: Re: [PATCH] KVM: x86: fix kvmclock breakage from timers branch merge
Date: Thu, 4 Sep 2014 23:27:49 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.10.1409042317560.3333@nanos> (raw)
In-Reply-To: <1409864744-26417-1-git-send-email-pbonzini@redhat.com>
On Thu, 4 Sep 2014, Paolo Bonzini wrote:
> Commit cbcf2dd3b3d4 (x86: kvm: Make kvm_get_time_and_clockread() nanoseconds
> based, 2014-07-16) used the wrong formula for boot_ns, thus breaking kvmclock on
> hosts that have a reliable TSC.
>
> To find the right formula, let's first backport the switch to nanoseconds
> to 3.16-era timekeeping logic. The full patch (which works) is at
> https://lkml.org/lkml/2014/9/4/462. The key line here is
>
> boot_ns = timespec_to_ns(&tk->total_sleep_time)
> + timespec_to_ns(&tk->wall_to_monotonic)
> + tk->xtime_sec * (u64)NSEC_PER_SEC;
>
> Because the above patch works, the conclusion is that the above formula
> is not the same as commit cbcf2dd3b3d4's
>
> boot_ns = ktime_to_ns(ktime_add(tk->tkr.base_mono, tk->offs_boot));
>
> As to what is the right one, commit 02cba1598a2a (timekeeping: Simplify getboottime(),
> 2014-07-16) provides a hint:
>
> offs_real = -wall-to_monotonic
> offs_boot = total_sleep_time
>
> offs_real - offs_boot = -wall_to_monotonic - total_sleep_time
>
> that is
>
> offs_boot - offs_real = wall_to_monotonic + total_sleep_time
>
> which is what this patch uses, adding xtime_sec separately. The "boot_ns"
> moniker is not too clear, so rename boot_ns to nsec_base and the existing
> nsec_base to snsec_base.
>
> Cc: Thomas Gleixner <tglx@linutronix.de>
> Cc: John Stultz <john.stultz@linaro.org>
> Reported-by: Chris J Arges <chris.j.arges@canonical.com>
> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
> ---
> Thomas/John, the problem with the above explanation is that
> tk_update_ktime_data has "base_mono = xtime_sec + wtm", and from
> there "base_mono + offs_boot = xtime_sec + wtm + total_sleep_time".
> Except that doesn't work, so something must be wrong in
> tk_update_ktime_data's comment.
Right. I'm staring into it and we need to fix the core code issue and
not the usage site.
Thanks,
tglx
next prev parent reply other threads:[~2014-09-04 21:27 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-09-04 21:05 Paolo Bonzini
2014-09-04 21:27 ` Thomas Gleixner [this message]
-- strict thread matches above, loose matches on Subject: below --
2014-09-04 12:58 Paolo Bonzini
2014-09-04 16:00 ` Chris J Arges
2014-09-04 17:14 ` Paolo Bonzini
2014-09-04 18:16 ` Chris J Arges
2014-09-04 19:15 ` Paolo Bonzini
2014-09-04 19:42 ` Paolo Bonzini
2014-09-04 20:37 ` Chris J Arges
2014-09-04 20:40 ` Paolo Bonzini
2014-09-04 20:43 ` Chris J Arges
2014-09-04 19:00 ` John Stultz
2014-09-04 19:14 ` Paolo Bonzini
2014-09-04 17:56 ` Paolo Bonzini
2014-09-04 20:58 ` Thomas Gleixner
2014-09-04 21:22 ` Paolo Bonzini
2014-09-04 22:24 ` Thomas Gleixner
2014-09-05 15:14 ` Thomas Gleixner
2014-09-05 16:39 ` Paolo Bonzini
2014-09-05 18:33 ` Thomas Gleixner
2014-09-05 20:37 ` Paolo Bonzini
2014-09-05 20:41 ` Thomas Gleixner
2014-09-05 21:00 ` Paolo Bonzini
2014-09-08 15:28 ` Chris J Arges
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.10.1409042317560.3333@nanos \
--to=tglx@linutronix.de \
--cc=chris.j.arges@canonical.com \
--cc=john.stultz@linaro.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®