mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Paolo Bonzini <pbonzini@redhat.com>
Cc: linux-kernel@vger.kernel.org, chris.j.arges@canonical.com,
	kvm@vger.kernel.org, John Stultz <john.stultz@linaro.org>
Subject: Re: [PATCH] KVM: x86: fix kvmclock breakage from timers branch merge
Date: Fri, 5 Sep 2014 00:24:14 +0200 (CEST)	[thread overview]
Message-ID: <alpine.DEB.2.10.1409050021240.3333@nanos> (raw)
In-Reply-To: <5408D815.9090105@redhat.com>

On Thu, 4 Sep 2014, Paolo Bonzini wrote:
> Il 04/09/2014 22:58, Thomas Gleixner ha scritto:
> > This is simply wrong.
> 
> It is.
> 
> > Now I have no idea why you think it needs to add xtime_sec. If the
> > result is wrong, then we need to figure out which one of the supplied
> > values is wrong and not blindly add xtime_sec just because that makes
> > it magically correct.
> > 
> > Can you please provide a proper background why you think that adding
> > xtime_sec is a good idea?
> 
> It's not a good idea indeed.  I didn't fully digest the 3.16->3.17
> timekeeping changes and messed up this patch.
> 
> However, there is a bug in the "base_mono + offs_boot" formula, given
> that:
> 
> - bisection leads to the merge commit of John's timers branch
> 
> - bisecting within John's timers branch, with a KVM commit on top to
>   make the code much easier to trigger, leads to commit cbcf2dd3b3d4
>   (x86: kvm: Make kvm_get_time_and_clockread() nanoseconds based,
>   2014-07-16).
> 
> - I backported your patch to 3.16, using wall_to_monotonic +
>   total_sleep_time + xtime_sec (wtm+xtime_sec as in pre-cbcf2dd3b3d4
>   code, total_sleep_time from 3.16 monotonic_to_bootbased) and it works
> 
> - In v2 of the patch I fixed the bug by changing the formula
>   "base_mono + offs_boot" to "offs_boot - offs_real" (and then adding
>   xtime_sec separately as in the 3.16 backport), but the two formulas
>   "base_mono + offs_boot" and "offs_boot - offs_real + xtime_sec" ought
>   to be identical.
> 
> I find "offs_boot - offs_real + xtime" more readable than the
> alternative "base_mono + offs_boot + xtime_nsec", so the fix doubles as
> a cleanup for me and I'm fine with it.  But something must be wrong in
> the timekeeping code.

I think I have a vague idea what happened, but I'm way too tired now
to write it up fully. I'll do that tomorrow morning with brain awake.

Thanks,

	tglx



  reply	other threads:[~2014-09-04 22:24 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-04 12:58 Paolo Bonzini
2014-09-04 16:00 ` Chris J Arges
2014-09-04 17:14   ` Paolo Bonzini
2014-09-04 18:16     ` Chris J Arges
2014-09-04 19:15       ` Paolo Bonzini
2014-09-04 19:42         ` Paolo Bonzini
2014-09-04 20:37           ` Chris J Arges
2014-09-04 20:40             ` Paolo Bonzini
2014-09-04 20:43               ` Chris J Arges
2014-09-04 19:00   ` John Stultz
2014-09-04 19:14     ` Paolo Bonzini
2014-09-04 17:56 ` Paolo Bonzini
2014-09-04 20:58 ` Thomas Gleixner
2014-09-04 21:22   ` Paolo Bonzini
2014-09-04 22:24     ` Thomas Gleixner [this message]
2014-09-05 15:14     ` Thomas Gleixner
2014-09-05 16:39       ` Paolo Bonzini
2014-09-05 18:33         ` Thomas Gleixner
2014-09-05 20:37           ` Paolo Bonzini
2014-09-05 20:41             ` Thomas Gleixner
2014-09-05 21:00               ` Paolo Bonzini
2014-09-08 15:28                 ` Chris J Arges
2014-09-06 11:01       ` [tip:timers/urgent] timekeeping: Update timekeeper before updating vsyscall and pvclock tip-bot for Thomas Gleixner
2014-09-04 21:05 [PATCH] KVM: x86: fix kvmclock breakage from timers branch merge Paolo Bonzini
2014-09-04 21:27 ` Thomas Gleixner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.10.1409050021240.3333@nanos \
    --to=tglx@linutronix.de \
    --cc=chris.j.arges@canonical.com \
    --cc=john.stultz@linaro.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pbonzini@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®