From: Thomas Gleixner <tglx@linutronix.de>
To: Shaohua Li <shli@fb.com>
Cc: "Yu, Fenghua" <fenghua.yu@intel.com>,
"Luck, Tony" <tony.luck@intel.com>,
"Anvin, H Peter" <h.peter.anvin@intel.com>,
Ingo Molnar <mingo@elte.hu>,
Peter Zijlstra <peterz@infradead.org>, Tejun Heo <tj@kernel.org>,
Borislav Petkov <bp@suse.de>,
Stephane Eranian <eranian@google.com>,
Marcelo Tosatti <mtosatti@redhat.com>,
David Carrillo-Cisneros <davidcc@google.com>,
"Shankar, Ravi V" <ravi.v.shankar@intel.com>,
Vikas Shivappa <vikas.shivappa@linux.intel.com>,
"Prakhya, Sai Praneeth" <sai.praneeth.prakhya@intel.com>,
linux-kernel <linux-kernel@vger.kernel.org>, x86 <x86@kernel.org>
Subject: Re: [PATCH v2 06/33] Documentation, x86: Documentation for Intel resource allocation user interface
Date: Tue, 13 Sep 2016 15:27:14 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.20.1609131525060.6233@nanos> (raw)
In-Reply-To: <20160912041539.GA56347@csimstu-mbp.local.dhcp.thefacebook.com>
On Sun, 11 Sep 2016, Shaohua Li wrote:
> On Sat, Sep 10, 2016 at 12:36:57AM +0000, Yu, Fenghua wrote:
> > One way to implement this is we can extend the current interface to accept
> > a resctrl file system mount parameter to switch b/w "procs" and "tasks" during
> > mount time. So the file sytem has either "procs" or "tasks" during run time. I don't think it's right to have both of them at the same time in the file system.
>
> A mount option doesn't make sense, which just creates more trouble. What's
> wrong to have both of 'procs' and 'tasks' at the same time, like cgroup? I
> think it's more natural to support both. As for the content of 'procs' and
> 'tasks', we could follow how cgroup handle them.
Right. There is nothing wrong with having both, but the very first step is
to get the basic infrastructure merged. Adding 'procs' is a straight
forward add on which can be implemented on top of the primary patch
set. There is no design change required to support it later.
Thanks,
tglx
next prev parent reply other threads:[~2016-09-13 13:30 UTC|newest]
Thread overview: 96+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-09-08 9:56 [PATCH v2 00/33] Enable Intel Resource Allocation in Resource Director Technology Fenghua Yu
2016-09-08 9:56 ` [PATCH v2 01/33] cacheinfo: Introduce cache id Fenghua Yu
2016-09-09 15:01 ` Nilay Vaish
2016-09-08 9:56 ` [PATCH v2 02/33] Documentation, ABI: Add a document entry for " Fenghua Yu
2016-09-08 19:33 ` Thomas Gleixner
2016-09-09 15:11 ` Nilay Vaish
2016-09-08 9:56 ` [PATCH v2 03/33] x86, intel_cacheinfo: Enable cache id in x86 Fenghua Yu
2016-09-08 9:56 ` [PATCH v2 04/33] drivers/base/cacheinfo.c: Export some cacheinfo functions for others to use Fenghua Yu
2016-09-08 8:21 ` Thomas Gleixner
2016-09-08 9:56 ` [PATCH v2 05/33] x86/intel_rdt: Cache Allocation documentation Fenghua Yu
2016-09-08 9:57 ` [PATCH v2 06/33] Documentation, x86: Documentation for Intel resource allocation user interface Fenghua Yu
2016-09-08 11:22 ` Borislav Petkov
2016-09-08 22:01 ` Shaohua Li
2016-09-09 1:17 ` Fenghua Yu
2016-09-08 22:45 ` Shaohua Li
2016-09-09 7:22 ` Fenghua Yu
2016-09-09 17:50 ` Shaohua Li
2016-09-09 18:03 ` Luck, Tony
2016-09-09 21:43 ` Shaohua Li
2016-09-09 21:59 ` Luck, Tony
2016-09-10 0:36 ` Yu, Fenghua
2016-09-12 4:15 ` Shaohua Li
2016-09-13 13:27 ` Thomas Gleixner [this message]
2016-09-08 9:57 ` [PATCH v2 07/33] x86/intel_rdt: Add support for Cache Allocation detection Fenghua Yu
2016-09-08 11:50 ` Borislav Petkov
2016-09-08 16:53 ` Yu, Fenghua
2016-09-08 17:17 ` Borislav Petkov
2016-09-08 13:17 ` Thomas Gleixner
2016-09-08 13:59 ` Yu, Fenghua
2016-09-13 22:40 ` Dave Hansen
2016-09-13 22:52 ` Luck, Tony
2016-09-13 23:00 ` Dave Hansen
2016-09-08 9:57 ` [PATCH v2 08/33] x86/intel_rdt: Add Class of service management Fenghua Yu
2016-09-08 8:56 ` Thomas Gleixner
2016-09-12 16:02 ` Nilay Vaish
2016-09-08 9:57 ` [PATCH v2 09/33] x86/intel_rdt: Add L3 cache capacity bitmask management Fenghua Yu
2016-09-08 9:40 ` Thomas Gleixner
2016-09-12 16:10 ` Nilay Vaish
2016-09-08 9:57 ` [PATCH v2 10/33] x86/intel_rdt: Implement scheduling support for Intel RDT Fenghua Yu
2016-09-08 9:53 ` Thomas Gleixner
2016-09-15 21:36 ` Yu, Fenghua
2016-09-15 21:40 ` Luck, Tony
2016-09-13 17:55 ` Nilay Vaish
2016-09-08 9:57 ` [PATCH v2 11/33] x86/intel_rdt: Hot cpu support for Cache Allocation Fenghua Yu
2016-09-08 10:03 ` Thomas Gleixner
2016-09-13 18:18 ` Nilay Vaish
2016-09-13 19:10 ` Luck, Tony
2016-09-08 9:57 ` [PATCH v2 12/33] x86/intel_rdt: Intel haswell Cache Allocation enumeration Fenghua Yu
2016-09-08 10:08 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 13/33] Define CONFIG_INTEL_RDT Fenghua Yu
2016-09-08 10:14 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 14/33] x86/intel_rdt: Intel Code Data Prioritization detection Fenghua Yu
2016-09-08 9:57 ` [PATCH v2 15/33] x86/intel_rdt: Adds support to enable Code Data Prioritization Fenghua Yu
2016-09-08 10:18 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 16/33] x86/intel_rdt: Class of service and capacity bitmask management for CDP Fenghua Yu
2016-09-08 10:29 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 17/33] x86/intel_rdt: Hot cpu update for code data prioritization Fenghua Yu
2016-09-08 10:34 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 18/33] sched.h: Add rg_list and rdtgroup in task_struct Fenghua Yu
2016-09-08 10:36 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 19/33] magic number for resctrl file system Fenghua Yu
2016-09-08 10:41 ` Thomas Gleixner
2016-09-08 10:47 ` Borislav Petkov
2016-09-08 9:57 ` [PATCH v2 20/33] x86/intel_rdt.h: Header for inter_rdt.c Fenghua Yu
2016-09-08 12:36 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 21/33] x86/intel_rdt_rdtgroup.h: Header for user interface Fenghua Yu
2016-09-08 12:44 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 22/33] x86/intel_rdt.c: Extend RDT to per cache and per resources Fenghua Yu
2016-09-08 14:57 ` Thomas Gleixner
2016-09-13 22:54 ` Dave Hansen
2016-09-08 9:57 ` [PATCH v2 23/33] x86/intel_rdt_rdtgroup.c: User interface for RDT Fenghua Yu
2016-09-08 14:59 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 24/33] x86/intel_rdt_rdtgroup.c: Create info directory Fenghua Yu
2016-09-08 16:04 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 25/33] include/linux/resctrl.h: Define fork and exit functions in a new header file Fenghua Yu
2016-09-08 16:07 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 26/33] Task fork and exit for rdtgroup Fenghua Yu
2016-09-08 19:41 ` Thomas Gleixner
2016-09-13 23:13 ` Dave Hansen
2016-09-13 23:35 ` Luck, Tony
2016-09-14 14:28 ` Dave Hansen
2016-09-08 9:57 ` [PATCH v2 27/33] x86/intel_rdt_rdtgroup.c: Implement resctrl file system commands Fenghua Yu
2016-09-08 20:09 ` Thomas Gleixner
2016-09-08 22:04 ` Shaohua Li
2016-09-09 1:23 ` Fenghua Yu
2016-09-08 9:57 ` [PATCH v2 28/33] x86/intel_rdt_rdtgroup.c: Read and write cpus Fenghua Yu
2016-09-08 20:25 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 29/33] x86/intel_rdt_rdtgroup.c: Tasks iterator and write Fenghua Yu
2016-09-08 20:50 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 30/33] x86/intel_rdt_rdtgroup.c: Process schemata input from resctrl interface Fenghua Yu
2016-09-08 22:20 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 31/33] Documentation/kernel-parameters: Add kernel parameter "resctrl" for CAT Fenghua Yu
2016-09-08 22:25 ` Thomas Gleixner
2016-09-08 9:57 ` [PATCH v2 32/33] MAINTAINERS: Add maintainer for Intel RDT resource allocation Fenghua Yu
2016-09-08 9:57 ` [PATCH v2 33/33] x86/Makefile: Build intel_rdt_rdtgroup.c Fenghua Yu
2016-09-08 23:59 ` Thomas Gleixner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.20.1609131525060.6233@nanos \
--to=tglx@linutronix.de \
--cc=bp@suse.de \
--cc=davidcc@google.com \
--cc=eranian@google.com \
--cc=fenghua.yu@intel.com \
--cc=h.peter.anvin@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=mtosatti@redhat.com \
--cc=peterz@infradead.org \
--cc=ravi.v.shankar@intel.com \
--cc=sai.praneeth.prakhya@intel.com \
--cc=shli@fb.com \
--cc=tj@kernel.org \
--cc=tony.luck@intel.com \
--cc=vikas.shivappa@linux.intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®