mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Deepa Dinamani <deepa.kernel@gmail.com>
Cc: linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org,
	arnd@arndb.de, torvalds@linux-foundation.org,
	gregkh@linuxfoundation.org, akpm@linux-foundation.org,
	tytso@mit.edu, viro@zeniv.linux.org.uk, y2038@lists.linaro.org
Subject: Re: [PATCH v5 1/5] vfs: Add current_time() api
Date: Wed, 14 Sep 2016 20:52:22 +0200 (CEST)	[thread overview]
Message-ID: <alpine.DEB.2.20.1609142049340.30349@nanos> (raw)
In-Reply-To: <1473864486-30862-2-git-send-email-deepa.kernel@gmail.com>

On Wed, 14 Sep 2016, Deepa Dinamani wrote:
> +/**
> + * current_time - Return FS time
> + * @inode: inode.
> + *
> + * Return the current time truncated to the time granularity supported by
> + * the fs.
> + *
> + * Note that inode and inode->sb cannot be NULL.
> + * Otherwise, the function warns and returns time without truncation.
> + */
> +struct timespec current_time(struct inode *inode)

Just a nitpick. Can we please rename that to fs_current_time() or something
similar which tells right away that this is a FS specific
function. current_time() is pretty generic and used in many places as
variable/argument name.

Thanks,

	tglx

  reply	other threads:[~2016-09-14 18:54 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-09-14 14:48 [PATCH v5 0/5] Introduce " Deepa Dinamani
2016-09-14 14:48 ` [PATCH v5 1/5] vfs: Add " Deepa Dinamani
2016-09-14 18:52   ` Thomas Gleixner [this message]
2016-09-14 20:29     ` Deepa Dinamani
2016-09-14 20:33       ` Thomas Gleixner
2016-09-14 14:48 ` [PATCH v5 2/5] fs: proc: Delete inode time initializations in proc_alloc_inode() Deepa Dinamani
2016-09-14 14:48 ` [PATCH v5 3/5] fs: Replace CURRENT_TIME with current_time() for inode timestamps Deepa Dinamani
2016-09-14 14:48 ` [PATCH v5 4/5] fs: Replace CURRENT_TIME_SEC " Deepa Dinamani
2016-09-14 14:48 ` [PATCH v5 5/5] fs: Replace current_fs_time() with current_time() Deepa Dinamani
2016-09-14 16:45 ` [PATCH v5 0/5] Introduce current_time() api Linus Torvalds
2016-09-27 22:46   ` Al Viro

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.20.1609142049340.30349@nanos \
    --to=tglx@linutronix.de \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=deepa.kernel@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=tytso@mit.edu \
    --cc=viro@zeniv.linux.org.uk \
    --cc=y2038@lists.linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®