mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Andi Kleen <andi@firstfloor.org>,
	Jesse Barnes <jbarnes@virtuousgeek.org>,
	"Rafael J. Wysocki" <rjw@sisk.pl>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	linux-acpi@vger.kernel.org, Ingo Molnar <mingo@elte.hu>
Subject: [PATCH] Revert duplicate "dock: bay: Don't call acpi_walk_namespace() when ACPI is disabled" commit (was: Please pull ACPI updates)
Date: Fri, 18 Jul 2008 01:11:38 +0200 (CEST)	[thread overview]
Message-ID: <alpine.LFD.1.10.0807180013190.4316@apollo.tec.linutronix.de> (raw)
In-Reply-To: <alpine.LFD.1.10.0807170752190.2959@woody.linux-foundation.org>

On Thu, 17 Jul 2008, Linus Torvalds wrote:
> On Thu, 17 Jul 2008, Andi Kleen wrote:
> > 
> > My plan was to keep everything in quilt and just regenerate for the pull.
> > Please let me know if it's now not allowed anymore to use quilt.
> 
> End-point developers can use quilt all thei like.
> 
> But people cannot and *MUST NOT* destroy other peoples work with quilt, 
> nor make it harder for people to share commits.
> 
> Len had apparently left a nice topic tree for you. You took that work, and 
> then destroyed it. And yes, it is noticeable: Jesse had shared some of the 
> work from Len by pulling one of the branches (the 'suspend' branch), and 
> then you literally re-wrote _public_ history, so now tohose patches are 
> duplicated.

It's not only about destroying work and history, it can be worse than that.

For example look at commits:

816c2eda3ce8fa7eb62f22e01e2ec7a3f7d677c0 (merged between 2.6.26-rc8 and -rc9)
and
cc7e51666d82aedfd6b9a033ca1a10d71c21f1ca (merged now)

The export to quilt and the lazy default fuzz setting of quilt added
aside of Andi's Signed-off-by the following gem:

commit cc7e51666d82aedfd6b9a033ca1a10d71c21f1ca
Author: Len Brown <len.brown@intel.com>
Date:   Tue Jun 24 22:57:12 2008 -0400

    dock: bay: Don't call acpi_walk_namespace() when ACPI is disabled.
    
    Signed-off-by: Len Brown <len.brown@intel.com>
    Signed-off-by: Andi Kleen <ak@linux.intel.com>

diff --git a/drivers/acpi/bay.c b/drivers/acpi/bay.c
index 61b6c5b..e6caf5d 100644
--- a/drivers/acpi/bay.c
+++ b/drivers/acpi/bay.c
@@ -380,6 +380,9 @@ static int __init bay_init(void)
 	if (acpi_disabled)
 		return -ENODEV;
 
+	if (acpi_disabled)
+		return -ENODEV;
+
 	/* look for dockable drive bays */
 	acpi_walk_namespace(ACPI_TYPE_DEVICE, ACPI_ROOT_OBJECT,
 		ACPI_UINT32_MAX, find_bay, &bays, NULL);
diff --git a/drivers/acpi/dock.c b/drivers/acpi/dock.c
index bb7c51f..1e872e7 100644
--- a/drivers/acpi/dock.c
+++ b/drivers/acpi/dock.c
@@ -920,6 +920,9 @@ static int __init dock_init(void)
 	if (acpi_disabled)
 		return 0;
 
+	if (acpi_disabled)
+		return 0;
+
 	/* look for a dock station */
 	acpi_walk_namespace(ACPI_TYPE_DEVICE, ACPI_ROOT_OBJECT,
 			    ACPI_UINT32_MAX, find_dock, &num, NULL);

[ Note the code duplication in both files ]

I stumbled accross this incidentally while looking at the recent merge
commits.

While this one looks odd but harmless, probably a full audit of all
the affected commits should be done.

Please revert the one I happened to notice. Patch below.

Thanks,

	tglx

----------->
Subject: APCI: revert duplicated patch
From: Thomas Gleixner <tglx@linutronix.de>

commit 816c2eda3ce8fa7eb62f22e01e2ec7a3f7d677c0
    dock: bay: Don't call acpi_walk_namespace() when ACPI is disabled.  

was merged between 2.6.26-rc8 and -rc9)

Due to rebasing the ACPI tree via quilt the same patch got applied
again via 

commit cc7e51666d82aedfd6b9a033ca1a10d71c21f1ca
    dock: bay: Don't call acpi_walk_namespace() when ACPI is disabled.  

Revert it, as it is obviously bogus.

Signed-off-by: Thomas Gleixner <tglx@linutronix.de>

---
diff --git a/drivers/acpi/bay.c b/drivers/acpi/bay.c
index e6caf5d..61b6c5b 100644
--- a/drivers/acpi/bay.c
+++ b/drivers/acpi/bay.c
@@ -380,9 +380,6 @@ static int __init bay_init(void)
 	if (acpi_disabled)
 		return -ENODEV;
 
-	if (acpi_disabled)
-		return -ENODEV;
-
 	/* look for dockable drive bays */
 	acpi_walk_namespace(ACPI_TYPE_DEVICE, ACPI_ROOT_OBJECT,
 		ACPI_UINT32_MAX, find_bay, &bays, NULL);
diff --git a/drivers/acpi/dock.c b/drivers/acpi/dock.c
index 1e872e7..bb7c51f 100644
--- a/drivers/acpi/dock.c
+++ b/drivers/acpi/dock.c
@@ -920,9 +920,6 @@ static int __init dock_init(void)
 	if (acpi_disabled)
 		return 0;
 
-	if (acpi_disabled)
-		return 0;
-
 	/* look for a dock station */
 	acpi_walk_namespace(ACPI_TYPE_DEVICE, ACPI_ROOT_OBJECT,
 			    ACPI_UINT32_MAX, find_dock, &num, NULL);

  parent reply	other threads:[~2008-07-17 23:13 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-07-16 21:45 Please pull ACPI updates Andi Kleen
2008-07-16 22:11 ` Rafael J. Wysocki
2008-07-16 23:33   ` Jesse Barnes
2008-07-16 23:45     ` Linus Torvalds
2008-07-16 23:51       ` Jesse Barnes
2008-07-17  0:32         ` Linus Torvalds
2008-07-17  0:53           ` Linus Torvalds
2008-07-17  2:26             ` Jesse Barnes
2008-07-17  2:56               ` Linus Torvalds
2008-07-17  6:45           ` Andi Kleen
2008-07-17 15:06             ` Linus Torvalds
2008-07-17  6:40       ` Andi Kleen
2008-07-17 15:03         ` Linus Torvalds
2008-07-17 18:49           ` Len Brown
2008-07-17 19:12             ` Harvey Harrison
2008-07-17 19:50               ` Andi Kleen
2008-07-17 19:12             ` Linus Torvalds
2008-07-17 19:16               ` Linus Torvalds
2008-07-17 21:15             ` J. Bruce Fields
2008-07-17 23:11           ` Thomas Gleixner [this message]
2008-07-17 23:25             ` [PATCH] Revert duplicate "dock: bay: Don't call acpi_walk_namespace() when ACPI is disabled" commit Andi Kleen
2008-07-18  0:07             ` [PATCH] Revert duplicate "ACPI: don't walk tables if ACPI was disabled" commit (was: Please pull ACPI updates) Thomas Gleixner
2008-07-17  6:47     ` Please pull ACPI updates Andi Kleen
2008-07-17 15:18       ` Linus Torvalds
2008-07-17 15:47         ` Linus Torvalds
2008-07-17 16:02           ` Linus Torvalds
2008-07-17 16:23           ` Andi Kleen
2008-07-17 19:11             ` Ray Lee
2008-07-17 19:49               ` Andi Kleen
2008-07-17 20:01                 ` Linus Torvalds
2008-07-17 20:14                   ` Andi Kleen
2008-07-17 20:16                   ` Linus Torvalds
2008-07-17 20:28                     ` Linus Torvalds
2008-07-18 13:25                       ` Olivier Galibert
2008-07-18 15:57                         ` Ray Lee
2008-07-17 20:34                     ` Andi Kleen
2008-07-17 20:11                 ` Ray Lee
2008-07-17 20:29                   ` Andi Kleen
2008-07-18  6:39                     ` david

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.1.10.0807180013190.4316@apollo.tec.linutronix.de \
    --to=tglx@linutronix.de \
    --cc=andi@firstfloor.org \
    --cc=jbarnes@virtuousgeek.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=rjw@sisk.pl \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®