* [PATCH] Correct comment in identify_ramdisk_image() routine.
@ 2008-08-05 22:36 Robert P. J. Day
0 siblings, 0 replies; only message in thread
From: Robert P. J. Day @ 2008-08-05 22:36 UTC (permalink / raw)
To: trivial; +Cc: Linux Kernel Mailing List
Correct the comment to reflect that a gzipped image will return zero,
not -1.
Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca>
---
the code is correct, it's only the comment that's wrong.
diff --git a/init/do_mounts_rd.c b/init/do_mounts_rd.c
index fedef93..a7c748f 100644
--- a/init/do_mounts_rd.c
+++ b/init/do_mounts_rd.c
@@ -71,7 +71,7 @@ identify_ramdisk_image(int fd, int start_block)
sys_read(fd, buf, size);
/*
- * If it matches the gzip magic numbers, return -1
+ * If it matches the gzip magic numbers, return 0
*/
if (buf[0] == 037 && ((buf[1] == 0213) || (buf[1] == 0236))) {
printk(KERN_NOTICE
========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry:
Have classroom, will lecture.
http://crashcourse.ca Waterloo, Ontario, CANADA
========================================================================
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2008-08-05 22:38 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-08-05 22:36 [PATCH] Correct comment in identify_ramdisk_image() routine Robert P. J. Day
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®