mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Torben Hohn <torbenh@gmx.de>
Cc: linux-kernel@vger.kernel.org, johnstul@us.ibm.com,
	hch@infradead.org, yong.zhang0@gmail.com
Subject: Re: [PATCH 02/18] provide xtime_update() which does not require holding xtime_lock like do_timer()
Date: Sat, 22 Jan 2011 11:36:28 +0100 (CET)	[thread overview]
Message-ID: <alpine.LFD.2.00.1101221131000.2971@localhost6.localdomain6> (raw)
In-Reply-To: <1295651224-29823-3-git-send-email-torbenh@gmx.de>

On Sat, 22 Jan 2011, Torben Hohn wrote:

> some arch code failed to lock the xtime_lock.
> and some code looks like its using the xtime_lock to protect
> other stuff.

That's not a good argument for creating xtime_update().

The point is that do_timer() needs to write lock xtime_lock and we
want to avoid the duplicated code all over the place.

The fact that some of the architectures have other code in the
xtime_lock protected region is completely irrelevant for this
change. That needs to be addressed by the arch specific patches.

> +
> +/* xtime_update - updates the timer infrastructure.

Please use proper kernel doc style. Also it does not update the timer
infrastructure, it's the timekeeping update.

The comment should also document, that this code needs to be called
with interrupts disabled.

Thanks,

	tglx

  reply	other threads:[~2011-01-22 10:36 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-01-21 23:06 make arch code use xtime_update() instead of do_timer() Torben Hohn
2011-01-21 23:06 ` [PATCH 01/18] move do_timer() from kernel/timer.c into kernel/time/timekeeping.c Torben Hohn
2011-01-22  9:45   ` Thomas Gleixner
2011-01-24 20:32   ` john stultz
2011-01-24 22:10     ` Thomas Gleixner
2011-01-24 22:21       ` Peter Zijlstra
2011-01-24 22:44         ` Thomas Gleixner
2011-01-25  9:08           ` Peter Zijlstra
2011-01-25 10:34             ` Peter Zijlstra
2011-01-25 16:51               ` Peter Zijlstra
2011-01-26  5:56                 ` Yong Zhang
2011-01-26  6:49                   ` Yong Zhang
2011-01-26 10:03                   ` Peter Zijlstra
2011-01-26 11:11                     ` Yong Zhang
2011-01-21 23:06 ` [PATCH 02/18] provide xtime_update() which does not require holding xtime_lock like do_timer() Torben Hohn
2011-01-22 10:36   ` Thomas Gleixner [this message]
2011-01-21 23:06 ` [PATCH 03/18] alpha: change do_timer() to xtime_update() Torben Hohn
2011-01-21 23:06 ` [PATCH 04/18] arm: switch from " Torben Hohn
2011-01-21 23:06 ` [PATCH 05/18] arm/mach-clps711x: switch " Torben Hohn
2011-01-21 23:06 ` [PATCH 06/18] blackfin: switch from " Torben Hohn
2011-01-21 23:06 ` [PATCH 07/18] cris/arch-v10: switch " Torben Hohn
2011-01-21 23:06 ` [PATCH 08/18] cris/arch-v32: " Torben Hohn
2011-01-21 23:06 ` [PATCH 09/18] frv: " Torben Hohn
2011-01-22 10:01   ` Thomas Gleixner
2011-01-24 12:51     ` torbenh
2011-01-24 13:09       ` Thomas Gleixner
2011-01-21 23:06 ` [PATCH 10/18] h8300: " Torben Hohn
2011-01-21 23:06 ` [PATCH 11/18] ia64: " Torben Hohn
2011-01-21 23:06 ` [PATCH 12/18] m32r: switch from " Torben Hohn
2011-01-21 23:06 ` [PATCH 13/18] m68k: switch " Torben Hohn
2011-01-21 23:07 ` [PATCH 14/18] mn10300: switch do_timer() to xtimer_update() Torben Hohn
2011-01-21 23:07 ` [PATCH 15/18] parisc: switch do_timer() to xtime_update() Torben Hohn
2011-01-21 23:07 ` [PATCH 16/18] sparc: " Torben Hohn
2011-01-22  0:51   ` David Miller
2011-01-21 23:07 ` [PATCH 17/18] xtensa: " Torben Hohn
2011-01-21 23:07 ` [PATCH 18/18] make do_timer() and xtime_lock private to the timer code Torben Hohn
2011-01-22 10:14 ` make arch code use xtime_update() instead of do_timer() Thomas Gleixner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.2.00.1101221131000.2971@localhost6.localdomain6 \
    --to=tglx@linutronix.de \
    --cc=hch@infradead.org \
    --cc=johnstul@us.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=torbenh@gmx.de \
    --cc=yong.zhang0@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®