mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Seiji Aguchi <seiji.aguchi@hds.com>
Cc: Steven Rostedt <rostedt@goodmis.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"fweisbec@gmail.com" <fweisbec@gmail.com>,
	"'mingo@elte.hu' (mingo@elte.hu)" <mingo@elte.hu>,
	"vnagarnaik@google.com" <vnagarnaik@google.com>,
	"x86@kernel.org" <x86@kernel.org>,
	"dle-develop@lists.sourceforge.net" 
	<dle-develop@lists.sourceforge.net>,
	Satoru Moriya <satoru.moriya@hds.com>
Subject: RE: [PATCH]trace,x86: add x86 irq vector tracepoints
Date: Fri, 13 Jul 2012 21:20:19 +0200 (CEST)	[thread overview]
Message-ID: <alpine.LFD.2.02.1207132115500.32033@ionos> (raw)
In-Reply-To: <A5ED84D3BB3A384992CBB9C77DEDA4D40F08E421@USINDEM101.corp.hds.com>

On Fri, 13 Jul 2012, Seiji Aguchi wrote:

> > Those x86 specific ones are not really frequently raised vectors,
> > so enabling them all won't affect performance and readability of
> > the traces too much.
> 
> OK. I will unify these to a single tracepoint.
> "x86_irq_vector" or so?

I'd rather see a real generic one, which can be used by other
architectures for their esoteric non common vectors as well.

Something like misc_vector_entry/exit. Any better name is welcome :)

Thanks,

	tglx



      reply	other threads:[~2012-07-13 19:20 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-03 22:29 Seiji Aguchi
2012-07-05 20:44 ` Steven Rostedt
2012-07-06  9:22   ` Ingo Molnar
2012-07-13 14:50   ` Seiji Aguchi
2012-07-13 15:48     ` Thomas Gleixner
2012-07-13 16:32       ` Seiji Aguchi
2012-07-13 19:20         ` Thomas Gleixner [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.2.02.1207132115500.32033@ionos \
    --to=tglx@linutronix.de \
    --cc=dle-develop@lists.sourceforge.net \
    --cc=fweisbec@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=rostedt@goodmis.org \
    --cc=satoru.moriya@hds.com \
    --cc=seiji.aguchi@hds.com \
    --cc=vnagarnaik@google.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®