From: Hugh Dickins <hughd@google.com>
To: Cong Wang <xiyou.wangcong@gmail.com>
Cc: linux-kernel@vger.kernel.org,
Andrew Morton <akpm@linux-foundation.org>,
Oleg Nesterov <oleg@redhat.com>,
Alexey Dobriyan <adobriyan@gmail.com>,
Al Viro <viro@zeniv.linux.org.uk>,
Vasiliy Kulikov <segoon@openwall.com>,
David Rientjes <rientjes@google.com>,
"Eric W. Biederman" <ebiederm@xmission.com>,
Stephen Wilson <wilsons@start.ca>,
Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com>,
KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>,
Naoya Horiguchi <n-horiguchi@ah.jp.nec.com>
Subject: Re: [PATCH 3/6] proc: remove mm_for_maps()
Date: Wed, 11 Apr 2012 17:38:50 -0700 (PDT) [thread overview]
Message-ID: <alpine.LSU.2.00.1204111737300.26607@eggly.anvils> (raw)
In-Reply-To: <1334123976-11681-3-git-send-email-xiyou.wangcong@gmail.com>
On Wed, 11 Apr 2012, Cong Wang wrote:
> mm_for_maps() is a simple wrapper for mm_access(),
> and the name is misleading, so just remove it and use
> mm_access() directly.
>
> Cc: Oleg Nesterov <oleg@redhat.com>
> Cc: Alexey Dobriyan <adobriyan@gmail.com>
> Signed-off-by: Cong Wang <xiyou.wangcong@gmail.com>
Yes, this is an improvement in my eyes.
Acked-by: Hugh Dickins <hughd@google.com>
> ---
> fs/proc/base.c | 7 +------
> fs/proc/internal.h | 2 --
> fs/proc/task_mmu.c | 4 ++--
> fs/proc/task_nommu.c | 2 +-
> 4 files changed, 4 insertions(+), 11 deletions(-)
>
> diff --git a/fs/proc/base.c b/fs/proc/base.c
> index 919d14c..8608a4d 100644
> --- a/fs/proc/base.c
> +++ b/fs/proc/base.c
> @@ -198,11 +198,6 @@ static int proc_root_link(struct dentry *dentry, struct path *path)
> return result;
> }
>
> -struct mm_struct *mm_for_maps(struct task_struct *task)
> -{
> - return mm_access(task, PTRACE_MODE_READ);
> -}
> -
> static int proc_pid_cmdline(struct task_struct *task, char * buffer)
> {
> int res = 0;
> @@ -242,7 +237,7 @@ out:
>
> static int proc_pid_auxv(struct task_struct *task, char *buffer)
> {
> - struct mm_struct *mm = mm_for_maps(task);
> + struct mm_struct *mm = mm_access(task, PTRACE_MODE_READ);
> int res = PTR_ERR(mm);
> if (mm && !IS_ERR(mm)) {
> unsigned int nwords = 0;
> diff --git a/fs/proc/internal.h b/fs/proc/internal.h
> index 5f79bb8..a306437 100644
> --- a/fs/proc/internal.h
> +++ b/fs/proc/internal.h
> @@ -31,8 +31,6 @@ struct vmalloc_info {
> unsigned long largest_chunk;
> };
>
> -extern struct mm_struct *mm_for_maps(struct task_struct *);
> -
> #ifdef CONFIG_MMU
> #define VMALLOC_TOTAL (VMALLOC_END - VMALLOC_START)
> extern void get_vmalloc_info(struct vmalloc_info *vmi);
> diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
> index 2b9a760..03360a1 100644
> --- a/fs/proc/task_mmu.c
> +++ b/fs/proc/task_mmu.c
> @@ -125,7 +125,7 @@ static void *m_start(struct seq_file *m, loff_t *pos)
> if (!priv->task)
> return ERR_PTR(-ESRCH);
>
> - mm = mm_for_maps(priv->task);
> + mm = mm_access(priv->task, PTRACE_MODE_READ);
> if (!mm || IS_ERR(mm))
> return mm;
> down_read(&mm->mmap_sem);
> @@ -914,7 +914,7 @@ static ssize_t pagemap_read(struct file *file, char __user *buf,
> if (!pm.buffer)
> goto out_task;
>
> - mm = mm_for_maps(task);
> + mm = mm_access(task, PTRACE_MODE_READ);
> ret = PTR_ERR(mm);
> if (!mm || IS_ERR(mm))
> goto out_free;
> diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
> index 74fe164..1ccfa53 100644
> --- a/fs/proc/task_nommu.c
> +++ b/fs/proc/task_nommu.c
> @@ -223,7 +223,7 @@ static void *m_start(struct seq_file *m, loff_t *pos)
> if (!priv->task)
> return ERR_PTR(-ESRCH);
>
> - mm = mm_for_maps(priv->task);
> + mm = mm_access(priv->task, PTRACE_MODE_READ);
> if (!mm || IS_ERR(mm)) {
> put_task_struct(priv->task);
> priv->task = NULL;
> --
> 1.7.7.6
>
>
next prev parent reply other threads:[~2012-04-12 0:39 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-04-11 5:59 [PATCH 1/6 v3] proc: clean up /proc/<pid>/environ handling Cong Wang
2012-04-11 5:59 ` [PATCH 2/6] proc: unify ptrace_may_access locking code Cong Wang
2012-04-11 5:59 ` [PATCH 3/6] proc: remove mm_for_maps() Cong Wang
2012-04-12 0:38 ` Hugh Dickins [this message]
2012-04-11 5:59 ` [PATCH 4/6] proc: use mm_access() instead of ptrace_may_access() Cong Wang
2012-04-11 5:59 ` [PATCH 5/6] proc: use task_access_lock() " Cong Wang
2012-04-12 13:22 ` Cong Wang
2012-04-12 15:29 ` Djalal Harouni
2012-04-11 5:59 ` [PATCH 6/6] proc: use IS_ERR_OR_NULL() Cong Wang
2012-04-12 0:41 ` Hugh Dickins
2012-04-12 13:17 ` Cong Wang
2012-04-12 13:23 ` Alexey Dobriyan
2012-04-12 18:46 ` KOSAKI Motohiro
2012-04-12 19:26 ` Hugh Dickins
2012-04-12 19:31 ` Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LSU.2.00.1204111737300.26607@eggly.anvils \
--to=hughd@google.com \
--cc=adobriyan@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=ebiederm@xmission.com \
--cc=kosaki.motohiro@jp.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=n-horiguchi@ah.jp.nec.com \
--cc=oleg@redhat.com \
--cc=rientjes@google.com \
--cc=segoon@openwall.com \
--cc=siddhesh.poyarekar@gmail.com \
--cc=viro@zeniv.linux.org.uk \
--cc=wilsons@start.ca \
--cc=xiyou.wangcong@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®