mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Breno Leitao <leitao@debian.org>
To: Tejun Heo <tj@kernel.org>
Cc: Lai Jiangshan <jiangshanlai@gmail.com>,
	linux-kernel@vger.kernel.org,  marco.crivellari@suse.com,
	kernel-team@meta.com
Subject: Re: [PATCH v2 4/9] workqueue: account nr_active by the backing pool
Date: Tue, 11 Aug 2026 03:15:01 -0700	[thread overview]
Message-ID: <anr2Df_PyQPMRnPo@gmail.com> (raw)
In-Reply-To: <anpFg_3VzrZVEZ59@slm.duckdns.org>

On Mon, Aug 10, 2026 at 11:41:23AM -1000, Tejun Heo wrote:
> On Wed, Aug 05, 2026 at 07:52:31AM -0700, Breno Leitao wrote:
> >  static struct wq_node_nr_active *wq_node_nr_active(struct workqueue_struct *wq,
> >  						   int node)
> >  {
> > -	if (!(wq->flags & WQ_UNBOUND))
> > +	if (WARN_ON_ONCE(!(wq->flags & WQ_UNBOUND)))
> >  		return NULL;
> 
> This just pushes the crash to the caller, right? Maybe do BUG_ON() instead?

Right. I will do a patch that transform this in BUG_ON() in the next
patchset.


Thanks for the review,
--breno

  reply	other threads:[~2026-08-11 10:15 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-05 14:52 [PATCH v2 0/9] workqueue: base pwq pool release and nr_active on " Breno Leitao
2026-08-05 14:52 ` [PATCH v2 1/9] workqueue: factor out get_percpu_pool() Breno Leitao
2026-08-05 14:52 ` [PATCH v2 2/9] workqueue: factor out alloc_and_link_percpu_pwqs() Breno Leitao
2026-08-05 14:52 ` [PATCH v2 3/9] workqueue: release pwq pools by pool type Breno Leitao
2026-08-05 14:52 ` [PATCH v2 4/9] workqueue: account nr_active by the backing pool Breno Leitao
2026-08-10 21:41   ` Tejun Heo
2026-08-11 10:15     ` Breno Leitao [this message]
2026-08-05 14:52 ` [PATCH v2 5/9] workqueue: test WQ_UNBOUND explicitly in the hotplug loops Breno Leitao
2026-08-05 14:52 ` [PATCH v2 6/9] workqueue: rename wq->unbound_attrs to wq->attrs Breno Leitao
2026-08-05 14:52 ` [PATCH v2 7/9] workqueue: allocate attrs for all workqueues Breno Leitao
2026-08-05 14:52 ` [PATCH v2 8/9] workqueue: rename alloc_unbound_pwq() to alloc_pwq() Breno Leitao
2026-08-05 14:52 ` [PATCH v2 9/9] workqueue: skip the node_nr_active update for non-unbound workqueues Breno Leitao
2026-08-10 22:10 ` [PATCH v2 0/9] workqueue: base pwq pool release and nr_active on the backing pool Tejun Heo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=anr2Df_PyQPMRnPo@gmail.com \
    --to=leitao@debian.org \
    --cc=jiangshanlai@gmail.com \
    --cc=kernel-team@meta.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marco.crivellari@suse.com \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®