* [PATCH] firmware: google: use named initializers for acpi_device_id
@ 2026-09-04 15:24 Pawel Zalewski
2026-09-07 4:21 ` Tzung-Bi Shih
0 siblings, 1 reply; 3+ messages in thread
From: Pawel Zalewski @ 2026-09-04 15:24 UTC (permalink / raw)
To: Tzung-Bi Shih, Brian Norris, Julius Werner
Cc: chrome-platform, linux-kernel, Pawel Zalewski
Use a named initializer for the acpi_device_id fields which
makes the code more readable and consistent with how lists
are initialized in the rest of the kernel code base. Also
drop explicitly setting fields to 0 where it is redundant.
Signed-off-by: Pawel Zalewski <pzalewski@thegoodpenguin.co.uk>
---
This series is converting lists that contain the acpi_device_id
struct, which is defined in the include/linux/device-id/acpi.h
to make use of named initializers (which they do not use currently).
This work is part of the on going effort in the kernel associated
with device-ids [1]
The plan is to convert acpi_device_id::driver_data to have an
anonymous union, similarly to what was introduced for PCI and I2C
device ID tables.The goal is to increase type-safety (as most of
the existing casts are gone), to improve readability and to make
use intent a bit more clear:
```
union {
kernel_ulong_t driver_data;
const void *driver_data_ptr;
}
```
But for that to work all lists containing the structs need to
use named initializers first to avoid triggering -Wmissing-braces.
I already have patches that implement this and touching a lot of
kernel subsystmes that use the acpi_device_id struct and that list
keeps on growing. Therefore, I have decided to split the series per
every subsystem into:
- pre-clean-ups that convert the lists to use named initializers
(which is this series)
- actual implementations that make some of the modules use the
driver_data_ptr union member
That way the task can be fragmented into manageable and independent
chunks of work and makes this effort easier to review.
Tested builds on a64 in Yocto using 7.3-rc1.
[1] https://lore.kernel.org/all/cover.1780048925.git.u.kleine-koenig@baylibre.com/
---
drivers/firmware/google/coreboot_table.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/firmware/google/coreboot_table.c b/drivers/firmware/google/coreboot_table.c
index 25ee8cf53429..2c8c928fbb33 100644
--- a/drivers/firmware/google/coreboot_table.c
+++ b/drivers/firmware/google/coreboot_table.c
@@ -250,8 +250,8 @@ static void coreboot_table_remove(struct platform_device *pdev)
#ifdef CONFIG_ACPI
static const struct acpi_device_id cros_coreboot_acpi_match[] = {
- { "GOOGCB00", 0 },
- { "BOOT0000", 0 },
+ { .id = "GOOGCB00" },
+ { .id = "BOOT0000" },
{ }
};
MODULE_DEVICE_TABLE(acpi, cros_coreboot_acpi_match);
---
base-commit: bc35965f6940a9bf834d54187b6088b8eb09206d
change-id: 20260904-acpi-firmware-5c9fd18aaea0
Best regards,
--
Pawel Zalewski <pzalewski@thegoodpenguin.co.uk>
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] firmware: google: use named initializers for acpi_device_id
2026-09-04 15:24 [PATCH] firmware: google: use named initializers for acpi_device_id Pawel Zalewski
@ 2026-09-07 4:21 ` Tzung-Bi Shih
2026-09-07 6:29 ` Pawel Zalewski
0 siblings, 1 reply; 3+ messages in thread
From: Tzung-Bi Shih @ 2026-09-07 4:21 UTC (permalink / raw)
To: Pawel Zalewski; +Cc: Brian Norris, Julius Werner, chrome-platform, linux-kernel
On Fri, Sep 04, 2026 at 04:24:00PM +0100, Pawel Zalewski wrote:
> drivers/firmware/google/coreboot_table.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
The file has moved to drivers/firmware/coreboot/coreboot_table.c recently.
Please rebase to the latest linux-next or for-firmware-next branch of
https://git.kernel.org/pub/scm/linux/kernel/git/chrome-platform/linux.git/
and resend.
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] firmware: google: use named initializers for acpi_device_id
2026-09-07 4:21 ` Tzung-Bi Shih
@ 2026-09-07 6:29 ` Pawel Zalewski
0 siblings, 0 replies; 3+ messages in thread
From: Pawel Zalewski @ 2026-09-07 6:29 UTC (permalink / raw)
To: Tzung-Bi Shih; +Cc: Brian Norris, Julius Werner, chrome-platform, linux-kernel
> The file has moved to drivers/firmware/coreboot/coreboot_table.c recently.
> Please rebase to the latest linux-next or for-firmware-next branch of
> https://git.kernel.org/pub/scm/linux/kernel/git/chrome-platform/linux.git/
> and resend.
Ah, will do in v2.
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2026-09-07 6:30 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-09-04 15:24 [PATCH] firmware: google: use named initializers for acpi_device_id Pawel Zalewski
2026-09-07 4:21 ` Tzung-Bi Shih
2026-09-07 6:29 ` Pawel Zalewski
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®