mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: David Gibson <david@gibson.dropbear.id.au>
To: Herve Codina <herve.codina@bootlin.com>
Cc: Rob Herring <robh@kernel.org>,
	Krzysztof Kozlowski <krzk@kernel.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
	David Lechner <dlechner@baylibre.com>,
	Ayush Singh <ayush@beagleboard.org>,
	Geert Uytterhoeven <geert@linux-m68k.org>,
	devicetree-compiler@vger.kernel.org, devicetree@vger.kernel.org,
	linux-kernel@vger.kernel.org, devicetree-spec@vger.kernel.org,
	Hui Pu <hui.pu@gehealthcare.com>,
	Ian Ray <ian.ray@gehealthcare.com>,
	Luca Ceresoli <luca.ceresoli@bootlin.com>,
	Thomas Petazzoni <thomas.petazzoni@bootlin.com>,
	Frank Li <Frank.Li@nxp.com>
Subject: Re: [PATCH v3 09/15] libfdt: Handle unknown tags in fdt_next_tag()
Date: Sat, 19 Sep 2026 14:46:05 +1000	[thread overview]
Message-ID: <aq4Tg0cAD8z6IL9Q@gractus.seuss> (raw)
In-Reply-To: <20260917192814.70cbecbb@bootlin.com>

[-- Attachment #1: Type: text/plain, Size: 9022 bytes --]

On Thu, Sep 17, 2026 at 07:28:14PM +0200, Herve Codina wrote:
> Hi David,
> 
> On Thu, 17 Sep 2026 19:36:06 +1000
> David Gibson <david@gibson.dropbear.id.au> wrote:
> 
> > On Thu, Sep 17, 2026 at 10:34:10AM +0200, Herve Codina wrote:
> > > Hi David,
> > > 
> > > On Wed, 16 Sep 2026 19:10:27 +1000
> > > David Gibson <david@gibson.dropbear.id.au> wrote:
> > >   
> > > > On Wed, Aug 26, 2026 at 10:31:40AM +0200, Herve Codina wrote:  
> > > > > The structured tag value definition introduced recently gives the
> > > > > ability to ignore unknown tags without any error when they are read.
> > > > > 
> > > > > libfdt uses fdt_next_tag() to get a tag.
> > > > > 
> > > > > Filtering out tags that should be ignored in fdt_next_tag() allows to
> > > > > have the filtering done globally and allows, in future releases, to have
> > > > > a central place to add new known tags that should not be filtered out.
> > > > > 
> > > > > An already known tag exists with the meaning of "just ignore". This tag
> > > > > is FDT_NOP. fdt_next_tag() callers already handle the FDT_NOP tag.
> > > > > 
> > > > > Avoid unneeded modification at callers side and use a fake FDT_NOP tag
> > > > > when an unknown tag that should be ignored is encountered.
> > > > > 
> > > > > Add also fdt_next_tag_() internal function for callers who need to know
> > > > > if the FDT_NOP tag returned is a real FDT_NOP or a fake FDT_NOP due to
> > > > > an unknown tag.    
> > > > 
> > > > I'm a bit unsure about this one.  If we were designing the libfdt
> > > > interface from scratch, I'd definitely say that fdt_next_tag() - as a
> > > > low level function - should return every tag, and it's up to the
> > > > caller to skip unknown ones.  fdt_next_tag() already provides
> > > > nextoffset making it fairly easy to do so.
> > > > 
> > > > But, of course, we're not building from scratch so we do need to
> > > > consider backwards compatibility.  Supplying a skipping and
> > > > non-skipping version as you have here is the obvious approach.
> > > > 
> > > > But I'm not entirely convinced it's the only or best approach.  A user
> > > > which calls fdt_next_tag() is, in a sense, already opting in to
> > > > low-level handling of the dtb.  They could well already be broken by
> > > > new tags (depending on how they handle the default case).  Arguably
> > > > it's reasonable to require them to be updated (once only) for this new
> > > > family of tags.  
> > > 
> > > I can go in that way. We will have same kind of sequence in almost all
> > > callers.
> > > 
> > >    do {
> > >       tag = fdt_next_tag()
> > >    } while (!fdt_tag_is_unknown(tag));  
> > 
> > Not really - users of fdt_next_tag() will typically already have a
> > switch on the tag type, so the unknown tag handling would be an
> > addition to the 'default' case, not requiring an extra loop.
> 
> Ok, those are to be update to use a switch on tag but that's not big deal
>  - fdt_check_node_offset_()
>  - fdt_check_prop_offset_()

These don't have a switch because they're asserting we're already on a
specific tag type.  They should still do that with structured tags:
these functions should be checking that we're exactly on an
FDT_BEGIN_NODE or FDT_PROP, not on a skippable tag that sits before
one of those.

Or to put it another way, if we did have fdt_next_tag()
vs. fdt_next_tag_all() these functions should be using
fdt_next_tag_all().

>  - fdt_add_subnode_namelen()

The logic here is placing the subnode after the parent's properties,
by moving past any FDT_PROP or FDT_NOP tags.  With skippable tags we
do need to skip those too.  Which we can express instead as skipping
until we find either an FDT_BEGIN_NODE (indicating the first child) or
an FDT_END_NODE (indicating the end of a currently childless parent).
So, no need for a new switch here.

>  - fdt_finish()

No need for changes here either - this already skips everything that's
not FDT_PROP, so it will do the right think for skippable tags.

> Some others like nextprop_() or fdt_next_node() mix a while loop and a
> switch/case. Some rework to be planned.

nextprop_() will need some rework, yes.

fdt_next_node() only barely: it already ignores FDT_PROP and FDT_NOP;
change that to 'default' and it will skip those and future structured
tags as well.

> > > We have to care about those "unknown_and_skippable" tags only when
> > > we modify a dtb. This is handled by a few functions.
> > > 
> > > The vast majority of callers of fdt_next_tag() just want to skip
> > > unknown tags.  
> > 
> > I'm not sure that's true of the (few) callers outside libfdt itself.
> 
> Well, today there is no "unknown" tags and existing callers works
> correctly.

Rather, any tags unknown by the caller are assumed fatal.

> Unknown tags are reported as FDT_NOP. It should be ok with existing callers.
> They should handle FDT_NOP.
> 
> > 
> > > > Another potential approach would be to actually use the symbol
> > > > versioning we have, but have som far only minimally exploited.  The
> > > > LIBFDT_1.2 version of fdt_next_tag() would skip tags that postdate it,
> > > > but we'd introduce a new version tag and the new default version of
> > > > fdt_next_tag() would return all tags.  That would of course require
> > > > figuring out how to do that with the verison script.  
> > > 
> > > Hum, I really don't want to have versioning in loop for fdt_next_tag().
> > 
> > I'm not sure what you mean by "in loop" here.
> 
> I don't want to add the versioning extra complexity in this context.
> I am sure we can find a solution for this "all tags vs only known tags"
> topic without versioning involved.

"known tags" is meaningless here - what matters is whether the tags
are known by the *caller*, which we don't know.

> > > Also, this could work in the dynamic lib (.so) case but not for static
> > > link and even less for libfdt code copy compiled in bootloaders or Linux
> > > kernel code.  
> > 
> > Are symbol versions entirely unsupported with static libraries?
> 
> I would say yes but maybe I am wrong.
> 
> https://sourceware.org/binutils/docs/ld/VERSION.html
> https://sourceware.org/binutils/docs/ld.html#index-_002d_002dversion_002dscript_003dversion_002dscriptfile

Ah, yes, I think you're right.  Ok, that's not going to work.
> 
> > Obviously they'd have to be resolved at (static) link time, not
> > runtime, but I don't see that it's impossible.
> > 
> > > fdt_next_tag() is a low level function accessible out of libfdt (API).
> > > If it doesn't skip unknown tags even for other libfdt internal function it
> > > will be a too lower function.  
> > 
> > I don't really follow what you're saying here.
> 
> Skipping unknown tag is a low level feature.
> I think fdt_next_tag() can handle this low level feature.

It really can't, because it doesn't know what tags the caller is aware
of.  It can only make a distinction between "older tags than
<arbitrary cutoff>" and "newer tags than <arbitrary cutoff>".

> Upper layer using fdt_next_tag() should not handle this tag skipping the
> general case and let fdt_next_tag() do this job.
> 
> Got the feeling that we are going to add complexity at upper layer to handle
> a feature that should be handled at low level.
> 
> > 
> > > Ok, we can have a wrapper on top of
> > > fdt_next_tag() to skip unknown tags.
> > > 
> > > fdt_next_tag() is a low level function but the rule related to skipping
> > > unknown tags is also a low level rule.
> > > 
> > > We have to choose:
> > > a) fdt_next_tag() as I proposed
> > >    Of course ok for me
> > > 
> > > b) fdt_next_tag() returns all tags -> Full handling at caller side
> > >    Ok, we can go in that direction but it will bring quite a lot of
> > >    code duplication.  
> > 
> > I'm not sure it's that bad, since fdt_next_tag() loops will typically
> > already have a 'default' case for irrelevant tags, which will
> > generally be handled the same as unknown tags.
> 
> Well as we did for "offset 0 vs real root node offset", I think the best way
> to known if it's bad or not is to try.

Agreed.

> I will not have time this week to propose something and I have a training
> next week.
> 
> If you're ok for a try, I will do it but not as quickly as I did for the
> "offset 0 vs real root node offset" topic.
> 
> > 
> > > I am not fully convinced by this option.
> > > 
> > > c) lib version
> > >    I disagree on my side  
> > 
> > Yeah, I'm not really convinced by this one either.
> 
> We are on the same page.
> 
> > 
> > > d) Other idea
> > >    Of course, I am still open.  
> > 
> > I haven't thought of any more ideas yet.
> > 
> 
> Best regards,
> Hervé
> 

-- 
David Gibson (he or they)	| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au	| minimalist, thank you, not the other way
				| around.
http://www.ozlabs.org/~dgibson

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  reply	other threads:[~2026-09-19  4:46 UTC|newest]

Thread overview: 68+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-26  8:31 [PATCH v3 00/15] Add support for structured tags and v18 dtb version Herve Codina
2026-08-26  8:31 ` [PATCH v3 01/15] fdtget: Use libfdt iterators instead of open coded loops Herve Codina
2026-08-27  3:55   ` David Gibson
2026-08-26  8:31 ` [PATCH v3 02/15] libfdt: Don't assume the root node is available at offset 0 Herve Codina
2026-08-30  3:21   ` David Gibson
2026-08-31 12:01     ` Herve Codina
2026-09-01  7:42       ` David Gibson
2026-09-01 12:18         ` Herve Codina
2026-09-02  7:06           ` David Gibson
2026-09-07 16:46             ` Herve Codina
2026-09-08  6:41               ` David Gibson
2026-09-08  8:08                 ` Herve Codina
2026-09-09  6:18                   ` David Gibson
2026-09-09  6:58                     ` Herve Codina
2026-09-09  7:02                       ` David Gibson
2026-08-26  8:31 ` [PATCH v3 03/15] tests: " Herve Codina
2026-09-01  8:03   ` David Gibson
2026-09-01 13:36     ` Herve Codina
2026-09-02  8:56       ` David Gibson
2026-08-26  8:31 ` [PATCH v3 04/15] tests/nopulate: Add a FDT_NOP before the root node Herve Codina
2026-09-01  8:05   ` David Gibson
2026-08-26  8:31 ` [PATCH v3 05/15] tests: treegen: Introduce emit_fdt_header_vers() Herve Codina
2026-09-09  6:38   ` David Gibson
2026-08-26  8:31 ` [PATCH v3 06/15] Introduce structured tag value definition Herve Codina
2026-09-10  4:51   ` David Gibson
2026-09-10  7:41     ` Herve Codina
2026-09-10  9:32       ` David Gibson
2026-09-11  7:16         ` Herve Codina
2026-09-12  2:34           ` David Gibson
2026-09-14 10:19             ` Herve Codina
2026-09-16  5:21               ` David Gibson
2026-09-17  7:04                 ` Herve Codina
2026-09-18  4:41                   ` David Gibson
2026-09-18  8:16                     ` Herve Codina
2026-09-19  4:22                       ` David Gibson
2026-09-10  5:33   ` David Gibson
2026-09-10  7:58     ` Herve Codina
2026-09-10  9:41       ` David Gibson
2026-09-11  7:53         ` Herve Codina
2026-09-12  2:35           ` David Gibson
2026-09-17  8:56             ` Herve Codina
2026-08-26  8:31 ` [PATCH v3 07/15] fdtdump: Handle unknown tags Herve Codina
2026-09-10  5:25   ` David Gibson
2026-08-26  8:31 ` [PATCH v3 08/15] flattree: " Herve Codina
2026-09-14  8:23   ` David Gibson
2026-09-15 10:16     ` Herve Codina
2026-09-15 11:52       ` David Gibson
2026-09-16  6:31         ` Herve Codina
2026-09-16  8:27           ` David Gibson
2026-09-17  7:11             ` Herve Codina
2026-08-26  8:31 ` [PATCH v3 09/15] libfdt: Handle unknown tags in fdt_next_tag() Herve Codina
2026-09-16  9:10   ` David Gibson
2026-09-17  8:34     ` Herve Codina
2026-09-17  9:36       ` David Gibson
2026-09-17 17:28         ` Herve Codina
2026-09-19  4:46           ` David Gibson [this message]
2026-08-26  8:31 ` [PATCH v3 10/15] libfdt: Introduce fdt_ptr_offset_() Herve Codina
2026-08-26  8:31 ` [PATCH v3 11/15] libfdt: Introduce fdt_getprop_by_offset_w() Herve Codina
2026-09-16  9:56   ` David Gibson
2026-09-16 10:42     ` Herve Codina
2026-09-17  4:52       ` David Gibson
2026-09-17  8:43         ` Herve Codina
2026-08-26  8:31 ` [PATCH v3 12/15] libfdt: Introduce fdt_getprop_offset_namelen() Herve Codina
2026-08-26  8:31 ` [PATCH v3 13/15] tests: Add wip_func utility Herve Codina
2026-09-16 10:00   ` David Gibson
2026-09-16 17:27     ` Herve Codina
2026-08-26  8:31 ` [PATCH v3 14/15] libfdt: Handle unknown tags on dtb modifications Herve Codina
2026-08-26  8:31 ` [PATCH v3 15/15] Introduce v18 dtb version Herve Codina

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aq4Tg0cAD8z6IL9Q@gractus.seuss \
    --to=david@gibson.dropbear.id.au \
    --cc=Frank.Li@nxp.com \
    --cc=ayush@beagleboard.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree-compiler@vger.kernel.org \
    --cc=devicetree-spec@vger.kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=geert@linux-m68k.org \
    --cc=herve.codina@bootlin.com \
    --cc=hui.pu@gehealthcare.com \
    --cc=ian.ray@gehealthcare.com \
    --cc=krzk@kernel.org \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luca.ceresoli@bootlin.com \
    --cc=robh@kernel.org \
    --cc=thomas.petazzoni@bootlin.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®