From: Boqun Feng <boqun@kernel.org>
To: "Paul E. McKenney" <paulmck@kernel.org>
Cc: rcu@vger.kernel.org, linux-kernel@vger.kernel.org,
kernel-team@meta.com,
Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
Steven Rostedt <rostedt@goodmis.org>,
lkmm@lists.linux.dev, Zqiang <qiang.zhang@linux.dev>,
Wang Lian <lianux.mm@gmail.com>,
Kunwu Chan <kunwu.chan@gmail.com>,
Bradley Morgan <brads@mainlining.org>
Subject: Re: [PATCH 19/28] hazptr: Permit detaching hazard pointers from contexts
Date: Sat, 19 Sep 2026 12:42:48 +0100 [thread overview]
Message-ID: <aq51OA4zu-p-nWyy@MacBook-0RXW5> (raw)
In-Reply-To: <20260919000056.3132131-19-paulmck@kernel.org>
On Fri, Sep 18, 2026 at 05:00:47PM -0700, Paul E. McKenney wrote:
> From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
>
> Provide a new hazptr_detach() function that detaches a given hazard
> pointer from its acquisition context. This context might be a task or
> an interrupt handler.
>
> [ paulmck: s/hazptr_detach_from_task/hazptr_detach/ per Mathieu. ]
>
> Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
> Signed-off-by: Paul E. McKenney <paulmck@kernel.org>
> Cc: Boqun Feng <boqun@kernel.org>
> Cc: <rcu@vger.kernel.org>
> Cc: <lkmm@lists.linux.dev>
> ---
> include/linux/hazptr.h | 55 ++++++++++++++++++++++++++++--------------
> 1 file changed, 37 insertions(+), 18 deletions(-)
>
> diff --git a/include/linux/hazptr.h b/include/linux/hazptr.h
> index b121f7779cda..8197a51b9f7a 100644
> --- a/include/linux/hazptr.h
> +++ b/include/linux/hazptr.h
> @@ -98,6 +98,41 @@ bool hazptr_slot_is_backup(struct hazptr_ctx *ctx, struct hazptr_slot *slot)
> return slot == &ctx->backup_slot.slot;
> }
>
> +/* Internal helper. */
> +static inline
> +void hazptr_promote_to_backup_slot(struct hazptr_ctx *ctx, struct hazptr_slot *slot)
> +{
> + struct hazptr_slot *backup_slot;
> +
> + backup_slot = hazptr_chain_backup_slot(ctx);
> + /*
> + * Move hazard pointer from the per-CPU slot to the
> + * backup slot. This requires hazard pointer
> + * synchronize to iterate on per-CPU slots with
> + * load-acquire before iterating on the overflow list.
> + */
> + WRITE_ONCE(backup_slot->addr, slot->addr);
> + /*
> + * store-release orders store to backup slot addr before
> + * store to per-CPU slot addr.
> + */
> + smp_store_release(&slot->addr, NULL);
> + /* Use the backup slot for context. */
> + ctx->slot = backup_slot;
> +}
> +
Probably needs a function doc for hazptr_detach(), how about the
following?
/*
* hazptr_detach: Detach the hazptr from its acquisition context.
*
* By default hazptr_acquire() expects to be released from its
* acquisition context. However there are cases where the acquisition
* context sends (in other words, transfers the ownership of) the hazptr
* to another context, e.g.
*
* hazptr_acquire(ctx, gp);
* hazptr_detach(ctx);
* defer_work->hp = ctx;
* queue_work(..., defer_work);
* <in defer_work->func()>
* hazptr_release(ctx);
*
* Use hazptr_detach() before sending the hazptr across contexts.
*
* It's safe to detach an "already-detatched" hazptr.
*/
Thoughts?
Regards,
Boqun
> +static inline
> +void hazptr_detach(struct hazptr_ctx *ctx)
> +{
> + struct hazptr_slot *slot;
> +
> + guard(preempt)();
> + slot = ctx->slot;
> + if (unlikely(hazptr_slot_is_backup(ctx, slot)))
> + return;
> + hazptr_promote_to_backup_slot(ctx, slot);
> +}
> +
> static inline
> void hazptr_note_context_switch(void)
> {
> @@ -106,27 +141,11 @@ void hazptr_note_context_switch(void)
>
> for (idx = 0; idx < NR_HAZPTR_PERCPU_SLOTS; idx++) {
> struct hazptr_slot_item *item = &percpu_slots->items[idx];
> - struct hazptr_slot *slot = &item->slot, *backup_slot;
> - struct hazptr_ctx *ctx;
> + struct hazptr_slot *slot = &item->slot;
>
> if (!slot->addr)
> continue;
> - ctx = item->ctx.ctx;
> - backup_slot = hazptr_chain_backup_slot(ctx);
> - /*
> - * Move hazard pointer from the per-CPU slot to the
> - * backup slot. This requires hazard pointer
> - * synchronize to iterate on per-CPU slots with
> - * load-acquire before iterating on the overflow list.
> - */
> - WRITE_ONCE(backup_slot->addr, slot->addr);
> - /*
> - * store-release orders store to backup slot addr before
> - * store to per-CPU slot addr.
> - */
> - smp_store_release(&slot->addr, NULL);
> - /* Use the backup slot for context. */
> - ctx->slot = backup_slot;
> + hazptr_promote_to_backup_slot(item->ctx.ctx, slot);
> }
> }
>
> --
> 2.40.1
>
next prev parent reply other threads:[~2026-09-19 11:42 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-18 23:59 [PATCH RFC v3 0/28] Simple hazard-pointer implementation and torture tests Paul E. McKenney
2026-09-19 0:00 ` [PATCH 01/28] hazptr: Implement Hazard Pointers Paul E. McKenney
2026-09-19 11:12 ` Bradley Morgan
2026-09-19 16:30 ` Linus Torvalds
2026-09-19 16:34 ` Bradley Morgan
2026-09-19 17:00 ` Linus Torvalds
2026-09-19 17:09 ` Mathieu Desnoyers
2026-09-19 18:09 ` Boqun Feng
2026-09-19 17:19 ` Mathieu Desnoyers
2026-09-19 18:18 ` Paul E. McKenney
2026-09-19 16:41 ` Bradley Morgan
2026-09-19 17:56 ` Paul E. McKenney
2026-09-19 0:00 ` [PATCH 02/28] hazptr: Add refscale test Paul E. McKenney
2026-09-19 0:00 ` [PATCH 03/28] torture: Add a hazptrtorture.c torture test Paul E. McKenney
2026-09-19 0:00 ` [PATCH 04/28] hazptrtorture: Add testing of on-stack hazptr_ctx structures Paul E. McKenney
2026-09-19 0:00 ` [PATCH 05/28] hazptrtorture: Add microsecond-scale sleep in readers Paul E. McKenney
2026-09-19 0:00 ` [PATCH 06/28] hazptrtorture: Enable system-independent CPU overcommit Paul E. McKenney
2026-09-19 0:00 ` [PATCH 07/28] torture: Add a stutter_will_wait() function Paul E. McKenney
2026-09-19 0:00 ` [PATCH 08/28] hazptrtorture: Use mnemonic local variables for context information Paul E. McKenney
2026-09-19 0:00 ` [PATCH 09/28] hazptrtorture: Split hazptr_torture_reader_tail() from hazptr_torture_reader() Paul E. McKenney
2026-09-19 0:00 ` [PATCH 10/28] hazptrtorture: Add kthread to release deferred hazard pointers Paul E. McKenney
2026-09-19 0:00 ` [PATCH 11/28] hazptrtorture: Defer release of " Paul E. McKenney
2026-09-19 0:00 ` [PATCH 12/28] hazptrtorture: Add irq_acquire to acquire hazptr from irq Paul E. McKenney
2026-09-19 0:00 ` [PATCH 13/28] hazptrtorture: Use task_state_to_char() for task-state reporting Paul E. McKenney
2026-09-19 0:00 ` [PATCH 14/28] hazptrtorture: Pass hazptr_pending to hazptr_torture_reader_tail() Paul E. McKenney
2026-09-19 0:00 ` [PATCH 15/28] hazptrtorture: Add the ability to disable the writer kthread Paul E. McKenney
2026-09-19 0:00 ` [PATCH 16/28] hazptrtorture: Add irq_release to release hazptr from irq Paul E. McKenney
2026-09-19 0:00 ` [PATCH 17/28] hazptrtorture: Accumulate operation statistics Paul E. McKenney
2026-09-19 0:00 ` [PATCH 18/28] doc: Add hazptrtorture module parameters Paul E. McKenney
2026-09-19 0:00 ` [PATCH 19/28] hazptr: Permit detaching hazard pointers from contexts Paul E. McKenney
2026-09-19 11:42 ` Boqun Feng [this message]
2026-09-19 11:43 ` Boqun Feng
2026-09-19 0:00 ` [PATCH 20/28] hazptrtorture: Detach deferred and IPIed hazard pointers Paul E. McKenney
2026-09-19 0:00 ` [PATCH 21/28] hazptr: Introduce CONFIG_HAZPTR_DEBUG misuse detection Paul E. McKenney
2026-09-19 0:00 ` [PATCH 22/28] hazptrtorture: Fix hazptr ownership issue Paul E. McKenney
2026-09-19 0:00 ` [PATCH 23/28] hazptrtorture: Enable CONFIG_HAZPTR_DEBUG Paul E. McKenney
2026-09-19 0:00 ` [PATCH 24/28] hazptr: Upgrade kernel-doc headers Paul E. McKenney
2026-09-19 0:00 ` [PATCH 25/28] hazptrtorture: Fix inverted sleep condition in do_pending kthread Paul E. McKenney
2026-09-19 0:00 ` [PATCH 26/28] hazptr: Implement two-phase wildcard scan Paul E. McKenney
2026-09-19 13:28 ` Boqun Feng
2026-09-19 0:00 ` [PATCH 27/28] hazptr: handle NULL address in hazptr_detach Paul E. McKenney
2026-09-19 0:00 ` [PATCH 28/28] torture.sh: Add hazptr torturing Paul E. McKenney
2026-09-19 11:18 ` Bradley Morgan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aq51OA4zu-p-nWyy@MacBook-0RXW5 \
--to=boqun@kernel.org \
--cc=brads@mainlining.org \
--cc=kernel-team@meta.com \
--cc=kunwu.chan@gmail.com \
--cc=lianux.mm@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lkmm@lists.linux.dev \
--cc=mathieu.desnoyers@efficios.com \
--cc=paulmck@kernel.org \
--cc=qiang.zhang@linux.dev \
--cc=rcu@vger.kernel.org \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®