From: "Lorenzo Stoakes (ARM)" <ljs@kernel.org>
To: "David Hildenbrand (Arm)" <david@kernel.org>
Cc: Andrew Morton <akpm@linux-foundation.org>,
"Liam R. Howlett" <liam@infradead.org>,
Vlastimil Babka <vbabka@kernel.org>,
Mike Rapoport <rppt@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>, Kairui Song <kasong@tencent.com>,
Qi Zheng <qi.zheng@linux.dev>,
Shakeel Butt <shakeel.butt@linux.dev>,
Barry Song <baohua@kernel.org>,
Axel Rasmussen <axelrasmussen@google.com>,
Yuanchu Xie <yuanchu@google.com>, Wei Xu <weixugc@google.com>,
Baoquan He <baoquan.he@linux.dev>,
Baolin Wang <baolin.wang@linux.alibaba.com>,
Brendan Jackman <brendan.jackman@linux.dev>,
Johannes Weiner <hannes@cmpxchg.org>, Zi Yan <ziy@nvidia.com>,
Oscar Salvador <osalvador@suse.de>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
"Rafael J. Wysocki" <rafael@kernel.org>,
Danilo Krummrich <dakr@kernel.org>,
Jan Kiszka <jan.kiszka@siemens.com>,
Kieran Bingham <kbingham@kernel.org>,
linux-kernel@vger.kernel.org, linux-mm@kvack.org,
linux-cxl@vger.kernel.org, driver-core@lists.linux.dev,
linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH 02/12] mm/sparse: refactor sparse_sections_init()
Date: Thu, 10 Sep 2026 15:38:03 +0100 [thread overview]
Message-ID: <aqLAplL54O9rpM_Y@gremlin> (raw)
In-Reply-To: <44f7ce5c-b75c-4c44-9202-1d2d3a1de965@kernel.org>
On Thu, Sep 10, 2026 at 04:30:43PM +0200, David Hildenbrand (Arm) wrote:
> On 9/10/26 15:29, Lorenzo Stoakes (ARM) wrote:
> > On Wed, Sep 09, 2026 at 03:32:55PM +0200, David Hildenbrand (Arm) wrote:
> >> memory_present() really identifies+prepares all early sections so the
> >> initialization in sparse_init() can properly iterating them to
> >> initialize metadata.
> >>
> >> Let's just inline memory_present() into sparse_sections_init() and
> >> cleaning up the code a bit while at it: make it clear that we are operating
> >> on pfns.
> >>
> >> Note that we call set_section_nid() now only if the section
> >> was not already created earlier. Now, there is no more inconsistency
> >> between what we (temporarily) store in ms->section_mem_map and what
> >> we store in our section->nid array.
> >>
> >> Signed-off-by: David Hildenbrand (Arm) <david@kernel.org>
> >
> > In general please keep move/refactor steps separate. It makes it harder to
> > review when two things are going on at one time.
> >
> > But I guess in this case the diff wouldn't be that different.
>
> Yeah, I actually want back and forth here and decided to keep it simple.
Yeah, this one's a bit of a blurry line but I think fine as it is!
>
> >
> > Anyway seems reasonable so:
> >
> > Acked-by: Lorenzo Stoakes (ARM) <ljs@kernel.org>
>
> Thanks!
>
> >
> >> ---
> >> mm/sparse.c | 41 +++++++++++++++++------------------------
> >> 1 file changed, 17 insertions(+), 24 deletions(-)
> >>
> >> diff --git a/mm/sparse.c b/mm/sparse.c
> >> index 6a6d258862904..36e3d854febc5 100644
> >> --- a/mm/sparse.c
> >> +++ b/mm/sparse.c
> >> @@ -179,22 +179,27 @@ static inline unsigned long first_present_section_nr(void)
> >> return next_present_section_nr(-1);
> >> }
> >>
> >> -/* Record a memory area against a node. */
> >> -static void __init memory_present(int nid, unsigned long start, unsigned long end)
> >> +void __init sparse_sections_init(void)
> >> {
> >> - unsigned long pfn;
> >> + unsigned long pfn, start_pfn, end_pfn;
> >> + int i, nid;
> >> +
> >> + sparse_extreme_init();
> >>
> >> - start &= PAGE_SECTION_MASK;
> >> - mminit_validate_memmodel_limits(&start, &end);
> >> - for (pfn = start; pfn < end; pfn += PAGES_PER_SECTION) {
> >> - unsigned long section_nr = pfn_to_section_nr(pfn);
> >> - struct mem_section *ms;
> >> + for_each_mem_pfn_range(i, MAX_NUMNODES, &start_pfn, &end_pfn, &nid) {
> >> + start_pfn &= PAGE_SECTION_MASK;
> >> + mminit_validate_memmodel_limits(&start_pfn, &end_pfn);
> >>
> >> - sparse_index_init(section_nr, nid);
> >> - set_section_nid(section_nr, nid);
> >> + for (pfn = start_pfn; pfn < end_pfn; pfn += PAGES_PER_SECTION) {
> >> + unsigned long section_nr = pfn_to_section_nr(pfn);
> >> + struct mem_section *ms;
> >>
> >> - ms = __nr_to_section(section_nr);
> >> - if (!ms->section_mem_map) {
> >> + sparse_index_init(section_nr, nid);
> >> + ms = __nr_to_section(section_nr);
> >> + if (ms->section_mem_map)
> >> + continue;
> >> +
> >> + set_section_nid(section_nr, nid);
> >
> > So the main change seems to be calling set_section_nid() only if
> > !ms->section_mem_map (and obv. calculating ms earlier), as described in the
> > commit msg.
>
> Yes! I also played with having that in a standalone patch but judged that it's
> not really worth it. I can move it to a separate patch if you think it would be
> better!
No need, not really a big diff delta and you call it out in the commit msg!
>
> --
> Cheers,
>
> David
--
Cheers, Lorenzo
next prev parent reply other threads:[~2026-09-10 14:38 UTC|newest]
Thread overview: 51+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-09 13:32 [PATCH 00/12] mm/sparse: remove SECTION_MARKED_PRESENT and further cleanups David Hildenbrand (Arm)
2026-09-09 13:32 ` [PATCH 01/12] mm/sparse: move mem_section init to sparse_extreme_init() David Hildenbrand (Arm)
2026-09-09 17:02 ` Oscar Salvador (SUSE)
2026-09-10 12:52 ` Lorenzo Stoakes (ARM)
2026-09-10 13:13 ` David Hildenbrand (Arm)
2026-09-10 13:33 ` Lorenzo Stoakes (ARM)
2026-09-09 13:32 ` [PATCH 02/12] mm/sparse: refactor sparse_sections_init() David Hildenbrand (Arm)
2026-09-09 17:09 ` Oscar Salvador (SUSE)
2026-09-09 17:18 ` David Hildenbrand (Arm)
2026-09-10 13:29 ` Lorenzo Stoakes (ARM)
2026-09-10 14:30 ` David Hildenbrand (Arm)
2026-09-10 14:38 ` Lorenzo Stoakes (ARM) [this message]
2026-09-09 13:32 ` [PATCH 03/12] mm/sparse: move initialization of section metadata to sparse_metadata_init() David Hildenbrand (Arm)
2026-09-09 17:22 ` Oscar Salvador (SUSE)
2026-09-10 13:43 ` Lorenzo Stoakes (ARM)
2026-09-09 13:32 ` [PATCH 04/12] mm/sparse: rename and cleanup sparse_init_nid() David Hildenbrand (Arm)
2026-09-10 7:41 ` Oscar Salvador (SUSE)
2026-09-10 13:46 ` Lorenzo Stoakes (ARM)
2026-09-10 14:29 ` David Hildenbrand (Arm)
2026-09-09 13:32 ` [PATCH 05/12] mm/sparse: cleanup sparse_init_one_section() David Hildenbrand (Arm)
2026-09-10 7:45 ` Oscar Salvador (SUSE)
2026-09-10 13:47 ` Lorenzo Stoakes (ARM)
2026-09-09 13:32 ` [PATCH 06/12] mm/sparse: rename __highest_present_section_nr to __highest_used_section_nr David Hildenbrand (Arm)
2026-09-10 7:56 ` Oscar Salvador (SUSE)
2026-09-10 13:49 ` Lorenzo Stoakes (ARM)
2026-09-09 13:33 ` [PATCH 07/12] mm/sparse: remove pfn_in_present_section() David Hildenbrand (Arm)
2026-09-10 7:59 ` Oscar Salvador (SUSE)
2026-09-10 13:50 ` Lorenzo Stoakes (ARM)
2026-09-09 13:33 ` [PATCH 08/12] mm/sparse: move __highest_used_section_nr handling David Hildenbrand (Arm)
2026-09-09 14:44 ` David Hildenbrand (Arm)
2026-09-10 8:33 ` Oscar Salvador (SUSE)
2026-09-10 9:13 ` David Hildenbrand (Arm)
2026-09-10 12:08 ` Oscar Salvador (SUSE)
2026-09-10 13:33 ` David Hildenbrand (Arm)
2026-09-10 14:16 ` Lorenzo Stoakes (ARM)
2026-09-10 14:29 ` David Hildenbrand (Arm)
2026-09-10 14:51 ` Lorenzo Stoakes (ARM)
2026-09-09 13:33 ` [PATCH 09/12] mm/sparse: remove SECTION_MARKED_PRESENT David Hildenbrand (Arm)
2026-09-10 12:15 ` Oscar Salvador (SUSE)
2026-09-10 14:32 ` Lorenzo Stoakes (ARM)
2026-09-10 15:11 ` David Hildenbrand (Arm)
2026-09-09 13:33 ` [PATCH 10/12] mm/sparse: remove flags parameter from sparse_init_one_section() David Hildenbrand (Arm)
2026-09-10 12:34 ` Oscar Salvador (SUSE)
2026-09-10 14:34 ` Lorenzo Stoakes (ARM)
2026-09-09 13:33 ` [PATCH 11/12] fs/proc/page: clarify comment in get_max_dump_pfn() David Hildenbrand (Arm)
2026-09-10 12:46 ` Oscar Salvador (SUSE)
2026-09-10 14:41 ` Lorenzo Stoakes (ARM)
2026-09-10 15:14 ` David Hildenbrand (Arm)
2026-09-09 13:33 ` [PATCH 12/12] mm/memory_hotplug: drop CONFIG_HAVE_ARCH_PFN_VALID handling from pfn_to_online_page() David Hildenbrand (Arm)
2026-09-10 14:47 ` Lorenzo Stoakes (ARM)
2026-09-10 15:15 ` David Hildenbrand (Arm)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aqLAplL54O9rpM_Y@gremlin \
--to=ljs@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=axelrasmussen@google.com \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=baoquan.he@linux.dev \
--cc=brendan.jackman@linux.dev \
--cc=dakr@kernel.org \
--cc=david@kernel.org \
--cc=driver-core@lists.linux.dev \
--cc=gregkh@linuxfoundation.org \
--cc=hannes@cmpxchg.org \
--cc=jan.kiszka@siemens.com \
--cc=kasong@tencent.com \
--cc=kbingham@kernel.org \
--cc=liam@infradead.org \
--cc=linux-cxl@vger.kernel.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mhocko@suse.com \
--cc=osalvador@suse.de \
--cc=qi.zheng@linux.dev \
--cc=rafael@kernel.org \
--cc=rppt@kernel.org \
--cc=shakeel.butt@linux.dev \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
--cc=weixugc@google.com \
--cc=yuanchu@google.com \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®