* [PATCH] eventpoll: return -ENOIOCTLCMD for unknown ioctl commands
@ 2026-09-24 18:57 hengyul
2026-09-24 21:59 ` Joe Damato
0 siblings, 1 reply; 2+ messages in thread
From: hengyul @ 2026-09-24 18:57 UTC (permalink / raw)
To: brauner, viro
Cc: jack, joe, jirislaby, sdf, edumazet, kuba, davem, pabeni, horms,
shuah, linux-fsdevel, netdev, linux-kselftest, linux-kernel,
Hengyu Liang
From: Hengyu Liang <hengyul@cs.unc.edu>
Before commit 18e2bf0edf4d ("eventpoll: Add epoll ioctl for
epoll_params"), epoll files had no ioctl handler, so ioctl() on an epoll
file descriptor failed with ENOTTY. That commit introduced the
EPIOCSPARAMS and EPIOCGPARAMS commands, but ep_eventpoll_ioctl() returns
-EINVAL for any other command, so since v6.9 every other ioctl() on an
epoll file descriptor fails with EINVAL instead of ENOTTY.
Documentation/driver-api/ioctl.rst says that an ioctl handler must
return -ENOTTY or -ENOIOCTLCMD for an unknown command, and that
returning -EINVAL there is wrong. Returning -ENOIOCTLCMD was also the
intent of the original series, whose changelog since v3 [1] says "when
an unknown ioctl is received, -ENOIOCTLCMD is returned instead of
-EINVAL as the ioctl documentation requires", and ep_eventpoll_bp_ioctl()
does return -ENOIOCTLCMD for unknown commands. However,
ep_eventpoll_ioctl() only passes EPIOCSPARAMS and EPIOCGPARAMS to it and
handles all other commands in its own default case, which returns
-EINVAL, so that path is never reached.
This is visible to userspace. For example, isatty(), ttyname() and
tcgetattr() on an epoll file descriptor set errno to EINVAL, while they
set ENOTTY for any other file descriptor that does not refer to a
terminal, as they also did for epoll file descriptors before v6.9.
Return -ENOIOCTLCMD from the default case, which the VFS turns into
-ENOTTY, and update the epoll_busy_poll selftest, which expected EINVAL
for an unknown command.
[1] https://lore.kernel.org/r/20240125225704.12781-1-jdamato@fastly.com
Fixes: 18e2bf0edf4d ("eventpoll: Add epoll ioctl for epoll_params")
Signed-off-by: Hengyu Liang <hengyul@cs.unc.edu>
---
fs/eventpoll.c | 2 +-
tools/testing/selftests/net/epoll_busy_poll.c | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/fs/eventpoll.c b/fs/eventpoll.c
index e0c4bf88a838..adf30b720b13 100644
--- a/fs/eventpoll.c
+++ b/fs/eventpoll.c
@@ -1264,7 +1264,7 @@ static long ep_eventpoll_ioctl(struct file *file, unsigned int cmd,
ret = ep_eventpoll_bp_ioctl(file, cmd, arg);
break;
default:
- ret = -EINVAL;
+ ret = -ENOIOCTLCMD;
break;
}
diff --git a/tools/testing/selftests/net/epoll_busy_poll.c b/tools/testing/selftests/net/epoll_busy_poll.c
index adf8dd0b5e0b..6b0b3213ffad 100644
--- a/tools/testing/selftests/net/epoll_busy_poll.c
+++ b/tools/testing/selftests/net/epoll_busy_poll.c
@@ -313,8 +313,8 @@ TEST_F(epoll_busy_poll, test_invalid_ioctl)
EXPECT_EQ(-1, ret)
TH_LOG("invalid ioctl should return error");
- EXPECT_EQ(EINVAL, errno)
- TH_LOG("invalid ioctl should set errno to EINVAL");
+ EXPECT_EQ(ENOTTY, errno)
+ TH_LOG("invalid ioctl should set errno to ENOTTY");
}
TEST_HARNESS_MAIN
--
2.53.0
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] eventpoll: return -ENOIOCTLCMD for unknown ioctl commands
2026-09-24 18:57 [PATCH] eventpoll: return -ENOIOCTLCMD for unknown ioctl commands hengyul
@ 2026-09-24 21:59 ` Joe Damato
0 siblings, 0 replies; 2+ messages in thread
From: Joe Damato @ 2026-09-24 21:59 UTC (permalink / raw)
To: hengyul
Cc: brauner, viro, jack, jirislaby, sdf, edumazet, kuba, davem,
pabeni, horms, shuah, linux-fsdevel, netdev, linux-kselftest,
linux-kernel
On Thu, Sep 24, 2026 at 02:57:47PM -0400, hengyul@cs.unc.edu wrote:
> From: Hengyu Liang <hengyul@cs.unc.edu>
>
> Before commit 18e2bf0edf4d ("eventpoll: Add epoll ioctl for
> epoll_params"), epoll files had no ioctl handler, so ioctl() on an epoll
> file descriptor failed with ENOTTY. That commit introduced the
> EPIOCSPARAMS and EPIOCGPARAMS commands, but ep_eventpoll_ioctl() returns
> -EINVAL for any other command, so since v6.9 every other ioctl() on an
> epoll file descriptor fails with EINVAL instead of ENOTTY.
>
> Documentation/driver-api/ioctl.rst says that an ioctl handler must
> return -ENOTTY or -ENOIOCTLCMD for an unknown command, and that
> returning -EINVAL there is wrong. Returning -ENOIOCTLCMD was also the
> intent of the original series, whose changelog since v3 [1] says "when
> an unknown ioctl is received, -ENOIOCTLCMD is returned instead of
> -EINVAL as the ioctl documentation requires", and ep_eventpoll_bp_ioctl()
> does return -ENOIOCTLCMD for unknown commands. However,
> ep_eventpoll_ioctl() only passes EPIOCSPARAMS and EPIOCGPARAMS to it and
> handles all other commands in its own default case, which returns
> -EINVAL, so that path is never reached.
>
> This is visible to userspace. For example, isatty(), ttyname() and
> tcgetattr() on an epoll file descriptor set errno to EINVAL, while they
> set ENOTTY for any other file descriptor that does not refer to a
> terminal, as they also did for epoll file descriptors before v6.9.
>
> Return -ENOIOCTLCMD from the default case, which the VFS turns into
> -ENOTTY, and update the epoll_busy_poll selftest, which expected EINVAL
> for an unknown command.
>
> [1] https://lore.kernel.org/r/20240125225704.12781-1-jdamato@fastly.com
>
> Fixes: 18e2bf0edf4d ("eventpoll: Add epoll ioctl for epoll_params")
> Signed-off-by: Hengyu Liang <hengyul@cs.unc.edu>
> ---
> fs/eventpoll.c | 2 +-
> tools/testing/selftests/net/epoll_busy_poll.c | 4 ++--
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/fs/eventpoll.c b/fs/eventpoll.c
> index e0c4bf88a838..adf30b720b13 100644
> --- a/fs/eventpoll.c
> +++ b/fs/eventpoll.c
> @@ -1264,7 +1264,7 @@ static long ep_eventpoll_ioctl(struct file *file, unsigned int cmd,
> ret = ep_eventpoll_bp_ioctl(file, cmd, arg);
> break;
> default:
> - ret = -EINVAL;
> + ret = -ENOIOCTLCMD;
> break;
> }
I think based on the documentation this is probably right, but I am now
wondering why both ep_eventpoll_ioctl and ep_eventpoll_bp_ioctl need to
exist.
Maybe when I first implemented this I thought it made sense to factor
out the busy poll ioctls into their own function, but in retrospect maybe it's
cleaner to just collapse the ioctl function into a single one instead of
having two layers?
In other words, maybe:
- delete ep_eventpoll_ioctl
- add the is_file_epoll check to ep_eventpoll_bp_ioctl
- rename ep_eventpoll_bp_ioctl to ep_eventpoll_ioctl
- fix the test (as you did in this version of the patch)
Would result in a cleaner fewer helpers / cleaner code ?
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-09-24 21:59 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-09-24 18:57 [PATCH] eventpoll: return -ENOIOCTLCMD for unknown ioctl commands hengyul
2026-09-24 21:59 ` Joe Damato
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®