From: Jens Axboe <axboe@kernel.dk>
To: Thomas Gleixner <tglx@linutronix.de>,
Nam Cao <namcao@linutronix.de>,
Anna-Maria Behnsen <anna-maria@linutronix.de>,
Frederic Weisbecker <frederic@kernel.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] hrtimers: Make hrtimer_update_function() less expensive
Date: Sat, 8 Feb 2025 08:18:36 -0700 [thread overview]
Message-ID: <b6f4b197-becb-4150-8986-2c568f7e738c@kernel.dk> (raw)
In-Reply-To: <87ikpllali.ffs@tglx>
On 2/7/25 2:16 PM, Thomas Gleixner wrote:
> The sanity checks in hrtimer_update_function() are expensive for high
> frequency usage like in the io/uring code due to locking.
>
> Hide the sanity checks behind CONFIG_PROVE_LOCKING, which has a decent
> chance to be enabled on a regular basis for testing.
Looks good to me, thanks Thomas. On my side, I always have a debug run
done with PROVE_LOCKING and KASAN, fwiw.
--
Jens Axboe
next prev parent reply other threads:[~2025-02-08 15:18 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-05 10:55 [PATCH v2 00/12] Consolidate hrtimer initialization - Part 5 Nam Cao
2025-02-05 10:55 ` [PATCH v2 01/12] hrtimers: Delete hrtimer_init() Nam Cao
2025-02-05 10:55 ` [PATCH v2 02/12] hrtimers: Switch to use __htimer_setup() Nam Cao
2025-02-05 10:55 ` [PATCH v2 03/12] hrtimers: Merge __hrtimer_init() into __hrtimer_setup() Nam Cao
2025-02-05 10:55 ` [PATCH v2 04/12] serial: xilinx_uartps: Use helper function hrtimer_update_function() Nam Cao
2025-02-05 10:55 ` [PATCH v2 05/12] io_uring: " Nam Cao
2025-02-05 18:45 ` Jens Axboe
2025-02-06 16:18 ` Thomas Gleixner
2025-02-06 20:05 ` Jens Axboe
2025-02-06 21:48 ` Thomas Gleixner
2025-02-07 17:46 ` Jens Axboe
2025-02-07 21:16 ` [PATCH] hrtimers: Make hrtimer_update_function() less expensive Thomas Gleixner
2025-02-08 15:18 ` Jens Axboe [this message]
2025-02-10 19:52 ` Thomas Gleixner
2025-02-10 19:56 ` Jens Axboe
2025-02-10 20:05 ` [tip: timers/core] " tip-bot2 for Thomas Gleixner
2025-02-05 10:55 ` [PATCH v2 06/12] wifi: rt2x00: Switch to use hrtimer_update_function() Nam Cao
2025-02-05 10:55 ` [PATCH v2 07/12] hrtimers: Make callback function pointer private Nam Cao
2025-02-05 10:55 ` [PATCH v2 08/12] hrtimers: Remove unnecessary NULL check in hrtimer_start_range_ns() Nam Cao
2025-02-05 10:55 ` [PATCH v2 09/12] hrtimers: Rename __hrtimer_init_sleeper() to __hrtimer_setup_sleeper() Nam Cao
2025-02-05 10:55 ` [PATCH v2 10/12] hrtimers: Rename debug_init() to debug_setup() Nam Cao
2025-02-05 10:55 ` [PATCH v2 11/12] hrtimers: Rename debug_init_on_stack() to debug_setup_on_stack() Nam Cao
2025-02-05 10:55 ` [PATCH v2 12/12] tracing/timers: Rename hrtimer_init event to hrtimer_setup Nam Cao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b6f4b197-becb-4150-8986-2c568f7e738c@kernel.dk \
--to=axboe@kernel.dk \
--cc=anna-maria@linutronix.de \
--cc=frederic@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=namcao@linutronix.de \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®