mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Nam Cao <namcao@linutronix.de>
To: Anna-Maria Behnsen <anna-maria@linutronix.de>,
	Frederic Weisbecker <frederic@kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	linux-kernel@vger.kernel.org
Cc: Nam Cao <namcao@linutronix.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Jens Axboe <axboe@kernel.dk>, Kalle Valo <kvalo@kernel.org>,
	Steven Rostedt <rostedt@goodmis.org>
Subject: [PATCH v2 00/12] Consolidate hrtimer initialization - Part 5
Date: Wed,  5 Feb 2025 11:55:09 +0100	[thread overview]
Message-ID: <cover.1738746927.git.namcao@linutronix.de> (raw)

All previous users of hrtimer_init() have been converted to use hrtimer_setup()
in the previous series:

  https://lore.kernel.org/lkml/cover.1738746821.git.namcao@linutronix.de
  https://lore.kernel.org/lkml/cover.1738746872.git.namcao@linutronix.de
  https://lore.kernel.org/lkml/cover.1738746904.git.namcao@linutronix.de


This series does the final cleanup:

  - Delete hrtimer_init()
  - Convert users who touch hrtimer::function to use hrtimer_update_function().
    Make hrtimer::function private afterward.
  - Rename the remaining *hrtimer_init*() to *hrtimer_setup*() to keep the
    names consistent

v1 -> v2 https://lore.kernel.org/lkml/cover.1729865740.git.namcao@linutronix.de
  - rebaes onto v6.14-rc1
---
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Jens Axboe <axboe@kernel.dk>
Cc: Kalle Valo <kvalo@kernel.org>
Cc: Steven Rostedt <rostedt@goodmis.org>
---
 Documentation/trace/ftrace.rst                |  4 +-
 .../net/wireless/ralink/rt2x00/rt2800mmio.c   |  2 +-
 .../net/wireless/ralink/rt2x00/rt2800usb.c    |  2 +-
 drivers/tty/serial/xilinx_uartps.c            |  4 +-
 include/linux/hrtimer.h                       |  4 +-
 include/linux/hrtimer_types.h                 |  4 +-
 include/trace/events/timer.h                  |  8 +--
 io_uring/io_uring.c                           |  2 +-
 kernel/time/hrtimer.c                         | 69 +++++--------------
 kernel/time/timer_list.c                      |  2 +-
 tools/perf/tests/shell/trace_btf_enum.sh      |  2 +-
 11 files changed, 35 insertions(+), 68 deletions(-)

-- 
2.39.5


             reply	other threads:[~2025-02-05 10:55 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-05 10:55 Nam Cao [this message]
2025-02-05 10:55 ` [PATCH v2 01/12] hrtimers: Delete hrtimer_init() Nam Cao
2025-02-05 10:55 ` [PATCH v2 02/12] hrtimers: Switch to use __htimer_setup() Nam Cao
2025-02-05 10:55 ` [PATCH v2 03/12] hrtimers: Merge __hrtimer_init() into __hrtimer_setup() Nam Cao
2025-02-05 10:55 ` [PATCH v2 04/12] serial: xilinx_uartps: Use helper function hrtimer_update_function() Nam Cao
2025-02-05 10:55 ` [PATCH v2 05/12] io_uring: " Nam Cao
2025-02-05 18:45   ` Jens Axboe
2025-02-06 16:18     ` Thomas Gleixner
2025-02-06 20:05       ` Jens Axboe
2025-02-06 21:48         ` Thomas Gleixner
2025-02-07 17:46           ` Jens Axboe
2025-02-07 21:16             ` [PATCH] hrtimers: Make hrtimer_update_function() less expensive Thomas Gleixner
2025-02-08 15:18               ` Jens Axboe
2025-02-10 19:52                 ` Thomas Gleixner
2025-02-10 19:56                   ` Jens Axboe
2025-02-10 20:05               ` [tip: timers/core] " tip-bot2 for Thomas Gleixner
2025-02-05 10:55 ` [PATCH v2 06/12] wifi: rt2x00: Switch to use hrtimer_update_function() Nam Cao
2025-02-05 10:55 ` [PATCH v2 07/12] hrtimers: Make callback function pointer private Nam Cao
2025-02-05 10:55 ` [PATCH v2 08/12] hrtimers: Remove unnecessary NULL check in hrtimer_start_range_ns() Nam Cao
2025-02-05 10:55 ` [PATCH v2 09/12] hrtimers: Rename __hrtimer_init_sleeper() to __hrtimer_setup_sleeper() Nam Cao
2025-02-05 10:55 ` [PATCH v2 10/12] hrtimers: Rename debug_init() to debug_setup() Nam Cao
2025-02-05 10:55 ` [PATCH v2 11/12] hrtimers: Rename debug_init_on_stack() to debug_setup_on_stack() Nam Cao
2025-02-05 10:55 ` [PATCH v2 12/12] tracing/timers: Rename hrtimer_init event to hrtimer_setup Nam Cao

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover.1738746927.git.namcao@linutronix.de \
    --to=namcao@linutronix.de \
    --cc=anna-maria@linutronix.de \
    --cc=axboe@kernel.dk \
    --cc=frederic@kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=kvalo@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rostedt@goodmis.org \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®