From: Ravi Bangoria <ravi.bangoria@linux.ibm.com>
To: Christophe Leroy <christophe.leroy@c-s.fr>
Cc: mpe@ellerman.id.au, mikey@neuling.org, apopple@linux.ibm.com,
paulus@samba.org, npiggin@gmail.com,
naveen.n.rao@linux.vnet.ibm.com, peterz@infradead.org,
jolsa@kernel.org, oleg@redhat.com, fweisbec@gmail.com,
mingo@kernel.org, linuxppc-dev@lists.ozlabs.org,
linux-kernel@vger.kernel.org,
Ravi Bangoria <ravi.bangoria@linux.ibm.com>
Subject: Re: [PATCH v2 03/16] powerpc/watchpoint: Introduce function to get nr watchpoints dynamically
Date: Wed, 1 Apr 2020 12:20:03 +0530 [thread overview]
Message-ID: <b6ff59ce-8251-c50f-1c0e-b1f54fccb09f@linux.ibm.com> (raw)
In-Reply-To: <7851b702-8a93-11a8-6553-e0a51967dfc0@c-s.fr>
On 4/1/20 11:59 AM, Christophe Leroy wrote:
>
>
> Le 01/04/2020 à 08:12, Ravi Bangoria a écrit :
>> So far we had only one watchpoint, so we have hardcoded HBP_NUM to 1.
>> But future Power architecture is introducing 2nd DAWR and thus kernel
>> should be able to dynamically find actual number of watchpoints
>> supported by hw it's running on. Introduce function for the same.
>> Also convert HBP_NUM macro to HBP_NUM_MAX, which will now represent
>> maximum number of watchpoints supported by Powerpc.
>
>
> Everywhere else in the code, it is called 'breakpoint', not 'watchpoint'.
>
> Wouldn't it be more consistent to call the function nr_bp_slots() instead of nr_wp_slots() ?
>
> Especially as we are likely going to extend your changes to support DABR2 in addition to DABR on BOOK3S/32.
Sure. I don't have strong onion for nr_wp_slots() and I can rename it to
nr_bp_slots(). but...
Even though existing code uses breakpoint and watchpoint interchangeably,
I'm using wp/watchpoint to represent data-breakpoint, to distinguish it
from instruction-breakpoint (CIABR). So IMHO, nr_wp_slots() should return
number DAWRs/DABRs and nr_bp_slots() should return number of CIABRs. Is
that okay?
Ravi
next prev parent reply other threads:[~2020-04-01 6:50 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-01 6:12 [PATCH v2 00/16] powerpc/watchpoint: Preparation for more than one watchpoint Ravi Bangoria
2020-04-01 6:12 ` [PATCH v2 01/16] powerpc/watchpoint: Rename current DAWR macros Ravi Bangoria
2020-04-01 6:12 ` [PATCH v2 02/16] powerpc/watchpoint: Add SPRN macros for second DAWR Ravi Bangoria
2020-04-01 6:12 ` [PATCH v2 03/16] powerpc/watchpoint: Introduce function to get nr watchpoints dynamically Ravi Bangoria
2020-04-01 6:29 ` Christophe Leroy
2020-04-01 6:50 ` Ravi Bangoria [this message]
2020-04-01 7:05 ` Christophe Leroy
2020-04-01 6:12 ` [PATCH v2 04/16] powerpc/watchpoint/ptrace: Return actual num of available watchpoints Ravi Bangoria
2020-04-01 6:12 ` [PATCH v2 05/16] powerpc/watchpoint: Provide DAWR number to set_dawr Ravi Bangoria
2020-04-01 7:03 ` Christophe Leroy
2020-04-01 6:12 ` [PATCH v2 06/16] powerpc/watchpoint: Provide DAWR number to __set_breakpoint Ravi Bangoria
2020-04-01 7:03 ` Christophe Leroy
2020-04-01 8:57 ` Ravi Bangoria
2020-04-01 9:11 ` Christophe Leroy
2020-04-01 9:44 ` Christophe Leroy
2020-04-01 6:13 ` [PATCH v2 07/16] powerpc/watchpoint: Get watchpoint count dynamically while disabling them Ravi Bangoria
2020-04-01 6:32 ` Christophe Leroy
2020-04-01 9:19 ` Ravi Bangoria
2020-04-01 6:13 ` [PATCH v2 08/16] powerpc/watchpoint: Disable all available watchpoints when !dawr_force_enable Ravi Bangoria
2020-04-01 6:33 ` Christophe Leroy
2020-04-01 9:00 ` Ravi Bangoria
2020-04-01 6:13 ` [PATCH v2 09/16] powerpc/watchpoint: Convert thread_struct->hw_brk to an array Ravi Bangoria
2020-04-01 6:43 ` Christophe Leroy
2020-04-01 9:06 ` Ravi Bangoria
2020-04-01 6:13 ` [PATCH v2 10/16] powerpc/watchpoint: Use loop for thread_struct->ptrace_bps Ravi Bangoria
2020-04-01 6:13 ` [PATCH v2 11/16] powerpc/watchpoint: Introduce is_ptrace_bp() function Ravi Bangoria
2020-04-01 6:13 ` [PATCH v2 12/16] powerpc/watchpoint: Use builtin ALIGN*() macros Ravi Bangoria
2020-04-01 6:13 ` [PATCH v2 13/16] powerpc/watchpoint: Prepare handler to handle more than one watcnhpoint Ravi Bangoria
2020-04-01 6:50 ` Christophe Leroy
2020-04-01 9:13 ` Ravi Bangoria
2020-04-01 9:20 ` Christophe Leroy
2020-04-01 9:23 ` Ravi Bangoria
2020-04-01 6:13 ` [PATCH v2 14/16] powerpc/watchpoint: Don't allow concurrent perf and ptrace events Ravi Bangoria
2020-04-01 6:52 ` Christophe Leroy
2020-04-01 6:13 ` [PATCH v2 15/16] powerpc/watchpoint/xmon: Don't allow breakpoint overwriting Ravi Bangoria
2020-04-01 6:13 ` [PATCH v2 16/16] powerpc/watchpoint/xmon: Support 2nd dawr Ravi Bangoria
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b6ff59ce-8251-c50f-1c0e-b1f54fccb09f@linux.ibm.com \
--to=ravi.bangoria@linux.ibm.com \
--cc=apopple@linux.ibm.com \
--cc=christophe.leroy@c-s.fr \
--cc=fweisbec@gmail.com \
--cc=jolsa@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=mikey@neuling.org \
--cc=mingo@kernel.org \
--cc=mpe@ellerman.id.au \
--cc=naveen.n.rao@linux.vnet.ibm.com \
--cc=npiggin@gmail.com \
--cc=oleg@redhat.com \
--cc=paulus@samba.org \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome