mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Gustavo Pimentel <gustavo.pimentel@synopsys.com>
To: Fabio Estevam <festevam@gmail.com>
Cc: Jingoo Han <jingoohan1@gmail.com>,
	"bhelgaas@google.com" <bhelgaas@google.com>,
	"lorenzo.pieralisi@arm.com" <lorenzo.pieralisi@arm.com>,
	"Joao.Pinto@synopsys.com" <Joao.Pinto@synopsys.com>,
	"kishon@ti.com" <kishon@ti.com>,
	"robh+dt@kernel.org" <robh+dt@kernel.org>,
	"mark.rutland@arm.com" <mark.rutland@arm.com>,
	"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>
Subject: Re: [PATCH v2 8/9] PCI: dwc: Small computation improvement
Date: Mon, 16 Apr 2018 09:35:55 +0100	[thread overview]
Message-ID: <b8f10ee2-b580-9d49-247f-6c65804816c4@synopsys.com> (raw)
In-Reply-To: <CAOMZO5Acd-5ed_FivBf=GMmKLxipnossDtG4ptzq5-LzcNBhjA@mail.gmail.com>

Hi Fabio,

On 15/04/2018 14:09, Fabio Estevam wrote:
> Hi Gustavo,
> 
> On Wed, Apr 11, 2018 at 4:40 AM, Gustavo Pimentel
> <gustavo.pimentel@synopsys.com> wrote:
> 
>> Can be this one?
>>
>> Probably any recent and decent compiler does this kind of substitution
>> in order to improve code performance. Nevertheless it's a coding good
>> practice whenever there is a division / multiplication by multiple of 2
>> to replace it by the equivalent operation in this case, the shift
>> rotation.
> 
> Subject says that this patch provides a computation improvement, but
> as you said above the compiler
> will perform the shift, so it doesn't seem we will get any benefit.

In the worth case there is no performance, so it will not hurt having it.
However depending the compiler and the platform this can bring some improvement.
For instance like Jingoo said: "The most platforms using 'dwc' are based on ARM
CPUs. So, the shift rotation can be better."

It's just a attempt to improve the code that doesn't bring any harm.

> 
> IMHO the original code has better readability as it makes easier to
> understand that pp->cfg0_size will get the half of
> resource_size(pp->cfg) size.

Personally I prefer the shift rotation rather the division by 2. But in my case
I'm used to use/see this type of operation, but it's like I said it's my
personal opinion.

> 
> I would say it is better to drop this patch from the series.

Let's see this patch inflicts pain on someone else, in that case I'll remove
from the series.

> 
> Thanks
> 

Regards,
Gustavo

  reply	other threads:[~2018-04-16  8:37 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-09  9:41 [PATCH v2 0/9] Designware EP support and code clean up Gustavo Pimentel
2018-04-09  9:41 ` [PATCH v2 1/9] bindings: PCI: designware: Example update Gustavo Pimentel
2018-04-09  9:41 ` [PATCH v2 2/9] PCI: dwc: Add support for endpoint mode Gustavo Pimentel
2018-04-10  5:12   ` Kishon Vijay Abraham I
2018-04-10 10:36     ` Gustavo Pimentel
2018-04-10 11:09       ` Kishon Vijay Abraham I
2018-04-09  9:41 ` [PATCH v2 3/9] bindings: PCI: designware: Add support for the EP in Designware driver Gustavo Pimentel
2018-04-09  9:41 ` [PATCH v2 4/9] PCI: Adds device ID for Synopsys Sample Endpoint Gustavo Pimentel
2018-04-09  9:41 ` [PATCH v2 5/9] misc: pci_endpoint_test: Add designware EP entry Gustavo Pimentel
2018-04-09  9:41 ` [PATCH v2 6/9] PCI: dwc: Define maximum number of vectors Gustavo Pimentel
2018-04-09 16:03   ` Lorenzo Pieralisi
2018-04-10  7:59     ` Gustavo Pimentel
2018-04-10  9:56       ` Lorenzo Pieralisi
2018-04-09  9:41 ` [PATCH v2 7/9] PCI: dwc: Replace lower into upper case characters Gustavo Pimentel
2018-04-09 10:25   ` Joe Perches
2018-04-09 13:10     ` Gustavo Pimentel
2018-04-09 14:25       ` Joe Perches
2018-04-11  0:05   ` Jingoo Han
2018-04-09  9:41 ` [PATCH v2 8/9] PCI: dwc: Small computation improvement Gustavo Pimentel
2018-04-11  0:01   ` Jingoo Han
2018-04-11  7:40     ` Gustavo Pimentel
2018-04-11 19:37       ` Jingoo Han
2018-04-16  8:41         ` Gustavo Pimentel
2018-04-15 13:09       ` Fabio Estevam
2018-04-16  8:35         ` Gustavo Pimentel [this message]
2018-04-09  9:41 ` [PATCH v2 9/9] PCI: dwc: Replace magic number by defines Gustavo Pimentel
2018-04-11  0:07   ` Jingoo Han

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b8f10ee2-b580-9d49-247f-6c65804816c4@synopsys.com \
    --to=gustavo.pimentel@synopsys.com \
    --cc=Joao.Pinto@synopsys.com \
    --cc=bhelgaas@google.com \
    --cc=devicetree@vger.kernel.org \
    --cc=festevam@gmail.com \
    --cc=jingoohan1@gmail.com \
    --cc=kishon@ti.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lorenzo.pieralisi@arm.com \
    --cc=mark.rutland@arm.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®