From: Hans Zhang <18255117159@163.com>
To: Arnd Bergmann <arnd@arndb.de>, Niklas Cassel <cassel@kernel.org>
Cc: "Manivannan Sadhasivam" <manivannan.sadhasivam@linaro.org>,
"Krzysztof Wilczyński" <kw@linux.com>,
"Kishon Vijay Abraham I" <kishon@kernel.org>,
"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org,
rockswang7@gmail.com
Subject: Re: [v8] misc: pci_endpoint_test: Fix overflow of bar_size
Date: Thu, 9 Jan 2025 17:19:23 +0800 [thread overview]
Message-ID: <bcb4e21c-f7e9-4b5e-8712-9ab462bdf46c@163.com> (raw)
In-Reply-To: <2b6eabad-ebd1-4e7d-b4bf-6b818dfc20ac@app.fastmail.com>
On 2025/1/9 14:29, Arnd Bergmann wrote:
>> On 2025/1/8 22:13, Niklas Cassel wrote:
>>>>> Ok. Looking at do_div(), it seems to be the correct API to use
>>>>> for this problem. Just change bar_size type to u64 (instead of casting)
>>>>> and use do_div() ? That is how it is seems to be used in other drivers.
>>>>
>>>> I think using div_u64_rem() instead of do_div() would make this
>>>> more readable as this is always an inline function, so the type can
>>>> remain resource_size_t, and the division gets optimized well when
>>>> that is a 32-bit type.
>>>
>>> After patch 1/2, we no longer care about the remainder, so I guess
>>> div64_u64() is the correct function to use then?
>
> div_u64() is the correct interface here, div64_u64() is the
> even slower version where both arguments are 64-bit wide.
>
>> >> drivers/misc/pci_endpoint_test.c:311:11: warning: comparison of
>> distinct pointer types ('typeof ((bar_size)) *' (aka 'unsigned int *')
>> and 'uint64_t *' (aka 'unsigned long long *'))
>> [-Wcompare-distinct-pointer-types]
>> 311 | remain = do_div(bar_size, buf_size);
>> | ^~~~~~~~~~~~~~~~~~~~~~~~~~
>
> You don't use div_u64() or div64_u64() here, do_div() is the macro
> version that must be called with a 64-bit argument.
>
> Arnd
Thank you so much Niklas and Arnd.
Best regards
Hans
prev parent reply other threads:[~2025-01-09 9:19 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-04 15:16 Hans Zhang
2025-01-06 11:49 ` Niklas Cassel
2025-01-06 13:56 ` Hans Zhang
2025-01-06 15:32 ` Hans Zhang
2025-01-07 10:32 ` Niklas Cassel
2025-01-07 11:27 ` Hans Zhang
2025-01-07 11:33 ` Niklas Cassel
2025-01-07 11:43 ` Hans Zhang
2025-01-07 11:47 ` Niklas Cassel
2025-01-07 12:09 ` Hans Zhang
2025-01-07 13:36 ` Niklas Cassel
2025-01-07 15:44 ` Hans Zhang
2025-01-07 15:57 ` Niklas Cassel
2025-01-07 16:12 ` Hans Zhang
2025-01-08 14:10 ` Arnd Bergmann
2025-01-08 14:13 ` Niklas Cassel
2025-01-09 2:59 ` Hans Zhang
2025-01-09 6:29 ` Arnd Bergmann
2025-01-09 9:19 ` Hans Zhang [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=bcb4e21c-f7e9-4b5e-8712-9ab462bdf46c@163.com \
--to=18255117159@163.com \
--cc=arnd@arndb.de \
--cc=cassel@kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=kishon@kernel.org \
--cc=kw@linux.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=manivannan.sadhasivam@linaro.org \
--cc=rockswang7@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®